Ubuntu

Wireless is disabled on boot

Reported by Michael Mulqueen on 2010-09-06
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
bcmwl (Ubuntu)
Undecided
Unassigned

Bug Description

Ubuntu Maverick
bcmwl-kernel-source 5.60.48.36+bdcom-0ubuntu5

When I boot and then log in, wireless does not connect. If I then use nm-applet, I see that wireless is disabled and also impossible to enable (greyed out).

The only way I have found to fix this is to open up jockey-gtk, remove Broadcom STA and then activate Broadcom STA. This is forgotten after every single boot, so I have to go through this 3 - 5 minute process every time I boot if I want to access my wireless network.

I've tried rmmod-ing and then modprobe-ing wl as an alternative, but that doesn't seem to do anything useful.

This is a regression compared to Lucid and Karmic. Wireless was flawless before I upgraded from Lucid to Maverick.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: bcmwl-kernel-source 5.60.48.36+bdcom-0ubuntu5
ProcVersionSignature: Ubuntu 2.6.35-19.28-generic 2.6.35.3
Uname: Linux 2.6.35-19-generic i686
NonfreeKernelModules: wl
Architecture: i386
CheckboxSubmission: 4d8461a5f6328e3c4be6f85562c3d815
CheckboxSystem: bb422ca46d02494cdbc459927a98bc2f
Date: Mon Sep 6 17:20:33 2010
InstallationMedia: Ubuntu-Netbook-Remix 9.10 "Karmic Koala" - Release i386 (20091027)
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LANG=en_GB.utf8
SourcePackage: bcmwl

Gordon Ball (chronitis) wrote :

The same bug affects me (regression on upgrade from lucid to maverick), with the same driver (bcmwl-kernel-source).

I note for the reporter (assuming the problem is actually identical) that right-clicking on the wireless taskbar logo and ticking "Enable Wireless" successfully brings the device back up, and a short while afterwards a wireless connection is successfully made (and stays up).

system: Lenovo Ideapad S12N
lspci reports: 07:00.0 Network controller: Broadcom Corporation BCM4312 802.11b/g LP-PHY (rev 01)
lsmod reports: wl 1959533 0

lshw reports:
  *-network
       description: Wireless interface
       product: BCM4312 802.11b/g LP-PHY
       vendor: Broadcom Corporation
       physical id: 0
       bus info: pci@0000:07:00.0
       logical name: eth2
       version: 01
       serial: 00:26:82:32:35:77
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=wl0 driverversion=5.60.48.36 ip=192.168.1.5 latency=0 multicast=yes wireless=IEEE 802.11bg
       resources: irq:19 memory:c2200000-c2203fff

On boot, lshw reports the same, except this entry starts " *-network DISABLED".
On boot, lsmod reports that wl is already loaded as above.

Gordon Ball (chronitis) wrote :

Followup

I'm not sure whether this is a bug with the driver (bcmwl-kernel-source) or networkmanager (network-manager-gnome).

Looking at the state of some things in the /sys hierarchy before and after checking "enable wireless" in network manager. I'm not sure if these are helpful or irrelevant, but it probably doesn't hurt...

/sys/bus/pci/devices/0000:07:00.0/enable "1" (before and after)
/sys/bus/pci/devices/0000:07:00.0/power/control "on" (before and after)

/sys/bus/pci/devices/0000:07:00.0/net/eth2/carrier "invalid node" -> "0"
/sys/bus/pci/devices/0000:07:00.0/net/eth2/dormant "invalid node" -> "0"
/sys/bus/pci/devices/0000:07:00.0/net/eth2/flags "0x1002" -> "0x1003"
/sys/bus/pci/devices/0000:07:00.0/net/eth2/link_mode "0" -> "1"
/sys/bus/pci/devices/0000:07:00.0/net/eth2/operstate "down" -> "up"
/sys/bus/pci/devices/0000:07:00.0/net/eth2/power/control "auto" (before and after)

In the end, I went back to the b43 driver. That _also_ has a bug in
it. Even after I have worked around that, I still have to right click
and enable wireless when I start each new session. Standby and
hibernation break the wireless (seemingly irreparably) and I have to
reboot.

The difference between your bug and my bug (or perhaps the way they
manifest themselves, they may still be the same) is that I couldn't
enable wireless, because it was greyed out.

Thomas Moerkerken (tank-nl) wrote :

blacklisting the acer_wmi module fixed both the startup and suspend/hibernate issues for me (b43 on Lenovo S10) as per http://lkml.org/lkml/2010/3/22/472

HTH
Thomas

I have this problem on Dell Inspiron 1545.

'Enable Wireless' in network manager is grayed out on boot.
I toggle the hardware button to disable wireless and run "sudo rfkill unblock all". Now the manager shows that wireless is disabled.
I toggle the button again and run the command again. Now the wireless is enabled again.
Using this command without toggling the button doesn't work.

This used to be an occasional problem that would be fixed by rebooting. It stayed when I started using the above method, until now. Now it just disappeared. "sudo rfkill list all" doesn't show anything now.

Adam Porter (alphapapa) on 2013-06-09
Changed in bcmwl (Ubuntu):
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers