Ubuntu

Broadcom STA (bcmwl) driver fails to build with 2.6.35-1 kernel [error: ‘struct net_device’ has no member named ‘mc_list’]

Reported by Robbie Williamson on 2010-06-07
76
This bug affects 13 people
Affects Status Importance Assigned to Milestone
bcmwl (Ubuntu)
Medium
Andy Whitcroft
broadcom-sta (Ubuntu)
Medium
Unassigned

Bug Description

Driver works in previous 2.6.34-5 kernel.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: linux-image-2.6.35-1-generic 2.6.35-1.1
Regression: Yes
Reproducible: Yes
ProcVersionSignature: Ubuntu 2.6.35-1.1-generic 2.6.35-rc1
Uname: Linux 2.6.35-1-generic i686
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.23.
AplayDevices:
 **** List of PLAYBACK Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC268 Analog [ALC268 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC268 Analog [ALC268 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xf0540000 irq 44'
   Mixer name : 'Realtek ALC268'
   Components : 'HDA:10ec0268,102802b0,00100101'
   Controls : 13
   Simple ctrls : 8
Date: Mon Jun 7 13:48:50 2010
HibernationDevice: RESUME=UUID=f09403f6-9ccf-4dd5-b241-362019d053f4
InstallationMedia: Ubuntu-Netbook 10.04 "Lucid Lynx" - Release i386 (20100429.4)
IwConfig:
 lo no wireless extensions.

 eth0 no wireless extensions.
Lsusb:
 Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: Dell Inc. Inspiron 910
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.35-1-generic root=UUID=5dfa6e38-ce0d-4647-a1d3-08726a5e542d ro quiet splash
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
RelatedPackageVersions: linux-firmware 1.36
SourcePackage: linux
dmi.bios.date: 08/05/2008
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A00
dmi.board.name: CN0J14
dmi.board.vendor: Dell Inc.
dmi.board.version: A00
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: A00
dmi.modalias: dmi:bvnDellInc.:bvrA00:bd08/05/2008:svnDellInc.:pnInspiron910:pvrA00:rvnDellInc.:rnCN0J14:rvrA00:cvnDellInc.:ct8:cvrA00:
dmi.product.name: Inspiron 910
dmi.product.version: A00
dmi.sys.vendor: Dell Inc.

Related branches

Robbie Williamson (robbiew) wrote :
Changed in linux (Ubuntu):
status: New → Triaged
Andy Whitcroft (apw) on 2010-06-08
tags: removed: needs-upstream-testing
Andy Whitcroft (apw) wrote :

Confirmed with a Maverick kernel and the latest DKMS module:

DKMS make.log for bcmwl-5.60.48.36+bdcom for kernel 2.6.35-1-generic (i686)
Tue Jun 8 09:36:13 BST 2010
make: Entering directory `/usr/src/linux-headers-2.6.35-1-generic'
  LD /var/lib/dkms/bcmwl/5.60.48.36+bdcom/build/built-in.o
  CC [M] /var/lib/dkms/bcmwl/5.60.48.36+bdcom/build/src/shared/linux_osl.o
  CC [M] /var/lib/dkms/bcmwl/5.60.48.36+bdcom/build/src/wl/sys/wl_linux.o
/var/lib/dkms/bcmwl/5.60.48.36+bdcom/build/src/wl/sys/wl_linux.c: In function ‘_wl_set_multicast_list’:
/var/lib/dkms/bcmwl/5.60.48.36+bdcom/build/src/wl/sys/wl_linux.c:1435: error: ‘struct net_device’ has no member named ‘mc_list’
/var/lib/dkms/bcmwl/5.60.48.36+bdcom/build/src/wl/sys/wl_linux.c:1435: error: ‘struct net_device’ has no member named ‘mc_count’
/var/lib/dkms/bcmwl/5.60.48.36+bdcom/build/src/wl/sys/wl_linux.c:1436: error: dereferencing pointer to incomplete type
/var/lib/dkms/bcmwl/5.60.48.36+bdcom/build/src/wl/sys/wl_linux.c:1442: error: dereferencing pointer to incomplete type
make[1]: *** [/var/lib/dkms/bcmwl/5.60.48.36+bdcom/build/src/wl/sys/wl_linux.o] Error 1
make: *** [_module_/var/lib/dkms/bcmwl/5.60.48.36+bdcom/build] Error 2
make: Leaving directory `/usr/src/linux-headers-2.6.35-1-generic'

Andy Whitcroft (apw) on 2010-06-08
Changed in linux (Ubuntu):
importance: Undecided → Medium
Andy Whitcroft (apw) on 2010-06-08
Changed in linux (Ubuntu):
assignee: nobody → Andy Whitcroft (apw)
Andy Whitcroft (apw) wrote :

Ok this is an issue with the wl driver compiling against v2.6.35. I will spin patches for bcmwl. Moving this to bcmwl as this is not a kernel bug.

affects: linux (Ubuntu) → bcmwl (Ubuntu)
Changed in bcmwl (Ubuntu):
assignee: Andy Whitcroft (apw) → nobody
Andy Whitcroft (apw) wrote :

Proposing the following debdiff for Maverick.

Andy Whitcroft (apw) on 2010-06-08
Changed in bcmwl (Ubuntu):
assignee: nobody → Andy Whitcroft (apw)
Alberto Milone (albertomilone) wrote :

I've reviewed the package, proposed a small change in dkms.conf (which Andy applied) and uploaded his changes.

Thanks Andy.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bcmwl - 5.60.48.36+bdcom-0ubuntu5

---------------
bcmwl (5.60.48.36+bdcom-0ubuntu5) maverick; urgency=low

  * debian/patches/0004-mclist.patch:
   - Switch over to multicast iterator functions for kernels v2.6.35 and
     later. This fixes module building on v2.6.35-1.1. Conditionalise
     the patch to support older kernels. (LP: #590924)
 -- Andy Whitcroft <email address hidden> Tue, 08 Jun 2010 11:19:05 +0100

Changed in bcmwl (Ubuntu):
status: Triaged → Fix Released
AttilaN (attila123456) wrote :

any chance to get this fix for lucid? (to use backported maverick kernel)

SpyroTSK (webmaster-spyro) wrote :
Alex (alexander-l-king) wrote :

Will this link also work for Lucid? I'm having the same problem as AttilaN.

Fajran Iman Rusadi (fajran) wrote :

I can use the package on my Lucid amd64

Reopening because it seems the patch hasn't been applied to bcmwl-kernel-source in Maverick. Maybe it was only applied to the source that is built and shipped as binaries, but not to the source that is shipped as source in /usr/src/? I still find the same lines and I had to apply the patch manually. I have bcmwl-kernel-source 5.60.48.36+bdcom-0ubuntu5.

Changed in bcmwl (Ubuntu):
status: Fix Released → Triaged

Please also apply the patch to broadcom-sta, as building it with module-assistant also fails with the same error as the one in comment #2.

Changed in broadcom-sta (Ubuntu):
importance: Undecided → Medium
tags: added: patch

Milan Bouchet-Valat: bcmwl-kernel-source is intended to be used with DKMS. The patch is shipped in /usr/src/bcmwl-5.60.48.36+bdcom/patches/0004-mclist.patch and applied at DKMS build time according to the instructions in /usr/src/bcmwl-5.60.48.36+bdcom/dkms.conf. (Ubuntu does not ship binary bcmwl modules.)

Changed in bcmwl (Ubuntu):
status: Triaged → Fix Released
tags: added: regression-release
removed: regression-potential
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in broadcom-sta (Ubuntu):
status: New → Confirmed
Constantine (theaspect) wrote :

Same on Ubuntu 12.04 with 3.2.0-24-generic

sek.tor (sek.tor) on 2012-12-21
description: updated
summary: - Broadcom STA (bcmwl) driver fails to build with 2.6.35-1 kernel
+ Broadcom STA (bcmwl) driver fails to build with 2.6.35-1 kernel [error:
+ ‘struct net_device’ has no member named ‘mc_list’]
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers