Jockey fails to install Broadcom STA wireless driver (BCM4311)

Bug #511379 reported by Remy Damour on 2010-01-22
142
This bug affects 31 people
Affects Status Importance Assigned to Milestone
bcmwl (Ubuntu)
High
Alberto Milone

Bug Description

Under Ubuntu 9.10, wifi worked out of the box by enabling Broadcom STA wireless driver (System / Administration / Hardware Drivers / activating "Broadcom STA wireless driver").

Under Ubuntu 10.4, when I try to activate the driver, the following error occurs: "Sorry, installation of this driver failed. Please have a look at the log file for details: /var/log/jockey.log" => I no longer can use my wifi card (which worked great on ubuntu 9.10).

 lsb_release -rd
Description: Ubuntu lucid (development branch)
Release: 10.04

lspci | grep BCM
01:00.0 Network controller: Broadcom Corporation BCM4311 802.11b/g WLAN (rev 01)

cat /var/log/jockey.log
2010-01-22 23:01:20,539 DEBUG: BroadcomWLHandler enabled(): kmod disabled, bcm43xx: blacklisted, b43: blacklisted, b43legacy: blacklisted
2010-01-22 23:01:24,677 DEBUG: BroadcomWLHandler enabled(): kmod disabled, bcm43xx: blacklisted, b43: blacklisted, b43legacy: blacklisted
2010-01-22 23:01:30,472 DEBUG: BroadcomWLHandler enabled(): kmod disabled, bcm43xx: blacklisted, b43: blacklisted, b43legacy: blacklisted
2010-01-22 23:01:35,364 WARNING: modinfo for module wl failed: ERROR: modinfo: could not find module wl

2010-01-22 23:01:35,365 WARNING: /sys/module/wl/drivers does not exist, cannot rebind wl driver
2010-01-22 23:01:35,386 DEBUG: BroadcomWLHandler enabled(): kmod disabled, bcm43xx: blacklisted, b43: blacklisted, b43legacy: blacklisted
2010-01-22 23:01:39,651 DEBUG: BroadcomWLHandler enabled(): kmod disabled, bcm43xx: blacklisted, b43: blacklisted, b43legacy: blacklisted
2010-01-22 23:01:39,984 DEBUG: BroadcomWLHandler enabled(): kmod disabled, bcm43xx: blacklisted, b43: blacklisted, b43legacy: blacklisted

Remy Damour (remy-damour) wrote :
Philip Muškovac (yofel) on 2010-01-23
affects: ubuntu → bcmwl (Ubuntu)
goto (gotolaunchpad) wrote :
Mike (bild85) wrote :

same problem here. However the solution was to remove the bcmwl-kernel driver using Synaptic, then going back into Hardware drivers as suggested here: http://ubuntuforums.org/showpost.php?p=8628930&postcount=3. At this point, I was still unable to activate the Broadcom STA driver, but noticed a new option, the Broadcom B43 wireless driver. I activated it and the activation was successful.
While I was in the Hardware Drivers dialog, I tried to activate the Nvidia Accelerated Graphics Driver and got Kernel Panic (caps-lock and scroll-lock lights blinking together, entire system unresponsive) so had to do a powercycle. I don't expect this was related to this bug, but thought I'd mention it. I'll open another bug for that if necessary.

Daniele Daccurso (danidak2000) wrote :

solved in same way like goto

Mike (bild85) wrote :

The above bug I filed was on 10.04. Turns out I had to go back to 9.04 due to another bug that was a show-stopper and I just had the same problem. Couldn't load either driver. Gave up quickly last night, but this morning I tried again and it succeeded.
Could the previous failures have been related to the download site?

Joshua Szmajda (josh-loki) wrote :

goto's link also solved the problem for me.

Cerin (chrisspen) wrote :

goto's link did not solve the problem for me.

Installing linux-headers-generic does not provide the necessary linux/sched.h file needed to build the custom driver.

nUboon2Age (nuboon2age) on 2010-05-19
summary: - cannot load Broadcom STA wireless driver (BCM4311)
+ Jockey fails to install Broadcom STA wireless driver (BCM4311)
arky (arky) on 2010-07-06
Changed in bcmwl (Ubuntu):
status: New → Confirmed
Harald Schilly (harald-schilly) wrote :

thx goto, took me only 10 minutes to get wlan working again!

Daniel Hahler (blueyed) on 2011-05-06
Changed in bcmwl (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → High
Stanley Sokolow (overbyte) wrote :

Same problem on Ubuntu 11.04. From the desktop live CD running to try it out, the system recognizes that it needs the Broadcom STA driver and installs it from the CD, with no Ethernet connection plugged in. But after installing the OS onto the hard drive (with the Ethernet connection that it insisted upon before starting installation), the system gives the "blacklisted" error when it tries to install the wifi driver after reboot. I'm writing this bug report from that computer with the live CD running and the Broadcom proprietary driver installed, so the driver on the CD is definitely ok. The repository where the actual installed hard-drive system looks must have a bad version of the driver, perhaps a regression to a prior version by mistake.

The computer is a Dell Inspiron 1764.

Stanley Sokolow (overbyte) wrote :

I reinstalled 11.04 from the live DVD, without connecting to the Internet, thinking that the proprietary Broadcom STA driver would install from the DVD. But that didn't help. When I rebooted after installation, and tried to activate the proprietary driver, the driver installer said that the drivers were not installed and insisted that I connect to the Internet, and after I plugged in, it downloaded the driver profiles and found the Broadcom driver, but got the same error. If there's a way to install the driver that is on the CD and DVD, that would be a work-around until the driver repository is fixed. I don't know how to force that installation, however.

Any suggestions?

Stanley Sokolow (overbyte) wrote :

I went to Synaptic from the System Settings dialog, searched for bcmwl. It found the kernel source for the Broadcom. Then I marked that source file for reinstallation, applied, and after it finished reinstalling, I rebooted. The driver now works. (I may have had to activate it first, don't remember, but if it isn't working, then install the driver either from system settings or by clicking on the icon when the top panel displays the restricted drivers icon.) I don't understand why re-installation of the source works from Synaptic, but the initial activation didn't work. It just does.

neuromancer (neuromancer) wrote :

Broadcom BCM4312, wifi does'nt work.
I get the jockey error when I try to activate it from driver manager.
Reinstalling it with apt-get install --reinstall bcmwl-kernel-source
enable my wireless interface but it doesn't find any wifi connection :(

(Ubuntu natty 11.04, on previous version, Ubuntu 10.10, it works with STA driver)

The same problem on my Dell Inspiron 1545, which is running Broadcom Corporation BCM4312 802.11b/g LP-PHY (rev 01) according to lspci.

I SOLVED this problem using the guide from Broadcom: http://www.broadcom.com/docs/linux_sta/README.txt (see at the bottom under "Ubuntu"). I think this is the same solution given by Stanley.

The weirdest thing about this bug is that IT DID NOT HAPPEN WHEN I RAN THE LIVE CD. Probably means that Jockey needs to recompile the bcm kernel (which isn't really a problem when running from a thumb drive).

Borph (borph) wrote :

I have a fresh install of Natty 11.04 (32bit, Dell Studio 1555) and

sudo apt-get install --reinstall bcmwl-kernel-source

SOLVED IT. Thanks all commenter above.

Arthur Zennig (arthur-zennig) wrote :

same problem: 11.04, jockey couldn't install the broadcom driver.
I tried the goto solution, according to the link he posted, didn't work ( still don't know how to compile drivers).
The Mike solution worked for me, but what I did was slightly different:
- Enter Synaptics;
- wrote "bcm", and found all the broadcomm related things and checked to erase them;
- restart;
- went again to "hardware instalation" ( auf deutsch "treiber") and checked the broadcom to install.
- restart;
------------------------------------------------------------
After restarting, the wlan was working as it should.
------------------------------------------------------------

Feedback note: I just realized it wasn't work today, 10 days after I formated (again) the notebook. Interesting was, that my wlan
============ was working fine before, without this complication. ( I installed 11.04 in May, no upgrade ). This time, the problem happend. Blind shot for the problem: During the instalation I choosed to download important features during the installation. Otherwise, I don't remember doing anything different.

Bart Heinsius (bheinsius) wrote :

Problem still exists in 11.10

Solved by:

apt-get install --reinstall bcmwl-kernel-source
reboot

Ales (w-ales) wrote :

I can confirm that. Kubuntu 11.10, HP ProBook 4525s, Broadcom BCM4313

After this "apt-get install --reinstall bcmwl-kernel-source" proprietary driver SEEMS to work but it doesn't.
On the network manager I can see "Driver: brcmsmac" which is probably open source driver.

psarhjinian (psarhjinian) wrote :

Just got this on a Dell Latitude E5420. Uninstalling bcmwl-kernel-source and running jockey to activate the driver resolved the problem.

Ana Paula L B (ana-bielinski) wrote :

I tried everything that has been said here and nothing. I'm running version 11.10 I installed today, in fact, I'm not reinstallei that thing supporting more ...

In my Note Infoway W7401 + 3BG + 320HD only it installed so far. Tried a wireless usb and nothing can someone help please!? =#

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/511379

tags: added: iso-testing
Paolo Sammicheli (xdatap1) wrote :

I just ran into this with Precise, the first update after a fresh install. I solved it removing bcmwl-kernel-source package and letting jockey to install it again.

Graeme Glass (graemeglass) wrote :

Just upgraded from 11.10 to 12.04 on a 2 month old dell vostro 1540, and ran into this issue.
Wireless worked out the box in 11.10

Ales (w-ales) wrote :

I tried to run
sudo jockey-text --auto-install
from console, and it worked. Even the LED indicator is on.

DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=12.04
DISTRIB_CODENAME=precise
DISTRIB_DESCRIPTION="Ubuntu 12.04.1 LTS"
Linux 3.2.0-30-generic-pae #48-Ubuntu SMP Fri Aug 24 17:14:09 UTC 2012 i686 athlon i386 GNU/Linux

peter kri (i-peter-k) wrote :

try ubuntu 10.10 - still no support -

Bradley Taranto (yldblueman) wrote :

i JUST WENT THROUGH THIS.
OPTION 1
 Load kubuntu-desktop in synaptic. USE PATCH CABLE NETWORK 500 MEGS of files. You can now use additional drivers in a graphical environment.
Option 2
Attempt to install your wifi driver. If it install your done. If it say's BLACKLISTED or check log file /var/log/jockey.log OPEN A TERMINAL and run "sudo gedit /var/log/jockey.log" if it has a series of errors scroll to bottom and see if it lists drivers as BLACKLIST.
If so, run "sudo ls /etc/modprobe.d/" and it will return something like
alsa-base.conf blacklist.conf blacklist-oss.conf blacklist-ath_pci.conf
blacklist-firewire.conf blacklist-rare-network.conf dkms.conf
blacklist-bcm43.conf blacklist-framebuffer.conf blacklist-watchdog.conf iwlwifi.conf
blacklist-modem.conf broadcom-sta-common.conf vmwgfx-fbdev.conf
figure out witch ones have your drivers in it. I used:
blacklist-bcm43.conf
broadcom-sta-common.conf
blacklist.conf
using the command "sudo gedit /etc/modprobe.d/blacklist-bcm43.conf" unblacklist the driver using (# driver ). The comments at the top of the file is guide for commenting. Do this for each PERTINENT file. Reboot.
YOU THINK IT WOULD HAVE WORKED BUT NOOOOO! using the command "sudo gedit /etc/modprobe.d/blacklist-bcm43.conf" FOR each PERTINENT file and comment out every blacklisted driver from your manufacturer.
# Warning: This file is autogenerated by bcmwl. All changes to this file will be lost.
# blacklist b43
# blacklist b43legacy
# blacklist ssb
# blacklist bcm43xx
# blacklist brcm80211
# blacklist brcmfmac
# blacklist brcmsmac
# blacklist bcma
THIS WORKED FOR ME!!!!!!!!!!!!!!!!!!!!!!

Yang Kun (YK) (dayangkuncn) wrote :

@Alberto, Hi Alberto, could you please take a look at this bug ? thanks

Changed in bcmwl (Ubuntu):
assignee: nobody → Alberto Milone (albertomilone)

I ran into this issue today on Ubuntu 12.04 (amd64).

It was working fine on kernel 3.2.0-23, until I upgraded yesterday to 3.2.0-45. After which I get same error as above.

My workaround is to boot back from kernel 3.2.0-23.

Adam Porter (alphapapa) wrote :

This now seems to be a dupe of bug 1097519. Shame that this bug has been around for so many years, still affecting people.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers