Broadcom STA module is not loadable on karmic due to unknown symbols

Bug #395630 reported by Marc D.
134
This bug affects 24 people
Affects Status Importance Assigned to Milestone
Baltix
New
Undecided
Unassigned
bcmwl (Ubuntu)
Won't Fix
Undecided
Unassigned

Bug Description

The Broadcom STA kernel module “wl.ko” is not loadable on a reasonably recent karmic installation (updates as of yersterday) because of unknown symbols. “modprobe wl.ko” does not load the module with a rather generic error message and the kernel log yields:

[ 25.315594] wl: module license 'MIXED/Proprietary' taints kernel.
[ 25.322704] Disabling lock debugging due to kernel taint
[ 25.337362] wl: Unknown symbol lib80211_get_crypto_ops

After manually loading the required modules, wl.ko can also be loaded:

root@galileo:~# insmod /lib/modules/2.6.31-1-generic/kernel/net/wireless/lib80211.ko
root@galileo:~# insmod /lib/modules/2.6.31-1-generic/kernel/net/wireless/lib80211_crypt_wep.ko
root@galileo:~# insmod /lib/modules/2.6.31-1-generic/kernel/net/wireless/lib80211_crypt_tkip.ko
root@galileo:~# insmod /lib/modules/2.6.31-1-generic/kernel/net/wireless/lib80211_crypt_ccmp.ko
root@galileo:~# modprobe wl

[ 168.822430] lib80211: common routines for IEEE802.11 drivers
[ 168.822454] lib80211_crypt: registered algorithm 'NULL'
[ 173.873436] lib80211_crypt: registered algorithm 'WEP'
[ 176.952228] lib80211_crypt: registered algorithm 'TKIP'
[ 179.797952] lib80211_crypt: registered algorithm 'CCMP'
[ 187.713168] wl 0000:05:00.0: PCI INT A -> GSI 18 (level, low) -> IRQ 18
[ 187.713195] wl 0000:05:00.0: setting latency timer to 64
[ 187.734771] eth1: Broadcom BCM4315 802.11 Wireless Controller 5.10.91.9

“depmod -a” does not help, updates/dkms/wl.ko is mentioned in the modules.dep file, but its dependency list is empty.

Incidentally, kernel/net/wireless/lib80211.ko is not even mentioned in modules.dep, however, updates/lib80211.ko is. By the way, loading updates/lib80211* instead of kernel/net/wireless/lib80211* does not help wl.ko, the symbols it requires are still missing, then.

kosh@galileo:/$ lsb_release -rd
Description: Ubuntu karmic (development branch)
Release: 9.10

kosh@galileo:/$ dpkg -l bcmwl-kernel-source linux-image-generic
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Cfg-files/Unpacked/Failed-cfg/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
||/ Name Version Description
+++-==============================-==============================-============================================================================
ii bcmwl-kernel-source 5.10.91.9+bdcom-0ubuntu4 Broadcom 802.11 Linux STA wireless driver source
ii linux-image-generic 2.6.31.1.11 Generic Linux kernel image

kosh@galileo:/$ uname -a
Linux galileo 2.6.31-1-generic #14-Ubuntu SMP Thu Jul 2 16:03:01 UTC 2009 i686 GNU/Linux

Revision history for this message
Anton Gladky (gladky-anton) wrote :

I do not use Karamic, but use Jaunty. After kernel update a several days ago my network did not work (WIFI and ETH).

http://georgia.ubuntuforums.org/showpost.php?p=7506946&postcount=18

this helped me to solve the problem

sudo /sbin/lrm-manager
sudo modprobe wl

But I think it should be fixed.

Revision history for this message
Marc D. (koshy) wrote :

Thank you, Anton, but linux-restricted-modules is no longer being used in karmic.

I have solved the problem by removing linux-backports-modules-2.6.31-1-generic which contained the bogus lib80211.ko. I have no idea why I installed that package in the first place. Now wl.ko loads correctly (and automatically) and its dependencies are correct:

updates/dkms/wl.ko: kernel/net/wireless/lib80211.ko

Please check whether the failure I described is the expected behaviour and whether a “Conflicts:” should be added to avert this issue. Otherwise, just close this bug. :-)

Changed in bcmwl (Ubuntu):
status: New → Fix Released
Changed in bcmwl (Ubuntu):
status: Fix Released → Confirmed
Revision history for this message
Xavier Gnata (xavier-gnata-gmail) wrote :

On a fresh karmic on a dell mini:

FATAL: Error inserting wl (/lib/modules/2.6.31-14-generic/updates/dkms/wl.ko): Unknown symbol in module, or unknown parameter (see dmesg)

and in the dmesg:
[ 51.603074] wl: disagrees about version of symbol lib80211_get_crypto_ops
[ 51.603083] wl: Unknown symbol lib80211_get_crypto_ops

dpkg -S lib80211.ko :
linux-image-2.6.31-14-generic: /lib/modules/2.6.31-14-generic/kernel/net/wireless/lib80211.ko
linux-backports-modules-2.6.31-14-generic: /lib/modules/2.6.31-14-generic/updates/cw/lib80211.ko

Removing linux-backports-modules-2.6.31-14-generic does not help (same error message).

BTW, with a "Network controller: Broadcom Corporation BCM4312 802.11b/g (rev 01)" which driver are we suppose to use?? b43? wl? In jaunty, I use to use wl and it was fine.

Revision history for this message
Xavier Gnata (xavier-gnata-gmail) wrote :

insmod /lib/modules/2.6.31-14-generic/kernel/net/wireless/lib80211.ko
insmod /lib/modules/2.6.31-14-generic/kernel/net/wireless/lib80211_crypt_ccmp.ko
insmod /lib/modules/2.6.31-14-generic/kernel/net/wireless/lib80211_crypt_tkip.ko
insmod /lib/modules/2.6.31-14-generic/kernel/net/wireless/lib80211_crypt_wep.ko
modprobe wl

does work so the fix should be quite easy.

Revision history for this message
Xavier Gnata (xavier-gnata-gmail) wrote :

Never mind...Removing linux-backports-modules-2.6.31-14-generic does fix the pb.

Revision history for this message
Solleon Menezes (solleon-menezes) wrote :

Yes! Just remove linux-backports-modules-2.6.31-14-generic and the problem was gone!

Revision history for this message
kol (kol-cv) wrote :

Removing linux-backports-modules-2.6.31-15-generic have eliminated problem.

Revision history for this message
Emix (liuying) wrote :

Thank you.Xavier Gnata.Removing linux-backports-modules-2.6.31-14-generic really work.

Revision history for this message
QuentinHartman (qhartman) wrote :

removing linux-backports-modules-2.6.31-15-generic also worked for me, however, I need that installed to allow the modules for vmware workstation to build properly. So the process that I run through anytime the kernel or vmware changes is:

-Install backports-modules
-rebuild vmware kernel modules
-uninstall backports
-rebuild bcmwl (if the kernel is what changed)

Revision history for this message
Xavier Gnata (xavier-gnata-gmail) wrote : Re: [Bug 395630] Re: Broadcom STA module is not loadable on karmic due to unknown symbols

On 11/16/2009 07:15 PM, QuentinHartman wrote:
> removing linux-backports-modules-2.6.31-15-generic also worked for me,
> however, I need that installed to allow the modules for vmware
> workstation to build properly. So the process that I run through anytime
> the kernel or vmware changes is:
>
> -Install backports-modules
> -rebuild vmware kernel modules
> -uninstall backports
> -rebuild bcmwl (if the kernel is what changed)
>
>

That's not a solution ;)

backports-modules should stop to provide modules with a incompatible ABI compare to the one which is in the kernel mainline....but I assume it is not that easy.

Xavier

Revision history for this message
^rooker (rooker) wrote :

It's not only no solution as Xavier says, but in my case I'm suffering from an unloadable "wl" module - *and* removing "linux-backports-modules-2.6.31-15-generic" did not work for me. :(

When trying to "modprobe wl", I get the following error in dmesg:
[quote]
wl: disagrees about version of symbol lib80211_get_crypto_ops
wl: Unknown symbol lib80211_get_crypto_ops
[/quote]

Unfortunately, that's also the reason why it's not even possible to *try* the proprietary broadcom STA-driver, suggested by Jockey.

(Well, I've learned not to trust Dell anymore: I've begged them to give me hardware that would *not* be a pain-in-the-ass with GNU/Linux and they gave me a 4312 chipset. *sigh*)

Any ideas/updates on this broadcom driver issue? There are currently too many HowTos for Karmic & b43xx-chipsets, everyone suggesting something different...

Revision history for this message
David (n1ea) wrote : Re: [Bug 395630] Re: Broadcom STA module is not loadable on karmic due to unknown symbols

The broadcom module was removed from Debian repositories for a while, but
now has reappeared. I installed Broadcom-sta-common and
Broadcom-sta-source modules 5.10.91.9.3-1: all from testing also they are
in Sid and they work fine for me.

David

Revision history for this message
Alberto Milone (albertomilone) wrote :

If the problem is being cause by a change in the ABI, can you try the following command, please?

sudo apt-get install --reinstall bcmwl-kernel-source

and restart your computer.

Please let me know if it solves the problem

Revision history for this message
orkomedix (fsiepman) wrote :

Hi Alberto,

I had the same problem with my Acer Aspire One and karmic (2.6.31-16). Removing the backports did not solve the problem but your idea with sudo apt-get install --reinstall bcmwl-kernel-source worked just fine. Thanks a lot !

Revision history for this message
kensch (kschaupp) wrote :

i also had this proble on 2.6.31-17 had to remove backports and sudo apt-get install --reinstall bcmwl-kernel-source then reboot to get mine to work

ken

Revision history for this message
Jeremy Nickurak (nickurak) wrote :

I'm using linux-backports-modules-2.6.31-17.19, and recompiling the bcm module with jockey isn't working. After a reboot, dmesg reads:

[ 502.506495] wl: disagrees about version of symbol lib80211_get_crypto_ops
[ 502.506509] wl: Unknown symbol lib80211_get_crypto_ops

Revision history for this message
Borph (borph) wrote :

That bug affected me too, without this bugentry I would have not solved it, thank you!!

I wanted to try out TuxOnIce (2.6.31-19-generic-tuxonice #56~ppa3-Ubuntu), but I also installed the linux-backports-modules-*, which was not a good idea.

==> after de-installing all linux-backports-modules-* (I had acutally some) it worked again!!

Revision history for this message
David (n1ea) wrote :

For what it's worth, Broadcom-STA is working correctly in the current
Lucid updated pre-release. Ubuntu 10.04 LTS - the Lucid Lynx.

David Ring
Green Harbor, MA
-30-

Revision history for this message
Vitaliy Kulikov (slonua) wrote :

NOT All linux-backports-modules-* must be removed to provide work.
Just, linux-backports-modules-$(uname -r)

I use linux-backports-modules-alsa .. for audio digging =)

Revision history for this message
steubens (steubens) wrote :

this seems to come and go as *-backports-* is updated, it'd be cool if there was a way to block something, or give an install message from dkms when you enable the 3rd party modules

Revision history for this message
James Whanger (james-whanger) wrote :

Alberto Milone,

Below are the results of your request on my system:

root@mini:/home/mini# sudo apt-get install --reinstall bcmwl-kernel-source
Reading package lists...Done
Building dependency tree
Reading state information... Done
Reinstallation of bcmwl-kernel-source is not possible, it cannot be downloaded.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
2 not fully installed or removed.
After this operation, 0B of additional disk space will be used.
Setting up b43-fwcutter (1:012-1build1) ...
--2010-05-02 19:04:44-- http://downloads.openwrt.org/sources/wl_apsta-3.130.20.0.o
Resolving downloads.openwrt.org...

failed: Name or service not known.
wget: unable to resolve host address `downloads.openwrt.org'
dpkg: error processing b43-fwcutter (--configure):
subprocess installed post-installation script returned error exit status 4
Setting up bcmwl-kernel-source

(5.60.48.36+bdcom-0ubuntu3) ...
Removing old bcmwl-5.60.48.36+bdcom DKMS files...

------------------------------
Deleting module version: 5.60.48.36+bdcom

completely from the DKMS tree.
------------------------------
Done.
Loading new bcmwl-5.60.48.36+bdcom DKMS files...
First Installation: checking all kernels...
Building only for 2.6.32-21-generic
Building for architecture i686
Building initial module for 2.6.32-21-generic
/usr/sbin/dkms: line 35: patch: command not found

Error! Application of patch 0001-MODULE_LICENSE.patch failed.
Check /var/lib/dkms/bcmwl/5.60.48.36+bdcom/build/ for more information.
dpkg: error processing bcmwl-kernel-source (--configure):
subprocess installed post-installation script returned error exit status 6
Errors were encountered while processing:
b43-fwcutter
bcmwl-kernel-source
E: Sub-process /usr/bin/dpkg returned an error code (1)

Revision history for this message
lynx (lynx-cpp) wrote :

root@fyq-laptop:/lib/modules/2.6.32-25-generic/kernel/net/wireless# insmod lib80211.ko
insmod: error inserting 'lib80211.ko': -1 File exists
root@fyq-laptop:/lib/modules/2.6.32-25-generic/kernel/net/wireless# insmod lib80211_crypt_wep.ko
insmod: error inserting 'lib80211_crypt_wep.ko': -1 Unknown symbol in module
root@fyq-laptop:/lib/modules/2.6.32-25-generic/kernel/net/wireless# insmod lib80211_crypt_tkip.ko
insmod: error inserting 'lib80211_crypt_tkip.ko': -1 Unknown symbol in module
root@fyq-laptop:/lib/modules/2.6.32-25-generic/kernel/net/wireless# insmod lib80211_crypt_ccmp.ko
insmod: error inserting 'lib80211_crypt_ccmp.ko': -1 Unknown symbol in module
root@fyq-laptop:/lib/modules/2.6.32-25-generic/kernel/net/wireless# modprobe wl
FATAL: Error inserting wl (/lib/modules/2.6.32-25-generic/updates/dkms/wl.ko): Unknown symbol in module, or unknown parameter (see dmesg)

I got these errors above . How to solve this problem ?

Revision history for this message
Asfand Qazi (ayqazi) wrote :

Remember, after you get rid of the backports packages, you have to do a 'modprobe -r lib80211', to get rid of the backport version of it. Then a fresh 'modprobe wl' should do the trick. At least it did for me.

Regards,
     Asfand

Revision history for this message
w1zard (pacehead) wrote :

Thank you Asfand Qazi - I was going round in circles until I saw your post. These steps fixed the issue for me:

remove all backports using apt-get
sudo apt-get install --reinstall bcmwl-kernel-source
modprobe -r lib80211
modprobe wl

Revision history for this message
Zygmunt Krynicki (zyga) wrote :

Marking as wont-fix as karmic is no longer supported

Changed in bcmwl (Ubuntu):
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers