bcmwl 6.30.223.271+bdcom-0ubuntu4 ADT test failure with linux 5.1.0-1.1

Bug #1827100 reported by Seth Forshee on 2019-04-30
38
This bug affects 9 people
Affects Status Importance Assigned to Milestone
bcmwl (Ubuntu)
Medium
Seth Forshee
Bionic
Undecided
Marcelo Cerri
Eoan
Undecided
Unassigned

Bug Description

[Impact]
The DKMS package won't work with new kernels on bionic.

[Test case]
Install and load the modules.

[Regression potential]
This might break the functioning of the module.

-----------------------------------

Testing failed on:
    amd64: https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-eoan-canonical-kernel-team-bootstrap/eoan/amd64/b/bcmwl/20190429_132741_e6057@/log.gz
    i386: https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-eoan-canonical-kernel-team-bootstrap/eoan/i386/b/bcmwl/20190429_124054_e6057@/log.gz

Seth Forshee (sforshee) on 2019-04-30
tags: added: kernel-adt-failure
Seth Forshee (sforshee) wrote :
Changed in bcmwl (Ubuntu):
assignee: nobody → Seth Forshee (sforshee)
importance: Undecided → Medium
status: New → In Progress
tags: added: patch
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bcmwl - 6.30.223.271+bdcom-0ubuntu5

---------------
bcmwl (6.30.223.271+bdcom-0ubuntu5) eoan; urgency=medium

  * debian/dkms.conf.in,
    debian/patches/0027-add-support-for-linux-5.1.patch (LP: #1827100):
    - Add support for Linux 5.1.

 -- Seth Forshee <email address hidden> Fri, 17 May 2019 15:35:42 -0500

Changed in bcmwl (Ubuntu):
status: In Progress → Fix Released
Marcelo Cerri (mhcerri) wrote :
Changed in bcmwl (Ubuntu Bionic):
status: New → Fix Released
Changed in bcmwl (Ubuntu Eoan):
status: New → In Progress
assignee: nobody → Marcelo Cerri (mhcerri)
Marcelo Cerri (mhcerri) on 2019-11-13
description: updated
Changed in bcmwl (Ubuntu Bionic):
status: Fix Released → In Progress
Changed in bcmwl (Ubuntu Eoan):
status: In Progress → Fix Released
assignee: Marcelo Cerri (mhcerri) → nobody
Changed in bcmwl (Ubuntu Bionic):
assignee: nobody → Marcelo Cerri (mhcerri)

Hello Seth, or anyone else affected,

Accepted bcmwl into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/bcmwl/6.30.223.271+bdcom-0ubuntu5~18.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in bcmwl (Ubuntu Bionic):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-bionic
e3b0c442 (e3b0c442) wrote :

Tested bcmwl-kernel-source 6.30.223.271+bdcom-0ubuntu5~18.04.1. The issue is resolved for me.

tags: added: verification-done verification-done-bionic
removed: verification-needed verification-needed-bionic
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bcmwl - 6.30.223.271+bdcom-0ubuntu5~18.04.1

---------------
bcmwl (6.30.223.271+bdcom-0ubuntu5~18.04.1) bionic; urgency=medium

  [ Seth Forshee ]
  * debian/dkms.conf.in,
    debian/patches/0027-add-support-for-linux-5.1.patch (LP: #1827100):
    - Add support for Linux 5.1.

 -- Marcelo Henrique Cerri <email address hidden> Wed, 13 Nov 2019 11:05:32 -0300

Changed in bcmwl (Ubuntu Bionic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for bcmwl has completed successfully and the package is now being released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers