bcmwl 6.30.223.271+bdcom-0ubuntu1~1.2 ADT test failure with linux-hwe-edge 4.15.0-23.25~16.04.1

Bug #1777646 reported by Marcelo Cerri on 2018-06-19
46
This bug affects 14 people
Affects Status Importance Assigned to Milestone
bcmwl (Ubuntu)
Undecided
Marcelo Cerri
Xenial
Medium
Marcelo Cerri

Bug Description

[Impact]

Currently the DKMS package fails to install on supported custom
kernels that are based on 4.15. That includes the current 4.15
hwe-edge and some of the custom and cloud kernels as well.

[Test Case]

Install the broadcom-sta package with the 4.15 hwe-edge kernel. The
package installation should proceed without any errors.

[Regression Potential]

Although new patches were added, the regression risk is very low since
the new changes are conditionally compiled based on the kernel
version.

Besides that, the new package was tested with the following kernels in
an amd64 environment:

- linux-generic 4.4
- linux-hwe 4.13
- linux-hwe-edge 4.15
- linux-azure 4.15

[Original Description]

Testing failed on:
    amd64: https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-xenial/xenial/amd64/b/bcmwl/20180528_193622_1abd6@/log.gz
    i386: https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-xenial/xenial/i386/b/bcmwl/20180528_193842_1abd6@/log.gz

Marcelo Cerri (mhcerri) wrote :
tags: added: kernel-adt-failure
Marcelo Cerri (mhcerri) wrote :
description: updated
Changed in bcmwl (Ubuntu):
assignee: nobody → Marcelo Cerri (mhcerri)
status: New → In Progress
tags: added: patch
Tyler Hicks (tyhicks) wrote :

Looks good! I've uploaded it to xenial.

Changed in bcmwl (Ubuntu Xenial):
assignee: nobody → Marcelo Cerri (mhcerri)
status: New → In Progress
Changed in bcmwl (Ubuntu):
status: In Progress → Invalid
Changed in bcmwl (Ubuntu Xenial):
status: In Progress → Fix Committed
Robie Basak (racb) wrote :

Does this package work correctly against the equivalent kernels in Bionic and Cosmic please? Obviously they'd be different versions, but I'd like to ensure the spirit of the SRU rule about being fixed in the development release to avoid a regression where a user uses a particular kernel flavor, upgrades, and gets a failure.

Hello Marcelo, or anyone else affected,

Accepted bcmwl into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/bcmwl/6.30.223.271+bdcom-0ubuntu1~1.3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed verification-needed-xenial
Leith Bade (ljbade) wrote :

The proposed package fails to install but does manage to build.

This is the install log:
i915
leith@leith-xps:~$ sudo apt-get install bcmwl-kernel-source
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
  libllvm5.0 libllvm5.0:i386 linux-headers-4.13.0-43
  linux-headers-4.13.0-43-generic linux-image-4.13.0-43-generic
  linux-image-extra-4.13.0-43-generic
Use 'sudo apt autoremove' to remove them.
The following NEW packages will be installed
  bcmwl-kernel-source
0 to upgrade, 1 to newly install, 0 to remove and 24 not to upgrade.
Need to get 1,547 kB of archives.
After this operation, 8,067 kB of additional disk space will be used.
Get:1 http://archive.ubuntu.com/ubuntu xenial-proposed/restricted amd64 bcmwl-kernel-source amd64 6.30.223.271+bdcom-0ubuntu1~1.3 [1,547 kB]
Fetched 1,547 kB in 2s (536 kB/s)
Selecting previously unselected package bcmwl-kernel-source.
(Reading database ... 441614 files and directories currently installed.)
Preparing to unpack .../bcmwl-kernel-source_6.30.223.271+bdcom-0ubuntu1~1.3_amd64.deb ...
Unpacking bcmwl-kernel-source (6.30.223.271+bdcom-0ubuntu1~1.3) ...
Setting up bcmwl-kernel-source (6.30.223.271+bdcom-0ubuntu1~1.3) ...
Loading new bcmwl-6.30.223.271+bdcom DKMS files...
First Installation: checking all kernels...
Building only for 4.15.0-24-generic
Building for architecture x86_64
Building initial module for 4.15.0-24-generic
Done.

wl:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/4.15.0-24-generic/updates/dkms/

depmod....

DKMS: install completed.
modprobe: ERROR: could not insert 'wl': Required key not available
update-initramfs: deferring update (trigger activated)
Processing triggers for shim-signed (1.33.1~16.04.1+13-0ubuntu2) ...
Processing triggers for initramfs-tools (0.122ubuntu8.11) ...
update-initramfs: Generating /boot/initrd.img-4.15.0-24-generic
W: Possible missing firmware /lib/firmware/i915/kbl_guc_ver9_14.bin for module i915
W: Possible missing firmware /lib/firmware/i915/bxt_guc_ver8_7.bin for module i915
leith@leith-xps:~$

Jeremy (wa113y3s) wrote :

Leith Bade, go into BIOS/UEFI settings and disable Secure Boot

Leopold Delouche (deathtickle) wrote :

All is working for me on 4.15.0-24-generic #26~16.04.1-Ubuntu.

bcmwl-kernel-source/xenial-proposed,now 6.30.223.271+bdcom-0ubuntu1~1.3 amd64 [installed]

kernel: wlan0: Broadcom BCM4331 802.11 Hybrid Wireless Controller 6.30.223.271 (r587334)

Andrew Vian (drewvian) wrote :

I have run into a bug when installing the 4.15.0-29-generic kernel today. The relevant bug report is here: https://bugs.launchpad.net/ubuntu/+source/bcmwl/+bug/1757008?comments=all

I would point out that I did not have a problem with the 4.15.0-24-generic kernel. When browsing for info on the bug, I found my way to this page as a fix.

The proposed fix installed successfully and the problem is corrected.

Vincent Ladeuil (vila) wrote :

> The proposed fix installed successfully and the problem is corrected.

\o/

Yet:

> I have run into a bug when installing the 4.15.0-29-generic kernel today.

So can we have the -proposed fix landed ?
Pretty please ? With sugar on top ?
Is it a matter of changing one bug tag ?
Which one (verification-done ?) ?

Melissa Rice (melissa-5) wrote :

Here is what worked for me to restore WiFi functionality...

1. Run Software & Udpates from the launcher. In the Developer Options tab, check the box for Pre-released updates. This will require your admin password and will update the cache.

2. Run Software Updater from the launcher. It will present you with lots of options of stuff to update. Because I did not want to beta test the whole proposed release at this moment, but just fix my WiFi, I unchecked all of the updates except the Broadcom wireless driver. Then I installed this update, which did not require a reboot.

3. I tested the WiFi by unplugging the internet cable and connecting to wireless, which worked. A reboot was not requested so I didn't reboot.

4. Run Software & Udpates from the launcher. In the Developer Options tab, uncheck the box for Pre-released updates. This will require your admin password, again. It will update the cache. I did this because I don't want to install any further updates from the Proposed (pre-release) repository, just the one I needed to make WiFi work again.

My computer is a very old Dell Inspiron with Ubuntu 16.04. The wireless was working until I updated the OS this morning and the update failed due to a Broadcom driver problem, as described in this post and also here: https://bugs.launchpad.net/ubuntu/+source/bcmwl/+bug/1757008. The above procedure corrected the problem without introducing any new problems. Thanks to everyone who contributed the fix! Much appreciated.

Rolf Boelens (rbo51) wrote :

Had the Broadcom wireless driver problem as well, when updating Ubuntu 16.04 this morning. Before rebooting, I did what Melissa Rice indicated. A prelease WL driver was inserted in the 16.04 update, and after the reboot wireless was working.

Michael Thorp (lobsta) wrote :

Applied fix as per Melissa Rice's post above and working fine on 16.04 on 4.15.0-29 kernel. Many thanks to all involved, it was getting tedious to have to boot into the old kernel repeatedly.

Tomas (tomas-olvecky) wrote :

Melissa Rice's fix worked for me also on 16.04 , hope the fix will appear in regular updates soon!

Andy Whitcroft (apw) wrote :

Based on the numerous successful reports using this version I am marking this verification-done-xenial.

tags: added: verification-done-xenial
removed: verification-needed-xenial
Changed in bcmwl (Ubuntu Xenial):
importance: Undecided → Medium

The verification of the Stable Release Update for bcmwl has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bcmwl - 6.30.223.271+bdcom-0ubuntu1~1.3

---------------
bcmwl (6.30.223.271+bdcom-0ubuntu1~1.3) xenial; urgency=medium

  * debian/dkms.conf.in, (LP: #1777646)
    debian/patches/0025-add-support-for-linux-4.14.patch:
    debian/patches/0026-add-support-for-linux-4.15.patch:
    - Add support for Linux 4.15.

 -- Marcelo Henrique Cerri <email address hidden> Tue, 19 Jun 2018 09:50:20 -0300

Changed in bcmwl (Ubuntu Xenial):
status: Fix Committed → Fix Released
Vincent Ladeuil (vila) wrote :

/me hugs apw

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments