bcmwl-kernel-source 6.30.223.271+bdcom-0ubuntu1~1.1: bcmwl kernel module failed to build [error: macro "alloc_netdev" requires 4 arguments, but only 3 given]

Bug #1699569 reported by Sagar swami on 2017-06-21
56
This bug affects 11 people
Affects Status Importance Assigned to Milestone
bcmwl (Ubuntu)
Undecided
Unassigned

Bug Description

Description: Ubuntu 16.04.2 LTS
Release: 16.04

N: Ignoring file '50unattended-upgrades.ucf-dist' in directory '/etc/apt/apt.conf.d/' as it has an invalid filename extension
N: Unable to locate package pkgname

trying to install broadcom wireless drivers but cant.

ProblemType: Package
DistroRelease: Ubuntu 16.04
Package: bcmwl-kernel-source 6.30.223.141+bdcom-0ubuntu2
ProcVersionSignature: Ubuntu 4.4.0-81.104-generic 4.4.67
Uname: Linux 4.4.0-81-generic x86_64
NonfreeKernelModules: wl nvidia_uvm nvidia_drm nvidia_modeset nvidia
ApportVersion: 2.20.1-0ubuntu2.6
Architecture: amd64
DKMSKernelVersion: 4.4.0-81-generic
Date: Wed Jun 21 23:33:42 2017
DuplicateSignature: dkms:bcmwl-kernel-source:6.30.223.271+bdcom-0ubuntu1~1.1:/var/lib/dkms/bcmwl/6.30.223.141+bdcom/build/src/wl/sys/wl_linux.c:1354:64: error: macro "alloc_netdev" requires 4 arguments, but only 3 given
InstallationDate: Installed on 2017-06-03 (18 days ago)
InstallationMedia: Ubuntu 14.04.5 LTS "Trusty Tahr" - Release amd64 (20160803)
PackageVersion: 6.30.223.271+bdcom-0ubuntu1~1.1
RelatedPackageVersions:
 dpkg 1.18.4ubuntu1.2
 apt 1.2.20
SourcePackage: bcmwl
Title: bcmwl-kernel-source 6.30.223.271+bdcom-0ubuntu1~1.1: bcmwl kernel module failed to build
UpgradeStatus: Upgraded to xenial on 2017-06-04 (16 days ago)

Sagar swami (aakashswamiaki) wrote :
tags: removed: need-duplicate-check
Daniel van Vugt (vanvugt) wrote :

This seems to be a recurrence of bug 1358966. That one was marked as Fix Released in vivid so I guess we should track the problem in a new bug now (this one).

summary: bcmwl-kernel-source 6.30.223.271+bdcom-0ubuntu1~1.1: bcmwl kernel module
- failed to build
+ failed to build [error: macro "alloc_netdev" requires 4 arguments, but
+ only 3 given]
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in bcmwl (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers