Client does not ACK auth/assoc responses from Cisco AP3800

Bug #1647036 reported by Stephen Anderson on 2016-12-03
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
bcmwl (Ubuntu)
High
Alberto Milone
Trusty
High
Unassigned
Xenial
High
Unassigned
Yakkety
High
Unassigned
Zesty
High
Alberto Milone

Bug Description

This client does not ACK Assoc Responses from a Cisco 3800. Traces attached.

- Model: Dell XPS13 9343
- OS Version: Ubuntu 14.04.5 LTS
- WNIC: Broadcom BCM4352 rev. 03 driver version 6.30.223.248
- SSID: user.wifi (WPA2/dot1x )
- MAC address: c4:8e:8f:f5:4a:7f
-Cisco AP : 3800 (wave 2)

Stephen Anderson (smanders) wrote :
Changed in bcmwl (Ubuntu):
assignee: nobody → Alberto Milone (albertomilone)
importance: Undecided → High
status: New → Triaged
Changed in bcmwl (Ubuntu):
status: Triaged → In Progress
Changed in bcmwl (Ubuntu Trusty):
status: New → Triaged
Changed in bcmwl (Ubuntu Xenial):
status: New → Triaged
Tim Gardner (timg-tpi) on 2016-12-07
Changed in bcmwl (Ubuntu Trusty):
status: Triaged → In Progress
Changed in bcmwl (Ubuntu Xenial):
status: Triaged → In Progress
Changed in bcmwl (Ubuntu Yakkety):
status: New → In Progress

Hello Stephen, or anyone else affected,

Accepted bcmwl into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/bcmwl/6.30.223.271+bdcom-0ubuntu1~0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in bcmwl (Ubuntu Trusty):
status: In Progress → Fix Committed
tags: added: verification-needed
Changed in bcmwl (Ubuntu Xenial):
status: In Progress → Fix Committed
Adam Conrad (adconrad) wrote :

Hello Stephen, or anyone else affected,

Accepted bcmwl into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/bcmwl/6.30.223.271+bdcom-0ubuntu1~1.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in bcmwl (Ubuntu Yakkety):
status: In Progress → Fix Committed
Adam Conrad (adconrad) wrote :

Hello Stephen, or anyone else affected,

Accepted bcmwl into yakkety-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/bcmwl/6.30.223.271+bdcom-0ubuntu1~2.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bcmwl - 6.30.223.271+bdcom-0ubuntu1

---------------
bcmwl (6.30.223.271+bdcom-0ubuntu1) zesty; urgency=medium

  * debian/dkms.conf.in
    - Drop obsolete patches.
  * New upstream release:
    - Client does not ACK auth/assoc responses from Cisco AP3800 (LP: #1647036).

 -- Alberto Milone <email address hidden> Tue, 06 Dec 2016 16:29:07 +0100

Changed in bcmwl (Ubuntu Zesty):
status: In Progress → Fix Released
Changed in bcmwl (Ubuntu Trusty):
importance: Undecided → High
Changed in bcmwl (Ubuntu Xenial):
importance: Undecided → High
Changed in bcmwl (Ubuntu Yakkety):
importance: Undecided → High
Alberto Milone (albertomilone) wrote :

I have used the driver on my 2011 macbook air for a couple of months and I haven't experienced any regressions whatsoever.

tags: added: verification-done
removed: verification-needed
Alberto Milone (albertomilone) wrote :

I have also tested the backported kernel in Xenial, and the module builds and works well (as with 4.4).

uname -r

4.8.0-35-generic

modinfo wl

filename: /lib/modules/4.8.0-35-generic/updates/dkms/wl.ko
license: MIXED/Proprietary
srcversion: 0ADAE750C888A523D63D8B5
alias: pci:v*d*sv*sd*bc02sc80i*
depends: cfg80211
vermagic: 4.8.0-35-generic SMP mod_unload modversions
parm: passivemode:int
parm: wl_txq_thresh:int
parm: oneonly:int
parm: piomode:int
parm: instance_base:int
parm: nompc:int
parm: intf_name:string

apt-cache policy linux-generic-hwe-16.04

linux-generic-hwe-16.04:
  Installed: 4.8.0.35.7
  Candidate: 4.8.0.35.7
  Version table:
 *** 4.8.0.35.7 400
        400 http://it.archive.ubuntu.com/ubuntu xenial-proposed/main amd64 Packages
        100 /var/lib/dpkg/status

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bcmwl - 6.30.223.271+bdcom-0ubuntu1~1.1

---------------
bcmwl (6.30.223.271+bdcom-0ubuntu1~1.1) xenial; urgency=medium

  * debian/dkms.conf.in
    - Drop obsolete patches.
  * New upstream release:
    - Client does not ACK auth/assoc responses from Cisco AP3800 (LP: #1647036).

bcmwl (6.30.223.248+bdcom-0ubuntu11) yakkety; urgency=medium

  * debian/patches/0020-add-support-for-linux-4.8.patch:
    - Fix whitespace issue that prevented DKMS from applying the patch.

bcmwl (6.30.223.248+bdcom-0ubuntu10) yakkety; urgency=medium

  * debian/dkms.conf.in,
    debian/patches/0020-add-support-for-linux-4.8.patch:
    - Add support for Linux 4.8. Thanks to Krzysztof Kolasa.

bcmwl (6.30.223.248+bdcom-0ubuntu9) yakkety; urgency=medium

  * debian/dkms.conf.in,
    debian/patches/0020-add-support-for-linux-4.7.patch:
    - Add support for Linux 4.7. Thanks to Vincent Gerris for pointing out
      the solution.

 -- Alberto Milone <email address hidden> Tue, 06 Dec 2016 16:29:07 +0100

Changed in bcmwl (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for bcmwl has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

tags: added: verification-done-xenial
removed: verification-done
Andy Whitcroft (apw) on 2017-02-15
description: updated
description: updated
Brian Murray (brian-murray) wrote :

What release does your macbook air run? If its not Xenial does that mean this is verified for Yakkety?

Steve Langasek (vorlon) wrote :

Alberto, could you please confirm whether this has been verified for yakkety?

Alberto Milone (albertomilone) wrote :

@Brian: my macbook runs xenial. I also used a backported yakkety kernel for testing, and it worked.

@Steve: I can probably install Yakkety on an external drive, and use it with my macbook to verify this, since I don't have enough space on the ssd.

Alberto Milone (albertomilone) wrote :

I have finally been able to install Yakkety and to test the driver in proposed. I am happy to confirm that the driver works correctly, and I haven't noticed any regressions with it.

tags: added: verification-done-yakkety
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bcmwl - 6.30.223.271+bdcom-0ubuntu1~2.1

---------------
bcmwl (6.30.223.271+bdcom-0ubuntu1~2.1) yakkety; urgency=medium

  * debian/dkms.conf.in
    - Drop obsolete patches.
  * New upstream release:
    - Client does not ACK auth/assoc responses from Cisco AP3800 (LP: #1647036).

 -- Alberto Milone <email address hidden> Tue, 06 Dec 2016 16:29:07 +0100

Changed in bcmwl (Ubuntu Yakkety):
status: Fix Committed → Fix Released

As part of a recent change in the Stable Release Update verification policy we would like to inform that for a bug to be considered verified for a given release a verification-done-$RELEASE tag needs to be added to the bug where $RELEASE is the name of the series the package that was tested (e.g. verification-done-xenial). Please note that the global 'verification-done' tag can no longer be used for this purpose.

Thank you!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers