Broadcom wireless drivers fail to build [error: implicit declaration of function 'rdtscl']

Bug #1616735 reported by vipul.bhokal on 2016-08-25
52
This bug affects 7 people
Affects Status Importance Assigned to Milestone
bcmwl (Ubuntu)
Undecided
Unassigned
broadcom-sta (Ubuntu)
Undecided
Unassigned

Bug Description

This problem started after I upgraded to the 16.04 Xenial Stack. I got a message "1404_HWE_EOL" and the ubuntu wiki page on the same suggested upgrading to the new stack. With the previous stack, random screen freezes happened, while using wifi, so I thought wifi drivers might be faulty, but now it has started happening while using wired LAN also.
Ubuntu Release: 14.04.5 LTS
Any help will be much appreciated. Thanks.

ProblemType: Package
DistroRelease: Ubuntu 14.04
Package: bcmwl-kernel-source 6.30.223.248+bdcom-0ubuntu0.1
ProcVersionSignature: Ubuntu 4.4.0-34.53~14.04.1-generic 4.4.15
Uname: Linux 4.4.0-34-generic i686
ApportVersion: 2.14.1-0ubuntu3.21
Architecture: i386
DKMSKernelVersion: 4.4.0-34-generic
Date: Wed Aug 24 14:52:12 2016
DuplicateSignature: dkms:bcmwl-kernel-source:6.30.223.248+bdcom-0ubuntu0.1:/var/lib/dkms/bcmwl/6.30.223.248+bdcom/build/src/shared/linux_osl.c:935:2: error: implicit declaration of function 'rdtscl' [-Werror=implicit-function-declaration]
InstallationDate: Installed on 2015-09-22 (337 days ago)
InstallationMedia: Custom 14.04 - Release i386
PackageVersion: 6.30.223.248+bdcom-0ubuntu0.1
RelatedPackageVersions:
 dpkg 1.17.5ubuntu5.7
 apt 1.0.1ubuntu2.14
SourcePackage: bcmwl
Title: bcmwl-kernel-source 6.30.223.248+bdcom-0ubuntu0.1: bcmwl kernel module failed to build
UpgradeStatus: No upgrade log present (probably fresh install)

vipul.bhokal (vipul-bhokal) wrote :
tags: removed: need-duplicate-check
summary: - bcmwl-kernel-source 6.30.223.248+bdcom-0ubuntu0.1: bcmwl kernel module
- failed to build, screen randomly freezes
+ Broadcom wireless drivers fail to build [error: implicit declaration of
+ function 'rdtscl']
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in bcmwl (Ubuntu):
status: New → Confirmed
Changed in broadcom-sta (Ubuntu):
status: New → Confirmed
Changed in broadcom-sta (Ubuntu):
status: Confirmed → Invalid
status: Invalid → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers