SRU Request: bcmwl: dkms build failures with linux-lts-wily

Bug #1518956 reported by Andy Whitcroft on 2015-11-23
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
bcmwl (Ubuntu)
High
Alberto Milone
Trusty
High
Alberto Milone

Bug Description

[Impact]
The lts-wily backported kernel in Trusty causes the DKMS module installed by bcmwl-kernel-source to fail to build.

[Test Case]
Install the lts-wily kernel and check that DKMS doesn't fail with the new bcmwl-kernel-source.

[Regression Potential]
Low, all the changes are already included in wily.
_______
We are seeing build failures for dkms packages on trusty + linux-lts-wily.

Andy Whitcroft (apw) on 2015-11-23
Changed in bcmwl (Ubuntu):
assignee: nobody → Alberto Milone (albertomilone)
Changed in bcmwl (Ubuntu):
status: New → Triaged
importance: Undecided → High
description: updated
summary: - bcmwl: dkms build failures with linux-lts-wily
+ SRU Request: bcmwl: dkms build failures with linux-lts-wily

Hello Andy, or anyone else affected,

Accepted bcmwl into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/bcmwl/6.30.223.248+bdcom-0ubuntu0.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in bcmwl (Ubuntu):
status: Triaged → Fix Released
Changed in bcmwl (Ubuntu Trusty):
assignee: nobody → Alberto Milone (albertomilone)
status: New → In Progress
importance: Undecided → High
status: In Progress → Fix Committed
tags: added: verification-needed

As a part of the Stable Release Updates quality process a search for Launchpad bug reports using the version of bcmwl from trusty-proposed was performed and bug 1529945 was found. Please investigate this bug report to ensure that a regression will not be created by this SRU. In the event that this is not a regression remove the "verification-failed" tag from this bug report and add the tag "bot-stop-nagging" to bug 1529945 (not this bug). Thanks!

tags: added: verification-failed
Adam Conrad (adconrad) wrote :

bjf tested this and reported on IRC that it works with lts-vivid and lts-wily.

tags: added: verification-done
removed: verification-failed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bcmwl - 6.30.223.248+bdcom-0ubuntu0.2

---------------
bcmwl (6.30.223.248+bdcom-0ubuntu0.2) trusty-proposed; urgency=medium

  * debian/dkms.conf.in,
    0016-repair-make-warnings.patch,
    0017-add-support-for-Linux-4.0.patch,
    0018-cfg80211_disconnected.patch,
    0019-broadcom-sta-6.30.223.248-3.18-null-pointer-fix.patch:
    - Add support for kernels up to 4.2 (LP: #1518956). Credit
      for the patches goes to Krzysztof Kolasa and to Tim Gardner.

 -- Alberto Milone <email address hidden> Fri, 27 Nov 2015 18:02:04 +0100

Changed in bcmwl (Ubuntu Trusty):
status: Fix Committed → Fix Released
Mathew Hodson (mathew-hodson) wrote :

This was previously marked as a duplicate of Bug #1415880: 14e4:4365 bcmwl-kernel source: fix for null pointer crash.

Since this bug is specifically mentioned in the changelog for the Trusty package, I unduped it.

tags: removed: verification-needed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers