bcmwl-kernel-source 6.30.223.248+bdcom-0ubuntu4: bcmwl kernel module failed to build [FATAL: modpost: GPL-incompatible module wl.ko uses GPL-only symbol 'flush_workqueue']

Bug #1481662 reported by Валерий on 2015-08-05
38
This bug affects 4 people
Affects Status Importance Assigned to Milestone
bcmwl (Ubuntu)
High
Unassigned

Bug Description

bcmwl-kernel-source 6.30.223.248+bdcom-0ubuntu4: bcmwl kernel module failed to build

ProblemType: Package
DistroRelease: Ubuntu 15.10
Package: bcmwl-kernel-source 6.30.223.248+bdcom-0ubuntu4
Uname: Linux 4.1.4-040104-generic i686
NonfreeKernelModules: wl
ApportVersion: 2.18-0ubuntu5
Architecture: i386
DKMSKernelVersion: 4.2.0-040200rc5-generic
Date: Wed Aug 5 12:12:36 2015
InstallationDate: Installed on 2015-06-02 (64 days ago)
InstallationMedia: Ubuntu 15.10 "Wily Werewolf" - Alpha i386 (20150601)
PackageVersion: 6.30.223.248+bdcom-0ubuntu4
RelatedPackageVersions:
 dpkg 1.18.1ubuntu1
 apt 1.0.9.10ubuntu1
SourcePackage: bcmwl
Title: bcmwl-kernel-source 6.30.223.248+bdcom-0ubuntu4: bcmwl kernel module failed to build
UpgradeStatus: No upgrade log present (probably fresh install)

Валерий (com-bvv) wrote :
summary: bcmwl-kernel-source 6.30.223.248+bdcom-0ubuntu4: bcmwl kernel module
- failed to build
+ failed to build [FATAL: modpost: GPL-incompatible module wl.ko uses GPL-
+ only symbol 'flush_workqueue']
Simon Eisenmann (longsleep) wrote :

As a workaround build your own bcmwl-kernel-source package with the change shown in https://github.com/longsleep/bcmwl-ubuntu/issues/6

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in bcmwl (Ubuntu):
status: New → Confirmed
Changed in bcmwl (Ubuntu):
importance: Undecided → High
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers