bcmwl-kernel-source 6.30.223.248+bdcom-0ubuntu2: bcmwl kernel module failed to build with kernel 4.0 [error: ‘STATION_INFO_TX_BITRATE’ undeclared (first use in this function)]

Bug #1424676 reported by rolmops on 2015-02-23
116
This bug affects 20 people
Affects Status Importance Assigned to Milestone
bcmwl (Ubuntu)
High
Unassigned
Nominated for Trusty by Daniel van Vugt
Precise
High
Unassigned
Trusty
High
Unassigned
Vivid
High
Unassigned

Bug Description

bcmwl-kernel-source 6.30.223.248+bdcom-0ubuntu2: bcmwl kernel module failed to build

ProblemType: Package
DistroRelease: Ubuntu 15.04
Package: bcmwl-kernel-source 6.30.223.248+bdcom-0ubuntu2
ProcVersionSignature: Ubuntu 3.18.0-13.14-generic 3.18.5
Uname: Linux 3.18.0-13-generic x86_64
NonfreeKernelModules: wl
ApportVersion: 2.16.1-0ubuntu2
Architecture: amd64
DKMSKernelVersion: 4.0.0-040000rc1-generic
Date: Mon Feb 23 18:14:07 2015
DuplicateSignature: dkms:bcmwl-kernel-source:6.30.223.248+bdcom-0ubuntu2:/var/lib/dkms/bcmwl/6.30.223.248+bdcom/build/src/wl/sys/wl_cfg80211_hybrid.c:1444:20: error: ‘STATION_INFO_TX_BITRATE’ undeclared (first use in this function)
InstallationDate: Installed on 2014-11-22 (93 days ago)
InstallationMedia: Ubuntu 15.04 "Vivid Vervet" - Alpha amd64 (20141121)
PackageVersion: 6.30.223.248+bdcom-0ubuntu2
SourcePackage: bcmwl
Title: bcmwl-kernel-source 6.30.223.248+bdcom-0ubuntu2: bcmwl kernel module failed to build
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

rolmops (dr150259) wrote :
summary: bcmwl-kernel-source 6.30.223.248+bdcom-0ubuntu2: bcmwl kernel module
- failed to build
+ failed to build [error: ‘STATION_INFO_TX_BITRATE’ undeclared (first use
+ in this function)]
Rodrigo-vivi (rodrigo-vivi) wrote :

Also change STATION_INFO_SIGNAL to BIT(NL80211_STA_INFO_SIGNAL)

Michael Leuchtenburg (dyfrgi) wrote :

This fixes the build issue and also silences a couple of warnings. I suppose you could edit out the warning silencing if you hate clean builds, or move it into a different patch.

Also needs to be added to dkms.conf:
PATCH[9]="0017-add-support-for-Linux-4.0.patch"

The attachment "0017-add-support-for-Linux-4.0.patch" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
tags: removed: need-duplicate-check
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in bcmwl (Ubuntu):
status: New → Confirmed
Changed in bcmwl (Ubuntu):
importance: Undecided → High
Simon Eisenmann (longsleep) wrote :

I added the latest patches. See here https://github.com/longsleep/bcmwl-ubuntu/commit/8be1d3cdcbfe42dc8e8832617deddfdcb678b09e

This patch can be applied to all currently maintained bcmwl packaging versions, and allows it to compile cleanly on Linux 4.0

Danny Stieben (dmaxel) wrote :

This fix needs to be pushed for 15.04. In the meantime, how do you compile it? The README has no instructions.

Just a little input, if you have recently upgraded your kernel, and your dkms fails to reinsert, a simpler way to fix this than the above instructions would be as follows:

gksudo gedit /usr/src/bcmwl-6.30.223.248+bdcom/src/wl/sys/wl_cfg80211_hybrid.c

Search for

STATION_INFO_TX_BITRATE;

replace as described above by Rodrigo-vivi with:

BIT(NL80211_STA_INFO_TX_BITRATE);

and search for

STATION_INFO_SIGNAL

replace with:

BIT(NL80211_STA_INFO_SIGNAL)

and then simply run

sudo dkms install bcmwl/6.30.223.248+bdcom

and let dkms take care of the making and inserting for you. Then reboot and you should be good to go. This worked for me in Vivid Vervet 15.04

summary: bcmwl-kernel-source 6.30.223.248+bdcom-0ubuntu2: bcmwl kernel module
- failed to build [error: ‘STATION_INFO_TX_BITRATE’ undeclared (first use
- in this function)]
+ failed to build with kernel 4.0 [error: ‘STATION_INFO_TX_BITRATE’
+ undeclared (first use in this function)]
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bcmwl - 6.30.223.248+bdcom-0ubuntu3

---------------
bcmwl (6.30.223.248+bdcom-0ubuntu3) wily; urgency=medium

  [ Simon Eisenmann ]
  * debian/dkms.conf.in
    debian/patches/0016-repair-make-warnings.patch
    debian/patches/0017-add-support-for-Linux-4.0.patch
    - Fixed make warnings
      Credit for the patch goes to Krzysztof Kolasa.
    - Add support for Linux 4.0 (LP: #1424676)
      Credit for the patch goes to Krzysztof Kolasa.

 -- Mario Limonciello <email address hidden> Mon, 11 May 2015 18:22:09 -0500

Changed in bcmwl (Ubuntu):
status: Confirmed → Fix Released
Astrid (beastlife42) wrote :

Hello,
I could have my wireless connection on Acer Aspire V3-471G with the card BCM43228 all in good order after upgrading from Trusty Thar to kernel Wily 4.0.4 by installing the package bcmwl - 6.30.223.248+bdcom-0ubuntu3.

To achieve this, I downloaded http://launchpadlibrarian.net/206246268/bcmwl-kernel-source_6.30.223.248%2Bbdcom-0ubuntu3_amd64.deb and used the command dpkg in the Terminal to build the module on my machine.

Thank you !

Tanguy Pruvot (tanguy-pruvot) wrote :

For the "Linux 4.0" patch... a simple define is enough :

+#define STATION_INFO_TX_BITRATE BIT(NL80211_STA_INFO_TX_BITRATE)
+#define STATION_INFO_SIGNAL BIT(NL80211_STA_INFO_SIGNAL)

Changed in bcmwl (Ubuntu):
assignee: nobody → Rafael David Tinoco (inaddy)
Brian Murray (brian-murray) wrote :

See Bug #1415880 for the test case.

Changed in bcmwl (Ubuntu Vivid):
status: New → Fix Committed
tags: added: verification-needed

Hello rolmops, or anyone else affected,

Accepted bcmwl into vivid-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/bcmwl/6.30.223.248+bdcom-0ubuntu2.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Brian Murray (brian-murray) wrote :

Hello rolmops, or anyone else affected,

Accepted bcmwl into precise-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/bcmwl/6.30.223.248+bdcom-0ubuntu0.0.3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Sqoorch (sqoorch) wrote :

Hi, I've installed bcmwl-kernel-source (6.30.223.248+bdcom-0ubuntu0.2) from trusty-proposed, xubuntu@linux-generic-lts-wily (4.2.0.25.19).
Works great for me - BCM43228 is now on! Thanks a lot.

Changed in bcmwl (Ubuntu Vivid):
importance: Undecided → High
PARTH (parth17pandya) wrote :

sudo apt-get update && sudo apt-get upgrade

E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem.
parth@parth-Inspiron-1525:~$ sudo dpkg --configure -a
Setting up ibus-gtk3:i386 (1.5.5-1ubuntu3.2) ...
Setting up duplicity (0.6.23-1ubuntu4.2) ...
Processing triggers for initramfs-tools (0.103ubuntu4.3) ...
update-initramfs: Generating /boot/initrd.img-3.13.0-24-generic
Setting up bcmwl-kernel-source (6.30.223.248+bdcom-0ubuntu0.2) ...
Removing old bcmwl-6.30.223.248+bdcom DKMS files...

-------- Uninstall Beginning --------
Module: bcmwl
Version: 6.30.223.248+bdcom
Kernel: 3.13.0-24-generic (i686)
-------------------------------------

Status: Before uninstall, this module version was ACTIVE on this kernel.

wl.ko:
 - Uninstallation
   - Deleting from: /lib/modules/3.13.0-24-generic/updates/dkms/
 - Original module
   - No original module was found for this module on this kernel.
   - Use the dkms install command to reinstall any previous module version.

depmod.......

DKMS: uninstall completed.

------------------------------
Deleting module version: 6.30.223.248+bdcom
completely from the DKMS tree.
------------------------------
Done.
Loading new bcmwl-6.30.223.248+bdcom DKMS files...
Building only for 3.13.0-24-generic
Building for architecture i686
Building initial module for 3.13.0-24-generic
Done.

wl:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/3.13.0-24-generic/updates/dkms/

depmod....

DKMS: install completed.

thats it, nothing moves ahead..... the process keeps on running....

exit terminal and then again gave

sudo apt-get update && sudo apt-get upgrade
.
.
.

The following packages were automatically installed and are no longer required:
  linux-tools-3.13.0-66 linux-tools-3.13.0-66-generic
Use 'apt-get autoremove' to remove them.
The following packages have been kept back:
  liboxideqt-qmlplugin liboxideqtcore0 liboxideqtquick0 linux-tools-generic
  linux-tools-virtual-lts-utopic oxideqt-codecs-extra
0 upgraded, 0 newly installed, 0 to remove and 6 not upgraded.
1 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n] y
Setting up bcmwl-kernel-source (6.30.223.248+bdcom-0ubuntu0.2) ...
Removing old bcmwl-6.30.223.248+bdcom DKMS files...

the same thing...!!!

The version of bcmwl in the proposed pocket of Vivid that was purported to fix this bug report has been removed because the bugs that were to be fixed by the upload were not verified in a timely (105 days) fashion.

Changed in bcmwl (Ubuntu Vivid):
status: Fix Committed → Won't Fix
tags: removed: verification-needed
Mathew Hodson (mathew-hodson) wrote :

There is still a package in precise-proposed that needs verification.

I am sure about the Trusty task. It may have been fixed with Bug #1518956.

tags: added: verification-needed
Martin Pitt (pitti) wrote :

The version of bcmwl in the proposed pocket of Precise that was purported to fix this bug report has been removed because the bugs that were to be fixed by the upload were not verified in a timely (105 days) fashion.

Changed in bcmwl (Ubuntu Precise):
status: New → Won't Fix

Hello rolmops, or anyone else affected,

Accepted bcmwl into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/bcmwl/6.30.223.271+bdcom-0ubuntu1~0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in bcmwl (Ubuntu Trusty):
status: New → Fix Committed
Changed in bcmwl (Ubuntu Trusty):
importance: Undecided → High
Changed in bcmwl (Ubuntu Precise):
importance: Undecided → High
Changed in bcmwl (Ubuntu):
assignee: Rafael David Tinoco (inaddy) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers