Comment 63 for bug 1415880

Martin Oemus (martqn) wrote :

For a while I stopped using suspend and it seemed promising, but today I experienced problems directly after booting.

1)
I'm afraid the log I posted earlier was not very meaningful. I triggered the behaviour by closing the lid of my laptop because this was a way to safely reproduce the issues. This seems to be a physical problem of my laptop. Probably the wifi antenna gets shielded when the lid is closed. In Windows 7 connection quality drops significantly and bandwidth goes down to 300 KB/s. In Linux the connection goes down completely (ping says Network is unreachable), produces the messages I posted earlier, including the call traces.
As annyoing as this is, it is probably nothing we can do anything about. The driver might not work as efficient as in Windows but that's it.

2)
----
This only means that broadcom WL driver tried to warn kernel that it roamed from one AP to another and new BSS could not be found (meaning that the card could not get all its new BSS - peers, APs, etc).
----
My network consists only of one BSS (router), but I tried it anyway. I set the mac address of my router in the BSSID field in the networkmanager interface. This didn't change anything at all, I still got call traces, indicating, according to you, failed roaming attempts.

3)
I attached the syslog from this morning. The problems start at 11:40:16 with 2 call traces. At 11:40:57 wpa_supplicant gives CTRL-EVENT-ASSOC-REJECT messages. Google recommends blacklisting certain modules, but none of them are loaded on my system. Another call trace follows and networkmanager says it's disconnected. It goes on a bit and finally re-establishes the connection. This seems to be more or less stable for already two hours or so.

I really don't know what to make of this. I can't see a distinct pattern. I'm not dependent on Wifi, so it's not a big deal.
Yet I'm still interested in solving this issue. My next step would be to test the whole thing without networkmanager and see how things are then because I think networkmanager really complicates debugging this. I wanted to explicitely set wpa_supplicant to use WPA2-CCMP only because in some setups I experienced connection problems when this wasn't explicitely set, but networkmanager doesn't offer me a way to do this.