Add support for the backported lts-utopic stack

Bug #1397028 reported by Alberto Milone on 2014-11-27
34
This bug affects 6 people
Affects Status Importance Assigned to Milestone
bcmwl (Ubuntu)
High
Unassigned
Precise
High
Alberto Milone
Trusty
High
Alberto Milone

Bug Description

SRU request:

[Impact]

 * As a result of this bug, bcmwl-kernel-source will fail to build the module against linux-generic-lts-utopic in Ubuntu 14.04.2.

[Test Case]

 * Enable the trusty-proposed repository and install bcmwl-kernel-source (6.30.223.248+bdcom-0ubuntu0.1).

 * Install linux-generic-lts-utopic

 * If the package installs without errors from DKMS with both the linux-generic and linux-generic-lts-utopic kernels, then the patches work correctly.

[Regression Potential]

 * The patches that I backported from 15.04 will preserve the current driver behaviour on linux-generic (3.13) and linux-generic-lts-utopic (3.16), thanks to the use of specific macros in the code which check the kernel version. As a result, no regressions of any kind can be expected on these kernels. As a plus, support for kernels up to 3.18 is also included.

Changed in bcmwl (Ubuntu):
assignee: nobody → Alberto Milone (albertomilone)
importance: Undecided → High
status: New → In Progress
Changed in bcmwl (Ubuntu Trusty):
status: New → In Progress
importance: Undecided → High
assignee: nobody → Alberto Milone (albertomilone)
Changed in bcmwl (Ubuntu):
status: In Progress → Invalid
assignee: Alberto Milone (albertomilone) → nobody
importance: High → Undecided
Changed in bcmwl (Ubuntu Trusty):
milestone: none → ubuntu-14.04.2
description: updated
Changed in bcmwl (Ubuntu Precise):
status: New → In Progress
importance: Undecided → High
assignee: nobody → Alberto Milone (albertomilone)

Hello Alberto, or anyone else affected,

Accepted bcmwl into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/bcmwl/6.30.223.248+bdcom-0ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in bcmwl (Ubuntu Trusty):
status: In Progress → Fix Committed
tags: added: verification-needed
Brian Murray (brian-murray) wrote :

Hello Alberto, or anyone else affected,

Accepted bcmwl into precise-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/bcmwl/6.30.223.248+bdcom-0ubuntu0.0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in bcmwl (Ubuntu Precise):
status: In Progress → Fix Committed
Yuriy Samarin (yosamarin) wrote :

After updating to 14.04.2 from 14.04.1 i have a many dependency problems in pakages.

Can't install WINE:
libglapi-mesa
libosmesa6

FGLRX:
libgl1-mesa-dri
xserver-xorg-core

Tholl1989 (mariajcore) wrote :

Tested package 'trusty-proposed/restricted bcmwl-kernel-source amd64 6.30.223.248+bdcom-0ubuntu0.1' on Ubuntu 14.04.2 against kernel 3.13.0-46-generic and 3.16.0-31-generic x86_64.
Builds and works.

tags: added: verification-done
removed: verification-needed
Tholl1989 (mariajcore) wrote :
tags: added: verification-done-trusty verification-needed-precise
removed: verification-done
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bcmwl - 6.30.223.248+bdcom-0ubuntu0.1

---------------
bcmwl (6.30.223.248+bdcom-0ubuntu0.1) trusty-proposed; urgency=medium

  * New upstream release (LP: #1397028):
    - This is an official public release from Broadcom.
  * debian/patches/0013-gcc.patch
    - Fix build with recent versions of GCC. Credit
      for the patch goes to Robert Ancell.
  * debian/dkms.conf.in,
    debian/patches/0014-add-support-for-Linux-3.17.patch,
    debian/patches/0015-add-support-for-Linux-3.18.patch:
    - Drop patches for kernels 3.10 (now upstream)
    - Add support for Linux 3.17.
      Credit for the patch goes to Brian Norris.
    - Add support for Linux 3.18.
      Credit for the patch goes to Krzysztof Kolasa.
 -- Alberto Milone <email address hidden> Thu, 27 Nov 2014 16:36:00 +0100

Changed in bcmwl (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for bcmwl has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

The fix for this bug has been awaiting testing feedback in the -proposed repository for precise for more than 90 days. Please test this fix and update the bug appropriately with the results. In the event that the fix for this bug is still not verified 15 days from now, the package will be removed from the -proposed repository.

tags: added: removal-candidate

The version of bcmwl in the proposed pocket of Precise that was purported to fix this bug report has been removed because the bugs that were to be fixed by the upload were not verified in a timely (105 days) fashion.

tags: removed: verification-needed-precise
Changed in bcmwl (Ubuntu Precise):
status: Fix Committed → Won't Fix
Yung Shen (kaxing) wrote :

sorry for the late verification, this one had been ran off the net.

In recent SRU testing cycles, and according to my comment below, the fix for works fine with latest precise kernel:

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1474801/comments/7

Changed in bcmwl (Ubuntu Precise):
status: Won't Fix → Fix Committed
tags: added: verification-done-precise
tags: added: verification-done

Hello Alberto, or anyone else affected,

Accepted bcmwl into precise-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/bcmwl/6.30.223.248+bdcom-0ubuntu0.0.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: removed: verification-done
tags: added: verification-needed
tags: removed: removal-candidate verification-done-precise
Yung Shen (kaxing) wrote :

bcmwl-kernel-source 6.30.223.248+bdcom-0ubuntu0.0.2 had been tested on multiple systems with proposed kernels.

detailed information can be found in following tracker bugs:
3.2.0-90.128: bug #1485173
3.13.0-63.104~precise1: bug #1485081

tags: added: verification-done verification-done-precise
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bcmwl - 6.30.223.248+bdcom-0ubuntu0.0.2

---------------
bcmwl (6.30.223.248+bdcom-0ubuntu0.0.2) precise-proposed; urgency=medium

  * New upstream release (LP: #1397028):
    - This is an official public release from Broadcom.
  * debian/patches/0013-gcc.patch
    - Fix build with recent versions of GCC. Credit
      for the patch goes to Robert Ancell.
  * debian/dkms.conf.in,
    debian/patches/0014-add-support-for-Linux-3.17.patch,
    debian/patches/0015-add-support-for-Linux-3.18.patch:
    - Drop patches for old kernels (now upstream)
    - Add support for Linux 3.17.
      Credit for the patch goes to Brian Norris.
    - Add support for Linux 3.18.
      Credit for the patch goes to Krzysztof Kolasa.

 -- Alberto Milone <email address hidden> Fri, 14 Aug 2015 12:46:43 +0200

Changed in bcmwl (Ubuntu Precise):
status: Fix Committed → Fix Released
Changed in bcmwl (Ubuntu):
status: Invalid → Fix Released
importance: Undecided → High
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments