bcmwl-kernel-source 6.30.223.141+bdcom-0ubuntu3: bcmwl kernel module failed to build [error: macro "__DATE__" might prevent reproducible builds [-Werror=date-time]]

Bug #1328858 reported by Andrea Cimitan
56
This bug affects 10 people
Affects Status Importance Assigned to Milestone
bcmwl (Ubuntu)
Critical
Robert Ancell
Nominated for Trusty by Daniel van Vugt

Bug Description

New kernel, doesn't build

ProblemType: Package
DistroRelease: Ubuntu 14.10
Package: bcmwl-kernel-source 6.30.223.141+bdcom-0ubuntu3
ProcVersionSignature: Ubuntu 3.13.0-19.40-generic 3.13.6
Uname: Linux 3.13.0-19-generic x86_64
NonfreeKernelModules: nvidia wl
ApportVersion: 2.14.3-0ubuntu1
Architecture: amd64
DKMSKernelVersion: 3.15.0-5-generic
Date: Wed Jun 11 10:23:39 2014
DuplicateSignature: dkms:bcmwl-kernel-source:6.30.223.141+bdcom-0ubuntu3:/var/lib/dkms/bcmwl/6.30.223.141+bdcom/build/src/wl/sys/wl_linux.c:2047:3: error: macro "__DATE__" might prevent reproducible builds [-Werror=date-time]
InstallationDate: Installed on 2014-03-22 (80 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Alpha amd64 (20140321)
PackageVersion: 6.30.223.141+bdcom-0ubuntu3
SourcePackage: bcmwl
SystemImageInfo: Error: [Errno 2] No such file or directory: 'system-image-cli'
Title: bcmwl-kernel-source 6.30.223.141+bdcom-0ubuntu3: bcmwl kernel module failed to build
UpgradeStatus: Upgraded to utopic on 2014-05-20 (21 days ago)

Revision history for this message
Andrea Cimitan (cimi) wrote :
tags: removed: need-duplicate-check
summary: bcmwl-kernel-source 6.30.223.141+bdcom-0ubuntu3: bcmwl kernel module
- failed to build
+ failed to build [error: macro "__DATE__" might prevent reproducible
+ builds [-Werror=date-time]]
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in bcmwl (Ubuntu):
status: New → Confirmed
Changed in bcmwl (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Critical
Revision history for this message
Robert Ancell (robert-ancell) wrote :

Used the gcc.patch from https://aur.archlinux.org/packages/broadcom-wl - this disables the warning in GCC with -Wno-date-time

Changed in bcmwl (Ubuntu):
assignee: nobody → Robert Ancell (robert-ancell)
Changed in bcmwl (Ubuntu):
status: Triaged → In Progress
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bcmwl - 6.30.223.141+bdcom-0ubuntu4

---------------
bcmwl (6.30.223.141+bdcom-0ubuntu4) utopic; urgency=medium

  * debian/patches/0013-gcc.patch:
    - Fix build with recent version of GCC (LP: #1328858)
 -- Robert Ancell <email address hidden> Fri, 01 Aug 2014 10:38:46 +1200

Changed in bcmwl (Ubuntu):
status: In Progress → Fix Released
Revision history for this message
Daniel van Vugt (vanvugt) wrote :

Still happening on trusty, obviously. See duplicates.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers