bcmwl-kernel-source 6.30.223.141+bdcom-0ubuntu2: bcmwl kernel module failed to build [error: too few arguments to function ‘cfg80211_ibss_joined’]

Bug #1307744 reported by Hegedus Lehel on 2014-04-14
162
This bug affects 33 people
Affects Status Importance Assigned to Milestone
bcmwl (Ubuntu)
High
Alberto Milone

Bug Description

installation of the kernel 3.15-RC1 on trusty...

ProblemType: Package
DistroRelease: Ubuntu 14.04
Package: bcmwl-kernel-source 6.30.223.141+bdcom-0ubuntu2
ProcVersionSignature: Ubuntu 3.13.0-24.46-generic 3.13.9
Uname: Linux 3.13.0-24-generic x86_64
NonfreeKernelModules: wl
ApportVersion: 2.14.1-0ubuntu2
Architecture: amd64
DKMSKernelVersion: 3.15.0-031500rc1-generic
Date: Tue Apr 15 01:19:44 2014
DuplicateSignature: dkms:bcmwl-kernel-source:6.30.223.141+bdcom-0ubuntu2:/var/lib/dkms/bcmwl/6.30.223.141+bdcom/build/src/wl/sys/wl_cfg80211_hybrid.c:1844:4: error: too few arguments to function ‘cfg80211_ibss_joined’
InstallationDate: Installed on 2014-04-13 (1 days ago)
InstallationMedia: Xubuntu 14.04 LTS "Trusty Tahr" - Beta amd64 (20140326)
PackageVersion: 6.30.223.141+bdcom-0ubuntu2
SourcePackage: bcmwl
Title: bcmwl-kernel-source 6.30.223.141+bdcom-0ubuntu2: bcmwl kernel module failed to build
UpgradeStatus: No upgrade log present (probably fresh install)

Hegedus Lehel (lehel) wrote :
summary: bcmwl-kernel-source 6.30.223.141+bdcom-0ubuntu2: bcmwl kernel module
- failed to build
+ failed to build [error: too few arguments to function
+ ‘cfg80211_ibss_joined’]
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in bcmwl (Ubuntu):
status: New → Confirmed
Bernardo Reino (reinob) wrote :

Just a quick note that this is caused by some change between kernel 3.14 (i.e. bcmwl compiled fine on 3.14) and 3.15 (here it fails to compile). The bcmwl regularly needs patches to keep up to date with the kernel.

This has nothing to do with trusty (I run precise).

tags: removed: need-duplicate-check
David Hoffmann (davidhoffmann) wrote :

I found a solution for that problem.
http://ubuntuforums.org/showthread.php?t=2216779&page=2

volker kempter (v-kempter) wrote :

affects me too:
no wifi after installation of kernel, version 3.15 rc4 (or version 3.15.0-0.1 in the ppa of the canonical kernel team). On the other hand, network connection via cable works. Should mention that wifi works fine with kernel 3.14. Also interesting: problem occcurs both with Lubuntu 14.04 qnd Lubuntu 14.10

Changed in bcmwl (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Alberto Milone (albertomilone)
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bcmwl - 6.30.223.141+bdcom-0ubuntu3

---------------
bcmwl (6.30.223.141+bdcom-0ubuntu3) utopic; urgency=medium

  * debian/patches/0012-add-support-for-Linux-3.15.patch:
    - Add support for Linux 3.15 (LP: #1307744).
 -- Alberto Milone <email address hidden> Mon, 12 May 2014 18:33:36 +0200

Changed in bcmwl (Ubuntu):
status: In Progress → Fix Released
Xabi Ezpeleta (xezpeleta) wrote :

Same problem here in a fresh Ubuntu 14.04.2 LTS installation. I can't see the wireless interface.

Kernel 3.16.0-30-generic
bcmwl-kernel-source 6.30.223.141

What can I do?

Thanks in advance

Xabi Ezpeleta (xezpeleta) wrote :

Here more info:

user@myhost:~$ sudo dpkg-reconfigure bcmwl-kernel-source
Removing all DKMS Modules
Done.
Loading new bcmwl-6.30.223.141+bdcom DKMS files...
Building only for 3.16.0-30-generic
Building for architecture x86_64
Building initial module for 3.16.0-30-generic
Error! Bad return status for module build on kernel: 3.16.0-30-generic (x86_64)
Consult /var/lib/dkms/bcmwl/6.30.223.141+bdcom/build/make.log for more information.
modprobe: FATAL: Module wl not found.
update-initramfs: deferring update (trigger activated)
Processing triggers for initramfs-tools (0.103ubuntu4.2) ...
update-initramfs: Generating /boot/initrd.img-3.16.0-30-generic

Xabi Ezpeleta (xezpeleta) wrote :

I also attach make.log file

W. Milszus (milszus) wrote :

Solution from #4 works on the new occurence 14.04.2 LTS, too.
You have to change the target kernel name "3.15.0-031500rc1-generic" to "3.16.0-30-generic" and proceed.

Xabi Ezpeleta (xezpeleta) wrote :

Thanks W. Milszus, It works like a charm.

Keeping it simple, i've followed those steps to solve the problem:

1. Replace the file /usr/src/bcmwl-6.30.223.141+bdcom/src/wl/sys/wl_cfg80211_hybrid.c with this one: https://gist.githubusercontent.com/xezpeleta/b6b13a70ad70c7c22128/raw/88c66b974022a5f9f0770f35f5bb886c2c975961/wl_cfg80211_hybrid.c

2. Run this command: sudo dpkg-reconfigure bcmwl-kernel-source

iliyas (ilu25) wrote :

Thanks Xabi Ezpeleta, It worked perfectly the first time.

Matt Hanyok (matthew-hanyok) wrote :

I see on 2014-05-13 it says:

"This bug was fixed in the package bcmwl - 6.30.223.141+bdcom-0ubuntu3"

Why wasn't the updated package, from 9 months ago, included in 14.04.2's install? That would have fixed the issue easily.

For anyone having this problem, rather than do code editing and compiling and everything mentioned above, you can grab the bcmwl-kernel-source package for Utopic (14.10) from here:

http://packages.ubuntu.com/utopic/bcmwl-kernel-source

Download the amd64 or i386 version, whichever you need, and install it (note: you will still need dkms installed on your system to install it). I just double-clicked it and let Ubuntu Software Centre do the install. That got my wireless interface on and working as expected.

Can we get the updated package put into the Trusty repositories, or have the Utopic one added to the backports?

doggoneit (byspec) wrote :

Thanks Matt!! When I got my Inspiron 910 I wiped XP and installed Ubuntu. I went through all of this then with 12.10 but couldnt remember how I fixed it. When I upgraded to 13.10 it still worked but I kept getting System Problem Detected messages. I then upgraded to 14.04 but the error messages continued while the wifi kept working. So I wiped and installed 14.04.2 last night and guess what, no wifi at all. Thanks to you it was an easy fix. My only concern is that future updates might break it?

Matt Hanyok (matthew-hanyok) wrote :

It's possible, but for your system to see it as an update it'd have to be a newer version than the one you've installed.

So if the respository is updated with a refresh of the version that shipped with 14.04.2, and it does an update, that refresh should contain the fix (according to the info on 2014-05-13). And if it doesn't see it as an update (because the version that shipped with 14.10 is a higher version number) then you'll be fine.

I'd suggest keeping the package in your downloads folder or somewhere in case you have to reinstall, or if something funky happens 14.04.3 comes out.

Same issue for me today with a fresh install of 14.04_2 downloaded yesterday and installed on a lenovo n500 today. No wifi. reply #11 works fine for me. Hopefully will stay working regardless of future updates...

John Jelinek (john-z) wrote :

+1 on Post #13. Works with Fresh 14.04.2 install.

Michael Thomas (mimotomo2009) wrote :

+1 to Post #13. Works fine on an updated 64Bit Lenovo Thinkpad Edge E145 (from 14.04.1 to 14.04.2 via sudo apt-get install --install-recommends linux-generic-lts-utopic xserver-xorg-lts-utopic libgl1-mesa-glx-lts-utopic libegl1-mesa-drivers-lts-utopic). This packages should be included (or upgraded from 6.30.223.141+bdcom-0ubuntu2 to) 6.30.223.248+bdcom-0ubuntu1 in Ubuntu 14.04.2.

Kenedy Silva (kenedyrms) wrote :

I just install new ubuntu 14.04.2 and no wifi after install this package :(

jsmitch (jsmitchger) wrote :

same here. Fresh install yesterday on vostro 1500. WLAN mini card not recognized. Driver build fails. Tried one of the fixes mentioned in this thread -- that failed as well.

steph (stephanie-lassieur) wrote :

on Acer lap top same thing wifi does not work. on the top of the page, bug status says fixed... Where to find the fix?
Thank you

steph (stephanie-lassieur) wrote :

Sorry I red again more carrefully and post 13 worked fine. Thank you

jsmitch (jsmitchger) wrote :

no joy using #13 solution--package fails:

 dpkg: dependency problems prevent configuration of bcmwl-kernel-source:
 bcmwl-kernel-source depends on dkms.

dpkg: error processing package bcmwl-kernel-source (--install):
 dependency problems - leaving unconfigured

Matt Hanyok (matthew-hanyok) wrote :

hi jsmitch -

you'll need to install the package "dkms" for the package listed in #13 to install. Normally it's installed when you attempt to update the proprietary driver module, but if you're on a fresh install and haven't done that, worry not.

The dkms package is located on the Ubuntu install media, at /pool/main/d/dkms - on the 14.04.2 media, the filename is "dkms_2.2.0.3-1.1ubuntu5.14.04_all.deb". Install that first, then install the bcmwl package file.

Also, related to this bug: I have a second system which was running 14.04.1 and I followed the instruction to "opt in" to the hardware enablement stack on that system, rather than doing a fresh install. Instructions for doing so are outlined here:

https://wiki.ubuntu.com/Kernel/LTSEnablementStack

I was surprised to find that doing so pulled down the updated bcmwl package automatically and did not require a manual install after the fact. So for those of you who are on a 14.04/14.04.1 install, rather than do a fresh install of 14.04.2, you may want to just run that first command listed to get the new kernel and other packages. It may save you some headache.

It looks like someone just didn't think to bundle the updated package with the 14.04.2 install media. Is there a chance the media image can be refreshed to include the updated bcmwl package, so future users won't have this problem? If not, can we mark this for 14.04.3 to ensure the problem is resolved with a new point release?

John Belton (jbelton1950) wrote :

This happened when I reinstalled my Dell Vostro 1510 laptop's system, the previous system was working and running Ubuntu 14.04.2, I noticed the kernel has changed so it must be soemthing to do with that. I have to use the laptop wirelessly to avoid thirty metre trailing all over the place!
I'll try installing from an older package.

GillesMelon (gilles-melon) wrote :

Solution #13 worked well with my fresh Ubuntu 14.04.2 fresh install on my old iMac 2008.
Many thanks.

Franck78 (fbourdonnec) wrote :

just unbelievable this bug fix is not included while installing from a fresh LTS 14.04.02 iso; yes LTS. You know what that means LTS ???

I install an LTS on some friend PC and it is a big fail for a stupid bug, in front of him. The worse situation to make Ubuntu a weak alternative. My friend : "see, your 'thing' have no wifi, ah, ah, going back to W7"

FOR SOMETHING KNOWN SINCE April 2014 !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

thanks to Matt

I still had this very same bug on an Asus f555l, I managed to get it working with package bcmwl-kernel-source_6.30.223.248+bdcom-0ubuntu1_amd64.deb which is not the one from the repos. I do not understand if the bug is going to be actually fixed or what.

Same issue reoccured here, on my dell-vostro 3560.

It's 07.03.2015!!! No network after fresh install!! Horrible!!

Solution from #11 worked well, but had to buy a network cable first!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers