Broadcom 4313 causes heavy interference with wireless clients after 13.04 upgrade

Bug #1174145 reported by Matt Weeks on 2013-04-29
62
This bug affects 11 people
Affects Status Importance Assigned to Milestone
bcmwl (Ubuntu)
Undecided
Unassigned

Bug Description

After Ubuntu 13.04 upgrade, other wireless clients cannot access my WPA2-AES-PSK home network. They encounter high packet loss when physically near my Ubuntu system, but function fine when physically close to the wireless router and away from my system or when my system is off. My system appears to be causing heavy interference with the other clients.

My wireless adapter is a Broadcom 4313 (built into the HP G72 laptop).

Interference starts on boot and runs continuously until poweroff, even when my system should not be transmitting or receiving network packets.

This began happening just after upgrading to 13.04, and did not happen with earlier versions of Ubuntu. I have been updating daily.

The wireless network is visible (not hidden SSID), and in mixed 802.11n/g mode.

I do not see unexpected network traffic on the wireless network card when running Wireshark on the offending system, although I can only see the ethernet packets; I cannot seem to put my card into monitor mode.

If necessary, I should be able to get a third computer capturing packets in monitor mode to see if my system is flooding RF packets, but that would require a bunch of time to set up.

Matt Weeks (scriptjunkie) wrote :

Card info:

# lspci -vvnn | grep 14e4
03:00.0 Network controller [0280]: Broadcom Corporation BCM4313 802.11b/g/n Wireless LAN Controller [14e4:4727] (rev 01)

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu:
status: New → Confirmed

I also have "kernel panics" (really doesn't, but very similar). Possibly caused by wireless process ioctl fault. Sorry I haven't any picture or more specific information but definitly is the wireless LAN.

Bill Askaga (bill-askaga) wrote :

Affects me as well with standard Ubuntu. However, using Ubuntu Gnome 13.04 live cd, i have no problems at all.

Bill Askaga (bill-askaga) wrote :

Update: After installation of Ubuntu Gnome on disk the problem reappeared.

Finally I could take a picture of the error I meant. It usually occurs after unsuccessfully trying to suspend. Also occurs spontaneously. Like Weeks, smartphones and laptops cannot properly access to the Internet.

Stephen (realakshun) wrote :

I can also confirm this behaviour on my Dell latitude E6430

lspci -vvnn | grep 14e4
03:00.0 Network controller [0280]: Broadcom Corporation BCM4313 802.11b/g/n Wireless LAN Controller [14e4:4727] (rev 01)

When the adapter is turned on, other wifi devices experience wifi interference and signal loss. When the adapter is turned off, other devices function normally.

Issue appeared after installing 13.04. Previous versions did not exhibit this behaviour.

netgull (glarosk) wrote :

Similar behaviour here with Ubuntu 12.04 after recent updates.
lspci -vvnn | grep 14e4
02:00.0 Network controller [0280]: Broadcom Corporation BCM4313 802.11b/g/n Wireless LAN Controller [14e4:4727] (rev 01)

With the proprietary driver disabled the problem goes away.

Stephen (realakshun) wrote :

disabling the proprietary driver does not resolve the issue on my Dell E6430

Dan O'Donovan (dodonovan) wrote :

Uninstalling the Broadcom 'wl' driver worked for me (on a Dell Vostro 3500 with BCM4313 PCI wireless adapter). The open-source brcmsmac driver that gets loaded instead of it doesn't have this problem.

To switch from 'wl' to 'brcmsmac' (on Ubuntu 13.04 anyway), simply:
  sudo apt-get remove bcmwl-kernel-source
(might need to reboot after that, or run 'sudo modprobe brcmsmac', if the new driver doesn't load automatically)

Stephen (realakshun) wrote :

I have previously disabled this driver in softtware sources ->additional drivers;

"Package 'bcmwl-kernel-source' is not installed, so not removed"

Yet the issue remains, I do not think this is solely a driver issue. What else can I do to debug?

bkloppenborg (bkloppenborg) wrote :

I just compared the current version (6.20.155.1) of bcmwl-kernel-source against the 5.100.82.112 version of the driver from quantal (downloaded from http://packages.ubuntu.com/raring/amd64/bcmwl-kernel-source/download)

Experimental setup was as follows:

Computer A: BCM4313 on Windows pinging off-site machine
Computer B: BCM4313 Linux box pinging same off-site machine

Prior to activating computer B's wifi, computer A had no ping timeouts in five minutes. After activating wifi on computer B with the 6.x driver, computer A had several ping timeouts within 1 minute. Upon shutting off wifi on computer B, computer A had no ping timeouts. This behavior has already been established by posts above, but is confirmed on my machine.

Then I installed the 5.x version of the driver using `dpkg -i` and repeated the experiment. As before prior to activating wifi on machine B, there were no ping timeouts on computer A. I turn on computer B's wifi and started pinging. Computer A had NO ping timeouts within three minutes. Then I started watching a video on YouTube. Computer A's ping times increased slightly (competing for bandwidth). After five minutes, only ONE ping timeout on computer A occurred.

So it would appear something changed between the 5.100.82.112 and 6.20.155.1 version of the drivers. Because I have a nice setup here and there were seven commits between these driver versions so I can probably debug this. Prior to me doing this though, can someone else check that they receive no interference with the 5.100.82.112 version of the driver.

Thanks.

Mounir (mounir-assaf) wrote :

I confirm that the current version of the driver bcmwl-kernel-source_6.20.155.1 on my dell E6520 laptop creates severe interferences with other wifi devices.
I just did the same test as above, after installing the same older version of the driver bcmwl-kernel-source_5.100.82.112, and it works just fine now.
The bug must have been introduced between those two versions 5.100.82.112 and 6.20.155.1.

bkloppenborg (bkloppenborg) wrote :

Interference cause tracked to changes of bcmwl-kernel-source between 5.100.82.112 and 6.20.155.1.

affects: ubuntu → bcmwl (Ubuntu)
bkloppenborg (bkloppenborg) wrote :

To make my comment above a little more specific, the version of bcmwl-kernel-source that does not cause interference in my tests is 5.100.82.112+bdcom-0ubuntu3 (the last release for quantal).

bkloppenborg (bkloppenborg) wrote :

And fixing a typo in #12, the quantal version comes from here:
http://packages.ubuntu.com/quantal/amd64/bcmwl-kernel-source/download

bkloppenborg (bkloppenborg) wrote :

Unmarked this bug as a duplicate of 1097519 for reasons explained here:
https://bugs.launchpad.net/ubuntu/+source/bcmwl/+bug/1097519/comments/30

bkloppenborg (bkloppenborg) wrote :

I've been trying the drivers from saucy (i.e. 6.30.223.30-bdcom0-ubuntu1) for the last week or so. The interference issue is either entirely gone or significantly reduced. If this is true for other users, we should probably suggest upgrading as a workaround (to the driver from here https://launchpad.net/ubuntu/saucy/+package/bcmwl-kernel-source) and close this bug.

M le, do the saucy drivers work for you?

Could you open a root terminal and run iwconfig? What you get? Did you get a kernel panic?

bkloppenborg (bkloppenborg) wrote :

No, no kernel panic for me with the saucy drivers (6.30.223.30-bdcom0-ubuntu1) running iwconfig via. sudo:

$ sudo iwconfig eth1
[sudo] password for bkloppenborg:
eth1 IEEE 802.11abg ESSID:"XXXXXXXXXXXXXX"
          Mode:Managed Frequency:2.412 GHz Access Point: 00:1C:28:XX:XX:XX
          Bit Rate=54 Mb/s Tx-Power=200 dBm
          Retry long limit:7 RTS thr:off Fragment thr:off
          Encryption key:off
          Power Management:on
          Link Quality=55/70 Signal level=-55 dBm
          Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
          Tx excessive retries:0 Invalid misc:0 Missed beacon:0

That's after 2 days, 12 hours of uptime through two sleep/resume cycles.

Well, we can say that the bug has been fixed now. It's time to update.

bkloppenborg (bkloppenborg) wrote :

Great. So to other users affected by this bug, simply apply the broadcom-kernel-source package from saucy as described in post #18 above.

Changed in bcmwl (Ubuntu):
status: Confirmed → Fix Released
Jim Ciallella (jimc) wrote :

For the layman, the suggested fix in comment #18 means:
- Go to https://launchpad.net/ubuntu/saucy/+package/bcmwl-kernel-source
- Click the link under Source package
- Under "Builds" click either saucy i386 (for 32-bit) or saucy AMD64 (for 64-bit)
- On the next page, under "Built files", click the link to download the .deb file
- Open the .deb and it should open in Ubuntu Software Center
- Click the Upgrade button

Vinay (vinay-wagh) wrote :

fix works for me too (although the fix is for saucy and I have raring!).

VInay

Same here. #23 instructions work for Latitude E6530 and Ubuntu 13.04 (64-bit)

Thank you all!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments