Broadcom 802.11ac [14e4:43b1]: wireless doesn't work after bcmwl-kernel-source installed, suspend/resume/shutdown failure

Bug #1119842 reported by Gabriel Thörnblad on 2013-02-08
50
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Broadcom Team
Undecided
Unassigned
HWE Next
High
Alberto Milone
bcmwl (Ubuntu)
High
Alberto Milone
Nominated for Precise by Anthony Wong
Nominated for Quantal by Anthony Wong
Nominated for Raring by Anthony Wong

Bug Description

This laptop has a Broadcom 802.11ac chip with a pci signature of [14e4:43b1]. When I install the bcmwl-kernel-source (as suggested by "Software Sources", suspend/resume no longer works and the laptop hangs when I try to shut it down. And to add insult to injury, my wireless card still doesn't work.

ProblemType: KernelOops
DistroRelease: Ubuntu 13.04
Package: linux-image-3.8.0-5-generic 3.8.0-5.10
ProcVersionSignature: Ubuntu 3.8.0-5.10-generic 3.8.0-rc6
Uname: Linux 3.8.0-5-generic x86_64
NonfreeKernelModules: nvidia
Annotation: This occured during a previous suspend and prevented it from resuming properly.
ApportVersion: 2.8-0ubuntu4
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: gabbe 1989 F.... pulseaudio
 /dev/snd/controlC0: gabbe 1989 F.... pulseaudio
CRDA: Error: command ['iw', 'reg', 'get'] failed with exit code 1: nl80211 not found.
Date: Fri Feb 8 22:30:47 2013
ExecutablePath: /usr/share/apport/apportcheckresume
Failure: suspend/resume
HibernationDevice: RESUME=UUID=7c89059e-2ea6-4ac1-bef4-d2fb9001403b
InstallationDate: Installed on 2013-02-05 (3 days ago)
InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Alpha amd64 (20130204.1)
InterpreterPath: /usr/bin/python3.3
IwConfig:
 eth0 no wireless extensions.

 lo no wireless extensions.
MachineType: ASUSTeK COMPUTER INC. G75VX
MarkForUpload: True
ProcCmdline: /usr/bin/python3 /usr/share/apport/apportcheckresume
ProcEnviron:
 TERM=linux
 PATH=(custom, no user)
ProcFB: 0 EFI VGA
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.8.0-5-generic.efi.signed root=UUID=57371a00-0a44-449d-af53-ab7dbd7f8f69 ro quiet splash
PulseList: Error: command ['pacmd', 'list'] failed with exit code 1: No PulseAudio daemon running, or not running as session daemon.
RelatedPackageVersions:
 linux-restricted-modules-3.8.0-5-generic N/A
 linux-backports-modules-3.8.0-5-generic N/A
 linux-firmware 1.100
SourcePackage: linux
Title: [ASUSTeK COMPUTER INC. G75VX] suspend/resume failure [non-free: nvidia]
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

dmi.bios.date: 12/24/2012
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: G75VX.205
dmi.board.asset.tag: ATN12345678901234567
dmi.board.name: G75VX
dmi.board.vendor: ASUSTeK COMPUTER INC.
dmi.board.version: 1.0
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: ASUSTeK COMPUTER INC.
dmi.chassis.version: 1.0
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrG75VX.205:bd12/24/2012:svnASUSTeKCOMPUTERINC.:pnG75VX:pvr1.0:rvnASUSTeKCOMPUTERINC.:rnG75VX:rvr1.0:cvnASUSTeKCOMPUTERINC.:ct10:cvr1.0:
dmi.product.name: G75VX
dmi.product.version: 1.0
dmi.sys.vendor: ASUSTeK COMPUTER INC.

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v3.8 kernel[0] (Not a kernel in the daily directory) and install both the linux-image and linux-image-extra .deb packages.

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.8-rc7-raring/

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete

Tested with v3.8-rc7-raring, and kernel bug is still present. However, the installation of bcwl-kernel-source segfaults when running dkms, so this may not be a kernel bug at all, but more probably a faulty module.
I will file a new bug report against the bcwl-kernel-source package.

tags: added: kernel-bug-exists-upstream
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
affects: linux (Ubuntu) → bcmwl (Ubuntu)
Bernardo Reino (reinob) wrote :

@gabriel-thornblad,

Just a quick/wild guess: have you installed the cgroup-bin package?

Reason for asking is: in your modules list I see kvm/kvm_intel and various vbox* modules, so there's a chance that you've also installed cgroup-bin as a dependency of libvirt.

Now, if that is the case, have a look at bugs #693594 and #858102. Package cgroup-bin, in its default configuration, is so badly broken that it, among other kernel-breaking measures, prevents suspend/resume and even correct shutdown.

If so, replace it with cgroup-lite.

If you don't have cgroup-bin then it must be something else (obviously :).

@reinob:
Thanks for the suggestion, however I don't have cgroup-bin installed
$ dpkg-query -l cgroup*
$ dpkg-query: no packages found matching cgroup*

Most likely it is my bleeding-edge wireless chip that is causing all this - since the problems go away if I remove the bcwl-source package...

This is what happens when I try to install the bcmwl-kernel-source package. Notice the "Segmentation fault" after DKMS completes. Does anyone know which step this might be?

$ sudo apt-get install bcmwl-kernel-source
...
Unpacking bcmwl-kernel-source (from .../bcmwl-kernel-source_6.20.155.1+bdcom-0ubuntu6_amd64.deb) ...
Setting up bcmwl-kernel-source (6.20.155.1+bdcom-0ubuntu6) ...
Loading new bcmwl-6.20.155.1+bdcom DKMS files...
Building only for 3.8.0-7-generic
Building for architecture x86_64
Building initial module for 3.8.0-7-generic
Done.

wl:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/3.8.0-7-generic/updates/dkms/

depmod....

DKMS: install completed.
Segmentation fault
update-initramfs: deferring update (trigger activated)
Processing triggers for initramfs-tools ...
update-initramfs: Generating /boot/initrd.img-3.8.0-7-generic

With this module installed I get the suspend/resume failures described earlier.

Bernardo Reino (reinob) wrote :

@gabriel-thornblad,

It is not clear (for me at least) where the wl module is actually loaded when you try to suspend.

From the dmesg (in "WifiSyslog.txt") it seems that the wl module fails to load:

Feb 7 11:15:36 amaranth kernel: [ 3.380643] wl driver 6.20.155.1 (r326264) failed with code 11
Feb 7 11:15:36 amaranth kernel: [ 3.380652] ------------[ cut here ]------------
Feb 7 11:15:36 amaranth kernel: [ 3.380653] Kernel BUG at ffffffffa0d36b8c [verbose debug info unavailable]
Feb 7 11:15:36 amaranth kernel: [ 3.380655] invalid opcode: 0000 [#1] SMP
Feb 7 11:15:36 amaranth kernel: [ 3.380672] Modules linked in: wl(POF+) coretemp ...
Feb 7 11:15:36 amaranth kernel: [ 3.380675] CPU 4
Feb 7 11:15:36 amaranth kernel: [ 3.380675] Pid: 649, comm: modprobe Tainted: PF O 3.8.0-4-generic ..
Feb 7 11:15:36 amaranth kernel: [ 3.380696] RIP: 0010:[<ffffffffa0d36b8c>] [<ffffffffa0d36b8c>] wl_cfg80211_detach+0xfc/0x100 [wl]

This is (most likely) also the Segmentation fault you get immediately after DKMS has built the module (after building it, it modprobe's it).

Unfortunately I only have kernel 3.5 (bcmwl works fine there -- BCM4313).

My suspicion is that the problem is with the interface between wl.ko and cfg80211.ko (I've seen somewhere a patch for wl to use WEXT instead of cfg8011 for kernel 3.8, but I always thought WEXT is deprecated).

Sorry I can't be more precise. One of these days I want to install kernel 3.8, but having BCM4313 (wlan) and AR8161 (ethernet), both requiring non-standard modules makes me think very carefully before touching the kernel :)

Changed in bcmwl (Ubuntu):
assignee: nobody → Alberto Milone (albertomilone)
tags: added: blocks-hwcert-enablement
Changed in bcmwl (Ubuntu):
importance: Medium → High
Rafał Miłecki (zajec5) wrote :

Could someone with Broadcom 802.11ac WiFI do one simple test for me, please?

1) Remove wl driver temporary:
rmmod wl

2) Try using "bcma" module:
modprobe bcma
echo "14e4 43b1" > /sys/bus/pci/drivers/bcma-pci-bridge/new_id
dmesg | grep bcma
(and provide output of the above dmesg command)

3) That's is. You can go back to "wl" now:
rmmod bcma
modprobe wl
(or just reboot the OS)

@Rafał Miłecki
Here's my results:
~# dmesg | grep bcma
[38788.786432] bcma: bus0: Found chip with id 0x4352, rev 0x03 and package 0x00
[38788.786478] bcma: bus0: Core 0 found: ChipCommon (manuf 0x4BF, id 0x800, rev 0x2B, class 0x0)
[38788.786501] bcma: bus0: Core 1 found: IEEE 802.11 (manuf 0x4BF, id 0x812, rev 0x2A, class 0x0)
[38788.786544] bcma: bus0: Core 2 found: UNKNOWN (manuf 0x4BF, id 0x83E, rev 0x02, class 0x0)
[38788.786588] bcma: bus0: Core 3 found: UNKNOWN (manuf 0x4BF, id 0x83C, rev 0x01, class 0x0)
[38788.786611] bcma: bus0: Core 4 found: USB 2.0 Device (manuf 0x4BF, id 0x81A, rev 0x11, class 0x0)
[38788.797221] bcma: bus0: invalid sprom read from the PCIe card, try to use fallback sprom
[38788.797225] bcma: bus0: Using fallback SPROM failed (err -2)
[38788.797227] bcma: bus0: No SPROM available
[38788.799352] bcma: bus0: Bus registered

Although I removed the module "ndiswrapper" instead of "wl", since that is the only way I can get it to work.

Changed in hwe-next:
assignee: nobody → Alberto Milone (albertomilone)
status: New → Confirmed
Changed in broadcom:
assignee: nobody → James M. Leddy (jm-leddy)
status: New → Confirmed
assignee: James M. Leddy (jm-leddy) → nobody
tags: added: ihv-broadcom
Anthony Wong (anthonywong) wrote :

Hi Gabriel, can you try the 6_30_223_95 driver in http://people.canonical.com/~ypwong/drivers/broadcom/ and see if it helps you?

Daniel Cardin (daniel-cardin) wrote :

Hello Anthony,

I have the same problem as everyone else, and the new driver is not working for me either...

summary: - [ASUSTeK COMPUTER INC. G75VX] suspend/resume failure [non-free: nvidia]
+ Broadcom 802.11ac [14e4:43b1]: wireless doesn't work after bcmwl-kernel-
+ source installed, suspend/resume/shutdown failure
Changed in hwe-next:
importance: Undecided → High
Anthony Wong (anthonywong) wrote :

Hi Daniel,

What is your kernel version? There are detailed steps in https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1173761/comments/29, could you give it a try?

Anthony Wong (anthonywong) wrote :

We recently packaged 6.30.223.141 for 13.10. It'd be helpful if anyone who has already upgraded to 13.10 can verify it. 13.10 will be released on Oct 17.

Changed in bcmwl (Ubuntu):
status: Confirmed → Incomplete
Andrew Naito (naitoah) wrote :

I did a fresh install of Ubuntu 13.10

bcmwl-kernel-source does prevent my system (Gateway MX6454 with 14e4:4311) from shutting down, suspend/restart, and reboot.

Only after removing bcmwl-kernel-source, and installing firmware-b43-installer, does my system properly work.

Felipe G. Maia (felipegmaia) wrote :

Hi everyone

I've installed Ubuntu 13.10 (Desktop AMD 64 bits - Kernel 3.11.0-17) last week and had the some problem reported by Gabriel (fails to reboot and to power off ; wireless card is not recognized).

I have a laptop Dell Latitude D830 with a Dell Wireless 1390 WLAN Minicard (chipset Broadcom BCM 4311 802.11 b/g), since 2007.

I had the latest available version of the 'bcmwl-kernel-source' package (Version: 6.30.223.141+bdcom-0ubuntu1), which was automatically installed with Ubuntu. Since I couldn't have it working at any cost, I removed this package and installed 'linux-firmware-nonfree' (Non-free firmware for Linux kernel drivers) (Version: 1.14ubuntu1), 'b43-fwcutter' (utility for extracting Broadcom 43xx firmware) (Version: 1:017-2) and 'firmware-b43-installer' (firmware installer for the b43 driver) (Version: 1:017-2), what solved my problem perfectly.

I've also tested other Ubuntu versions on this machine (12.04 LTS AMD64, 13.04 AMD64 and 13.10 i386) and had the exact same problem. However, in 2009 when I had Ubuntu 9.04 (Jaunty Jackalope) this issue wasn't present. This Broadcom's open-source driver (bcmwl-kernel-source) was released right after on that same year, for Ubuntu 9.10 (Karmic Koala).

When you do a bug-report search, right from this Launchpad Ubuntu Bug platform, with the statement "bcmwl-kernel-source", 37 reports are returned, dating from 2010 until now. It seems that this issue is chronic , which ramains since the package was released. I don't know how many kernels and device models are incompatible with this Broadcom driver, neither if it's just a driver version issue or if it's the driver itself (all versions) that is not well adapted to the kernel.

To be honest, I took a week to find where the problem was and make my system work properly. Probably, if I wasn't a free software (open source-code) and Linux/Ubuntu enthusiast, I would have given up at the begening and returned to the convenience of Windows. Failure to have the wireless card working and to reboot and power off properly, are serious problems that may discourage novice users to adopt Ubuntu.

Perhaps there should be created a Graph linking the members of the three groups involved in the issue: hardware device model, kernel version and Broadcom driver version. Members among diferent groups would be linked to each other when a bug between them is present and unsolved. A Graph grafical representation (Graph diagram) could be usefull to help to map and clarify this problem.

I am glad to be a Linux/Ubuntu user and a member of this Ubuntu community! I hope I have helped somehow!

Cheers!!

Changed in bcmwl (Ubuntu):
status: Incomplete → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers