[raring] BCM4313 -- bcmwl triggers panics with 3.7 and 3.8 kernels

Bug #1098225 reported by Andy Whitcroft on 2013-01-10
116
This bug affects 23 people
Affects Status Importance Assigned to Milestone
Broadcom Team
Undecided
Unassigned
bcmwl (Ubuntu)
Undecided
Alberto Milone

Bug Description

Seeing panics with v3.7 and v3.8 with latest bcmwl, also affects previous version.

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: bcmwl-kernel-source 6.20.155.1+bdcom-0ubuntu4
ProcVersionSignature: Ubuntu 3.8.0-0.1~masternext201301101227-generic 3.8.0-rc3
Uname: Linux 3.8.0-0-generic i686
ApportVersion: 2.8-0ubuntu1
Architecture: i386
Date: Thu Jan 10 15:30:18 2013
EcryptfsInUse: Yes
InstallationDate: Installed on 2010-05-06 (980 days ago)
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release i386 (20100429)
MarkForUpload: True
SourcePackage: bcmwl
UpgradeStatus: Upgraded to raring on 2012-01-04 (371 days ago)

Andy Whitcroft (apw) wrote :
Andy Whitcroft (apw) wrote :

Dmesg when panicing.

Andy Whitcroft (apw) wrote :
Download full text (3.8 KiB)

[ 27.714716] ------------[ cut here ]------------
[ 27.714844] Kernel BUG at f9138eca [verbose debug info unavailable]
[ 27.714992] invalid opcode: 0000 [#1] SMP
[ 27.715098] Modules linked in: snd_hrtimer pci_stub vboxpci(OF) vboxnetadp(OF) vboxnetflt(OF) vboxdrv(OF) ebtable_nat ebtables ipt_MASQUERADE iptable_nat nf_nat_ipv4 nfnetlink_log nfnetlink xt_CHECKSUM iptable_mangle bridge stp llc dm_crypt snd_hda_codec_realtek snd_hda_intel xt_hl ip6t_rt snd_hda_codec nf_conntrack_ipv6 snd_hwdep joydev nf_defrag_ipv6 ipt_REJECT xt_LOG snd_pcm xt_limit acer_wmi xt_tcpudp sparse_keymap xt_addrtype nf_conntrack_ipv4 nf_defrag_ipv4 xt_state ip6table_filter ip6_tables snd_page_alloc nf_conntrack_netbios_ns nf_conntrack_broadcast nf_nat_ftp nf_nat snd_seq_midi nf_conntrack_ftp snd_seq_midi_event nf_conntrack iptable_filter snd_rawmidi ip_tables x_tables uvcvideo videobuf2_vmalloc videobuf2_memops snd_seq videobuf2_core videodev usb_storage microcode snd_seq_device snd_timer lib80211_crypt_tkip wl(POF) snd psmouse lib80211 serio_raw lpc_ich atl1c cfg80211 soundcore mac_hid rfcomm bnep bluetooth parport_pc ppdev nfsd auth_rpcgss nfs_acl nfs binfmt_misc lockd sunrpc coretemp fscache lp parport i915 i2c_algo_bit drm_kms_helper drm wmi video
[ 27.716022] Pid: 2116, comm: wpa_supplicant Tainted: PF O 3.8.0-0-generic #1~masternext201301101227 Acer AO533 /AO533
[ 27.716022] EIP: 0060:[<f9138eca>] EFLAGS: 00210246 CPU: 0
[ 27.716022] EIP is at wl_cfg80211_scan+0x2da/0x340 [wl]
[ 27.716022] EAX: 00000000 EBX: f3151600 ECX: f92eca40 EDX: f093fe00
[ 27.716022] ESI: f093fe00 EDI: f30c2120 EBP: f1633c24 ESP: f1633c00
[ 27.716022] DS: 007b ES: 007b FS: 00d8 GS: 00e0 SS: 0068
[ 27.716022] CR0: 80050033 CR2: 080e8380 CR3: 3326d000 CR4: 000007f0
[ 27.716022] DR0: 00000000 DR1: 00000000 DR2: 00000000 DR3: 00000000
[ 27.716022] DR6: ffff0ff0 DR7: 00000400
[ 27.716022] Process wpa_supplicant (pid: 2116, ti=f1632000 task=f31059b0 task.ti=f1632000)
[ 27.716022] Stack:
[ 27.716022] 000116bf f093fa00 f8c2f758 00000121 f093fe00 00000200 f3151600 f093fe00
[ 27.716022] f30c2120 f1633c58 f8c2fbfd ffffffff 00000033 00000003 f3151600 f30c2120
[ 27.716022] f30c2000 f1633c84 f093fe00 f8c63200 f8c63660 f8c22740 f1633cb4 c1551b2d
[ 27.716022] Call Trace:
[ 27.716022] [<f8c2f758>] ? nl80211_trigger_scan+0xc8/0x610 [cfg80211]
[ 27.716022] [<f8c2fbfd>] nl80211_trigger_scan+0x56d/0x610 [cfg80211]
[ 27.716022] [<f8c22740>] ? __cfg80211_rdev_from_attrs+0x160/0x160 [cfg80211]
[ 27.716022] [<c1551b2d>] genl_rcv_msg+0x22d/0x290
[ 27.716022] [<c1551900>] ? genl_rcv+0x30/0x30
[ 27.716022] [<c1551526>] netlink_rcv_skb+0x86/0xa0
[ 27.716022] [<c15518ec>] genl_rcv+0x1c/0x30
[ 27.716022] [<c1550ec7>] netlink_unicast+0x167/0x1e0
[ 27.716022] [<c1551169>] netlink_sendmsg+0x229/0x3a0
[ 27.716022] [<c151a11c>] sock_sendmsg+0x9c/0xd0
[ 27.784114] [<c12e9e7a>] ? radix_tree_lookup+0xa/0x10
[ 27.784114] [<c151a3e9>] __sys_sendmsg+0x299/0x2b0
[ 27.784114] [<c1019325>] ? fpu_finit+0x55/0x70
[ 27.784114] [<c1043dc7>] ? kmap_atomic_prot+0xe7/0x100
[ 27.784114] [<c1132685>] ? handle_mm_f...

Read more...

Andy Whitcroft (apw) wrote :

02:00.0 Network controller [0280]: Broadcom Corporation BCM4313 802.11b/g/n Wireless LAN Controller [14e4:4727] (rev 01)

summary: - [raring] bcmwl triggers panics with 3.7 and 3.8 kernels
+ [raring] BCM4313 -- bcmwl triggers panics with 3.7 and 3.8 kernels
Changed in bcmwl (Ubuntu):
assignee: nobody → Alberto Milone (albertomilone)
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bcmwl - 6.20.155.1+bdcom-0ubuntu5

---------------
bcmwl (6.20.155.1+bdcom-0ubuntu5) raring; urgency=low

  * 0007-nl80211-move-scan-API-to-wdev.patch:
   - Move scan API to wdev. This fixes an issue with
     Linux >= 3.6 (LP: #1098225).
     Thanks to Robert Hooker for suggesting the patch.
 -- Alberto Milone <email address hidden> Thu, 10 Jan 2013 18:09:48 +0100

Changed in bcmwl (Ubuntu):
status: In Progress → Fix Released
dmiranda (dmiranda) wrote :

With this version of bcwl my computer does not find the network card on boot

dmiranda (dmiranda) wrote :

Please ignore my last comment... my problem was in dkms and and old version of virtualbox... Sorry for the white noise.

Kimr1508 (kimr1508) wrote :

Can someone confirm if they experience similar problems with broadcom 4312?

I receive kernel panic after a random number of minutes (normally 2 - 15 minutes) when I use Transmission. When doing casual web browsing I do not get any panic, so maybe it is network load related.

If I boot with kernel 3.5 there are no problems at all.

I currently have "6.20.155.1+bdcom-0ubuntu5" installed, and my machine is an upgrade from Xubuntu 12.10 to 13.04.

Kimr1508 (kimr1508) wrote :

The kernel panic on broadcom 4312 can also be reproduced copying a large file to another computer (samba share). So it is not only when Transmission is used to generate network traffic .

Bernardo Reino (reinob) wrote :

@kimr1508,

Can you confirm that you have bcmwl version 6.20.155.1+bdcom-0ubuntu5 (or ..6) installed?

Same problem for me. Latest drivers (6.20.155.1+bdcom-0ubuntu6) installed

Bernardo Reino (reinob) wrote :

Reading https://bugzilla.rpmfusion.org/show_bug.cgi?id=2526#c11 it appears that the "wl-linux-3.6-patch" is needed (attached).

If anyone with kernel >= 3.6 could apply this patch and try..

Kimr1508 (kimr1508) wrote :

@Bernardo
Yes, I can confirm that I have 6.20.155.1+bdcom-0ubuntu6 installed.

Kimr1508 (kimr1508) wrote :

Someone at http://askubuntu.com/questions/263411/how-to-install-wireless-driver-broadcom-sta-wl-for-asus-x201e-with-kernel-3-8 seems to have created a patch for kernel 3.8, but I am not quite sure where to implement the patch changes, so I have not tried it out myself.

Andreas Degert (adegert) wrote :

This bug seems to affect me too:

Hardware: BCM43227

Kernel version versus bcmwl-kernel-source version:

                 5.100.82.112+bdcom-0ubuntu3_i386 6.20.155.1+bdcom-0ubuntu6_i386
3.5.0-26 works works
3.8.0-13 works panic

can someone confirm that the quantal version works with 3.8.0?
(just download the deb-package and install with dpkg -i)

Kim Rasmussen (kimr1508-n) wrote :

I did some extra testing with the latest OpenSuse 12.3 release, which use kernel 3.7 and 5.100 version of broadcom-wl. This combination also resulted in kernel paninc.

So far my list looks like this:
kernel 3.2 with broadcom-wl 6.200. OK
kernel 3.5 with broadcom-wl 5.100. OK
kernel 3.7 with broadcom-wl 5.100. Panic
kernel 3.8 with broadcom-wl 6.200. Panic

I've just done a minimal CLI reinstall (raring mini.iso) on my Mini 311c with Broadcom wireless (BCM43x) (observed previously but worked around with 5.100).

Installing laptop-mode-tools after installing bcmwl-kernel-source triggers a panic; this is repeatable (and leaves dpkg in an unusable state, every attempt to 'dpkg --configure -a' causes a panic when laptop-mode-tools is configured).

Are there new (e.g.) power saving functions in the kernel that could be causing this bug?

Oh, I should note that was with 3.8.0-14. I can't update to 3.8.0-15. :D

I started with another minimal CLI install (adding the same packages as last time*), but this time also installed the latest Liquorix kernel (3.8-4.dmz.2). I get a panic after installing bcmwl with Ubuntu kernel 3.8.0-15 but no panic when booting with Liquorix.

Can anyone confirm whether they have panics with Liquorix? If not then might this be a kernel sauce issue?

(* minimal KDE: sudo apt-get install kdm acpi acpi-support laptop-mode-tools network-manager-kde)

Oh, my mistake. It looks as though the kernel module hasn't built for the Liquorix kernel. This might explain why it hasn't panicked.

Igor Tarasov (tarasov-igor) wrote :

Ubuntu 13.04 did not boot just because of this bug. Using 3.5 kernel I've installed bcmwl-kernel-source from 12.10 and it did help. So, I've put bcmwl-kernel-source on hold until this bug gets fixed.

Igor Tarasov (tarasov-igor) wrote :

And, old version of bcmwl driver breaks networking on 3.8. So, owners of affected cards on Ubuntu 13.04 have two options: do not use this driver at all (and have no wi-fi) or to use one of the older kernels, 3.5.0.something from Ubuntu 12.10, for example.

Strangely I no longer, and this remains to be seen with more use, have this panic because I manually installed "dpgk -i 6.20.155.1+bdcom-0ubuntu5." an older package. The version "6.20.155.1+bdcom-0ubuntu6" causes the kernel panic it seems. Futhermore my "uname -a" is "3.8.0-19-generic #30-Ubuntu x86_64". If you need any additional information please reply.

Also effected by this bug. Using the bcm 4312 LP-PHY chip in my laptop. For now I have installed a 3.4 kernel from 12.10 and all is fine.

However is it safe to remove the Linux-kernel-generic (sorry if not correct name, not on a buntu box atm ;) ) package and the 3.8 kernel packages via synaptic so that the 3.4 kernel is the default? Or can I set the 3.4 kernel as the default in grub, because setting the default value in grub only changes the menu entries on the first screen of grub (and the other older kernels is shown on the 'second' screen after selecting advanced options?)

Pardon the lack of knowledge on my side, but I see a fix has been released for this bug, does this mean that if I run 'sudo apt-get update && sudo apt-get dist-upgrade' I will get the fix?

If not, how would one go about to get this fix?

XandY (xandy) wrote :

Installing bcmwl-kernel-source_6.30.223.30+bdcom-0ubuntu1_amd64.deb from Saucy seems to have fixed it for me on Raring
(package downloaded from https://launchpad.net/ubuntu/saucy/amd64/bcmwl-kernel-source/6.30.223.30+bdcom-0ubuntu1, installed via dpkg -i)

Before that, I had kernel panic using Raring and version bcmwl-kernel-source 6.20.155 as others described here. Downgrading to 5.100 seemed to be a fix for me too contrary to what others in the thread experienced.

Andreas Degert (adegert) wrote :

bcmwl-kernel-source_6.30.223.30+bdcom-0ubuntu1_amd64.deb works for me too (better than 5.100.82.112+bdcom-0ubuntu3_i386, which had delayed network detection with linux 3.8.0). It does not compile for the current lowlatency kernel (3.8.0-22-lowlatency) because of a GPL-only export symbol. The "fixed" version (just declare it GPL...) works also on that kernel.

Trent McPheron (tiz-ex1) wrote :

I just fresh installed Raring on an Inspiron N4010 and ran into this issue. If you have the bcmwl module installed, installing laptop-mode-tools will cause an *immediate* kernel panic, and, as mentioned, leave the system unusable.

To get out of this state, boot into a live environment, chroot into your system, and fix dpkg from there, then removing laptop-mode-tools. Bind only /dev, /proc, and /sys in the chroot. This will cause the system to operate enough to actually fix dpkg and install/uninstall laptop-mode-tools, but not enough to actually operate it, so you can safely recover from the error.

I will try installing saucy's bcmwl later and report back on the results.

Bernardo Reino (reinob) wrote :

I don't see why this bug should be a duplicate of 1097519. The latter is about using brcmsmac instead of the proprietary bcmwl. This bug is about bcmwl, so I cannot be a duplicate.

There seems to be a not-so-well-thought effort of combining various bugs. I note that brcmsmac does not work *properly* with BCM4313.

I tried to install the bcmwl package from saucy repository: all the panics are gone and the wireless card started to work as it was with previous ubuntu releases. The only problem I had is that it manages to connect to a WPA1 network, but it has some problems transmitting/receiving data. I'll do some tests as soon as I'm near to a WPA1 network ;)

My card is a BCM4312, but maybe this package works well also with 4313

Here you can find and try yourself the package I mentioned before:
https://launchpad.net/ubuntu/+source/bcmwl/6.30.223.30+bdcom-0ubuntu2/+build/4724924/+files/bcmwl-kernel-source_6.30.223.30%2Bbdcom-0ubuntu2_amd64.deb

KeithG (grider-4) wrote :

Tried this tonight with 13.04. Installed the DEB and all seems to be fine so far. I was getting kernel panic and freeze during periods of high wifi usage.

After some time testing this deb I have to say that it works fine 75 times
over 100. I've noticed that it can't transmit/receive data over a WPA1
network (as mentioned in my precedent post) and trying to send some audio
stream to a pulseaudio server on a remote Pc causes the pulseaudio
connection to give up after hearing some hiccups. Trying with another wi-fi
card I have no problems.

2013/7/22 KeithG <email address hidden>

> Tried this tonight with 13.04. Installed the DEB and all seems to be
> fine so far. I was getting kernel panic and freeze during periods of
> high wifi usage.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1098225
>
> Title:
> [raring] BCM4313 -- bcmwl triggers panics with 3.7 and 3.8 kernels
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/broadcom/+bug/1098225/+subscriptions
>

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.