Ubuntu

Broadcom STA driver can't install on systems

Reported by Tim Chen on 2012-05-22
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
bcmwl (Ubuntu)
Medium
Alberto Milone
Precise
Medium
Alberto Milone

Bug Description

system: Lenovo ThinkCentre Edge S710/S510

The wifi is unable to work, the jockey shows the Broadcom STA can be installed.
But installation failed.
jockey.log is attached.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: linux-image-3.2.0-24-generic 3.2.0-24.37
ProcVersionSignature: Ubuntu 3.2.0-24.37-generic 3.2.14
Uname: Linux 3.2.0-24-generic x86_64
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 2.0.1-0ubuntu5
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: PCH [HDA Intel PCH], device 0: ALC269VB Analog [ALC269VB Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: ubuntu 1427 F.... pulseaudio
CRDA: Error: command ['iw', 'reg', 'get'] failed with exit code 1: nl80211 not found.
Card0.Amixer.info:
 Card hw:0 'PCH'/'HDA Intel PCH at 0xfe520000 irq 46'
   Mixer name : 'Intel CougarPoint HDMI'
   Components : 'HDA:10ec0269,17aa307a,00100100 HDA:80862805,80862805,00100000'
   Controls : 22
   Simple ctrls : 10
Date: Tue May 22 03:21:48 2012
HibernationDevice: RESUME=UUID=7b7355a3-7a64-405c-8e9b-6872d2eb024c
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120425)
IwConfig:
 lo no wireless extensions.

 eth0 no wireless extensions.
MachineType: LENOVO YANGTIAN
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-24-generic root=UUID=b441d55f-456b-41ba-94c3-45e77f8044fc ro quiet splash initcall_debug vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.2.0-24-generic N/A
 linux-backports-modules-3.2.0-24-generic N/A
 linux-firmware 1.79
RfKill:

SourcePackage: linux
StagingDrivers: rts5139 mei
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 03/02/2011
dmi.bios.vendor: LENOVO
dmi.bios.version: 9OKT08AUS
dmi.board.asset.tag: To be filled by O.E.M.
dmi.board.name: To be filled by O.E.M.
dmi.board.vendor: LENOVO
dmi.board.version: To be filled by O.E.M.
dmi.chassis.type: 3
dmi.chassis.vendor: To Be Filled By O.E.M.
dmi.chassis.version: To Be Filled By O.E.M.
dmi.modalias: dmi:bvnLENOVO:bvr9OKT08AUS:bd03/02/2011:svnLENOVO:pnYANGTIAN:pvrLenovoProduct:rvnLENOVO:rnTobefilledbyO.E.M.:rvrTobefilledbyO.E.M.:cvnToBeFilledByO.E.M.:ct3:cvrToBeFilledByO.E.M.:
dmi.product.name: YANGTIAN
dmi.product.version: Lenovo Product
dmi.sys.vendor: LENOVO

Tim Chen (ctf) wrote :
Changed in linux (Ubuntu):
assignee: nobody → Anthony Wong (anthonywong)
Brad Figg (brad-figg) on 2012-05-22
Changed in linux (Ubuntu):
status: New → Confirmed
Jesse Sung (wenchien) wrote :

This is due to the kernel currently run is linux-image-3.2.0-24-generic 3.2.0.24.26, but linux-headers-generic does not update yet.

$ dpkg -l | grep header
ii linux-headers-3.2.0-23 3.2.0-23.36 Header files related to Linux kernel version 3.2.0
ii linux-headers-3.2.0-23-generic 3.2.0-23.36 Linux kernel headers for version 3.2.0 on 64 bit x86 SMP
ii linux-headers-generic 3.2.0.23.25 Generic Linux kernel headers

Update linux-headers-generic and linux-headers-3.2.0-24-generic/linux-headers-3.2.0-24 will be installed, and then broadcom STA driver can be installed without any problem.

Changed in linux (Ubuntu):
assignee: Anthony Wong (anthonywong) → Alberto Milone (albertomilone)
affects: linux (Ubuntu) → bcmwl (Ubuntu)
Changed in bcmwl (Ubuntu):
importance: Undecided → Medium
Ara Pulido (apulido) on 2012-06-13
tags: added: blocks-hwcert-enablement
Ara Pulido (apulido) wrote :

Tim, can you:

1) Reinstall 12.04 and update
2) Install broadcom drivers

Thanks,
Ara.

Changed in bcmwl (Ubuntu):
status: Confirmed → Incomplete
Tim Chen (ctf) wrote :

update kernel to 3.2.0-27.43
jocky still can't install Broadcom STA driver.
after Installed linux-headers-generic then installed bcmwl-kernel-source, the wifi works.(comment #2)

Changed in bcmwl (Ubuntu):
status: Incomplete → Confirmed
Chris Van Hoof (vanhoof) on 2012-07-27
Changed in bcmwl (Ubuntu Precise):
status: New → Confirmed
importance: Undecided → Medium
assignee: nobody → Alberto Milone (albertomilone)
Tim Chen (ctf) wrote :

Tried in Quantal daily image, kernel 3.5.0-11.11. Jockey can't work, but I manually installed bcmwl-kernel-source, then the wireless works.

Ara Pulido (apulido) wrote :

Added quantal tag, as we will need to have this suggested by ubuntu-drivers

tags: added: quantal
Alberto Milone (albertomilone) wrote :

please attach your new /var/log/jockey.log

Changed in bcmwl (Ubuntu Precise):
status: Confirmed → Incomplete
Changed in bcmwl (Ubuntu):
status: Confirmed → Incomplete
Tim Chen (ctf) on 2013-02-05
Changed in bcmwl (Ubuntu):
status: Incomplete → Fix Released
Changed in bcmwl (Ubuntu Precise):
status: Incomplete → Fix Released
Jeff Marcom (jeffmarcom) wrote :

This shouldn't be fixed release should it? It still fails to install without giving a user any information as to what to do next.

Jeff Marcom (jeffmarcom) wrote :

This is still very much a bug from a user's perspective.

Changed in bcmwl (Ubuntu):
status: Fix Released → New
Changed in bcmwl (Ubuntu Precise):
status: Fix Released → New
Alberto Milone (albertomilone) wrote :

This is really a duplicate of bug #1123107

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers