this does not work with dell 1390

Bug #92088 reported by Eugenia Loli-Queru on 2007-03-13
20
Affects Status Importance Assigned to Milestone
bcm43xx-fwcutter (Ubuntu)
Undecided
Unassigned
Declined for Feisty by Henrik Nilsen Omma
Declined for Gutsy by Henrik Nilsen Omma

Bug Description

Binary package hint: bcm43xx-fwcutter

Please fix the bcm43xx driver to support DELL's 1390 card. I just got a new laptop yesterday and ubuntu gives me lots of firmware errors. This IS the right driver for my card, but it does not work well with the version of Dell's hardware. I had to blacklist the bcm43 driver and install ndiswrapper to get me up and running. In the forums people who have the same Inspiron 1505 or 640m laptop as I do, have the same problem.

Sitsofe Wheeler (sitsofe) wrote :

Thank you for your bug report.

Eugenia:

My understanding is that the bcm43xx native Linux driver does not work with every card that contains that chipset (mainly because it has had to be reverse engineered which is hard work). There is a small list of cards it does work with here:
http://bcm43xx.berlios.de/?go=devices . If you can aid the upstream effort to support your card I suspect Ubuntu would pick the fixed version of the driver in a later release.

I'm not sure it is wise to try and default cards to use ndiswrapper though as I hear this is not really a solution for people running the 64bit version of Ubuntu...

Eugenia Loli-Queru (eloli) wrote :

This is not good enough. You see, Ubuntu not only does not provide support for my Dell 1390 card (mistakenly I called it 1370 above), but it spits this out in the terminal all the time

hostname kernel: [17179624.668000] bcm43xx: Error: Microcode
"bcm43xx_microcode5.fw" not available or load failed.

I had to *blacklist* the bcm43xx module in order to install ndiswrapper and have it work. It's one thing to not support a card and another to create problems thinking that it does support the card. I think you must modify the module's code to not load if a 1390 card is there -- at least not before the project has a working driver for it.

More info about the wifi minicard:

0c:00.0 Network controller: Broadcom Corporation Dell Wireless 1390 WLAN Mini-PCI Card (rev 01)
        Subsystem: Dell Unknown device 0007
        Flags: bus master, fast devsel, latency 0, IRQ 17
        Memory at efdfc000 (32-bit, non-prefetchable) [size=16K]
        Capabilities: [40] Power Management version 2
        Capabilities: [58] Message Signalled Interrupts: Mask- 64bit- Queue=0/0 Enable-
        Capabilities: [d0] Express Legacy Endpoint IRQ 0

Sitsofe Wheeler (sitsofe) wrote :

Could you add the output of
lscpi -vvn
for your card too please?

Eugenia Loli-Queru (eloli) wrote :

attached is the output

Eugenia Loli-Queru (eloli) wrote :

BTW, the BCM43xx driver was giving this error on the log:

hostname kernel: bcm43xx: Error: Microcode "bcm43xx_microcode5.fw" not available or load failed.

It seems that Ubuntu does not have the right firmware installed for the Dell/Broadcomm 1390 cards. However, from what I learned the firmware is now included in the Fedora-Extras DVD and it's possibly "free for individual usage".

Could you please check it out? It would be a shame to have the driver all loaded but not working because of forgetting to add the firmware files.

Changed in bcm43xx-fwcutter:
status: Unconfirmed → Confirmed
description: updated
Alex Mayorga (alex-mayorga) wrote :

Eugenia,

I've corrected the title of this bug for you.

Sitsofe,

I'm seeing exactly the same as Eugenia on a Insiron 1501 on a fully updated, as of yesterday, Feisty.

user@host:~$ lspci -v | grep Broadcom
05:00.0 Network controller: Broadcom Corporation Dell Wireless 1390 WLAN Mini-PCI Card (rev 01)

And bunch of:
hostname kernel: [17179624.668000] bcm43xx: Error: Microcode
"bcm43xx_microcode5.fw" not available or load failed.

I've also linked Answer# 3839

Let me know how can I assist to get this fixed.

Thanks in advance

nanog (sorenimpey) wrote :

This worked for me in Edgy and Feisty:

http://ubuntuforums.org/showthread.php?t=391961

A more generic but very similar tutorial:
http://ubuntuforums.org/showthread.php?t=185174

Is there a problem with supporting the firmware package at the third-party repository?
BTW, The firmware and kernel module has been rock-stable on 2 bcm laptops (including a dell 1390 4311).

This wireless card is very common and should be supported by default.

Eugenia Loli-Queru (eloli) wrote :

Please note that I was able to make the card work after also installing the fwcutter package and installing the right firmware. BUT. This did not work well, because every about 10 seconds of connection, disconnection happens. And then you retry, you reconnect to the wifi router, and then disconnection happens again. In other words, the current driver+firmware available via open source channels is not really usable. I had to use ndiswrapper to make it work well.

Alex Mayorga (alex-mayorga) wrote :

I've stumbled into this post in the bcm43xx development list https://lists.berlios.de/pipermail/bcm43xx-dev/2007-April/004438.html

Any chance that patch would make it into Feisty RC?

Patching a kernel is still out of my league so if anyone can put it in layman terms or make it "just work" i would be grateful.

Eugenia Loli-Queru (eloli) wrote :

It would be nice to get better speeds with the patch you linked (make the https as http if you can't get in the above URL), however, my problem was the constant connection/disconnection with the kind of firmware that the fwcutter package pulled from the web.

nanog (sorenimpey) wrote :

@Eugenia
Did you uninstall ndis wrapper prior to trying fwcutter and the cafuego firmware (removal of nidis wrapper was stressed in tutorials for other distros). A reinstall of network manager anecdotally helped with stability problems on unencrypted networks.

I would be really happy if the patch made it into RC or is offered as a kernel upgrade in the near future. (It took awhile to upgrade 65 packages today.)

Eugenia Loli-Queru (eloli) wrote :

No, I did not uninstall ndiswrapper, because it is part of the system now. I don't want to mess it up. Besides, I don't see why it would interfere, ndiswrapper was not loaded when the bcm driver was loaded when I tried it.

nanog (sorenimpey) wrote :

I upgraded my kernel to 2.6.21rc6 and the dell 1390 card (bcm43xx) is stable and the speed issue was solved. This should really be included in feisty as a significant percentage of all laptops currently being sold have the infamous 4311 card. Basically every other distro has problems with this. I suspect many would consider switching to Ubuntu if this prepatch was made default or offered as a package.

nanog (sorenimpey) wrote :

@alex
This post contains a link to the tutorial that allowed me to prepatch (the prepatch includes the patch mentioned in the berlios mail list). I now have stable and *FAST* 1390 card.

http://ubuntuforums.org/showthread.php?t=407859

Alex Mayorga (alex-mayorga) wrote :

@nanog

Can you pleas link to the specific patch, maybe attach it here to see if this get picked up?

Thanks in advance.

nanog (sorenimpey) wrote :

The patches can be found here:

ftp://lwfinger.dynalias.org/patches

The patches will apparently be included in 2.6.22rc1.

Alex Mayorga (alex-mayorga) wrote :

This is still broken on gutsy tribe 5.

Alex Mayorga (alex-mayorga) wrote :

FWIW

Here's how I got rid of the bcm43xx: Error: Microcode "bcm43xx_microcode5.fw" not available or load failed. messages with my
Broadcom Corporation Dell Wireless 1390 WLAN Mini-PCI Card (rev 01)

 wget http://downloads.openwrt.org/sources/wl_apsta-3.130.20.0.o
 sudo bcm43xx-fwcutter -w /lib/firmware ./wl_apsta-3.130.20.0.o
 sudo ifconfig eth1 down
 sudo ifconfig eth1 up

After that the dmesg errors disappeared.

Hi Alex,

I am using Gutsy Tribe 5, although I am a newbie, because I thought this was fixed. However, when I tried your instruction I get the following:

sudo bcm43xx-fwcutter -w /lib/firmware ./wl_apsta-3.130.20.0.o
sudo: bcm43xx-fwcutter: command not found

I tried to find any *fwcutter* and found no such file. Please update the instructions above.
Thanks,
Dinesh

OK, I activated the restricted driver and got it. I was able to complete your instructions.

Now the router is seen, but it still fails to obtain an IP address, is it because I have the router configured to WPA Personal?

Alex Mayorga (alex-mayorga) wrote :

@Dinesh

You might need wpa supplicant or something like that. My laptop now authenticates with WEP to my router and gets a DHCP IP just fine, but won't ping the router or other machines on the network, very strange.

Please post any success or failure you get.

nanog (sorenimpey) wrote :

FYI: The 1390 card works in Gutsy. The restricted drivers manager automagically install the firmware via fwcutter.

Alex Mayorga (alex-mayorga) wrote :

@nanog,

Would you be kind enough to help me clean up the firmware mess that my laptop might be now and get to use the "automagic" please?

Thanks in advance.

MAIKO (maikko) wrote :

i tried in all ways but on gutsy my dell 1390 doesn't work,i installed by restricted drivers bcmfwcutter and wl_apsta but internet doesn't work :(

Alex Mayorga (alex-mayorga) wrote :

7.10 is released and this is still broken.

hotani (hotani) wrote :

Yep, broken here on a Dell Latitude D531

Henrik Nilsen Omma (henrik) wrote :

This will be retargeted towards the Hardy kernel once it is released. I've tagged this as "hardy-kernel-candidate" so that we make sure to retarget this report once the new release is out. However against the linux-source-2.6.22 package this is being marked as "Won't Fix" as it does not meet the criteria for a stable release update. To learn more about the stable release update process please refer to https://wiki.ubuntu.com/StableReleaseUpdates . Thanks!

Changed in bcm43xx-fwcutter:
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments