Can do more than suggest libxerces2-java-doc

Bug #190247 reported by James Westby on 2008-02-08
4
Affects Status Importance Assigned to Milestone
bcel (Ubuntu)
Wishlist
Unassigned

Bug Description

Hi,

The current libbcel-java-doc only suggests libxerces2-java-doc,
as the latter used to be in multiverse. It has now (in hardy)
moved to main, and as such the former can now go back
to depending on it.

Thanks,

James

Related branches

Daniel T Chen (crimsun) on 2008-11-28
Changed in bcel:
importance: Undecided → Wishlist
status: New → Triaged
Savvas Radevic (medigeek) wrote :

bcel (5.2-3ubuntu3) jaunty; urgency=low

  * debian/control: Added libbcel-java, libxerces2-java-doc back to
    "Depends:". (LP: #190247)

Changed in bcel:
assignee: nobody → medigeek
status: Triaged → In Progress
Changed in bcel:
assignee: medigeek → nobody
status: In Progress → Confirmed
Alexander Sack (asac) wrote :

why a depends and not Recommends? is the xerces2 doc essential?

Savvas Radevic (medigeek) wrote :

I have no idea, I thought of supporting to revert the status of how it used to be. Perhaps James or Martin Pitt (uploader of that change) can give a better explanation.
Or we should file this to the Debian maintainer upstream?

This is the changelog note from 5.2-2ubuntu2:
  * Merge from debian unstable, remaining changes:
    - libbcel-java-doc: Add alternative dependency on libgcj-doc.
    - debian/control: Drop libbcel-java-doc's dependency to
      libxerces2-java-doc to a suggestion, since that is in multiverse.

This is how it was before (5.2-2ubuntu1) in Ubuntu debian/control:
Package: libbcel-java-doc
Architecture: all
Section: doc
Depends: libgcj-doc | classpath-doc, libxerces2-java-doc
Suggests: libbcel-java
Description: Documentation for Byte Code Engineering Library (BCEL)
 Documentation for the BCEL Java library which is used to manipulate Java
 bytecode.
 .
  Homepage: http://jakarta.apache.org/bcel/

This is the Debian debian/control (5.2-3):
Package: libbcel-java-doc
Architecture: all
Section: doc
Depends: classpath-doc, libxerces2-java-doc
Suggests: libbcel-java
Description: Documentation for Byte Code Engineering Library (BCEL)
 Documentation for the BCEL Java library which is used to manipulate Java
 bytecode.
 .
  Homepage: http://jakarta.apache.org/bcel/

I've added a new patch to set as Depends only "libxerces2-java-doc".

Martin Pitt (pitti) wrote :

I agree, it should be reverted to what Debian has. Someone should file a bug against Debian's bcel to drop it to recommends, and also switch to default-jdk build system.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bcel - 5.2-3ubuntu3

---------------
bcel (5.2-3ubuntu3) jaunty; urgency=low

  * debian/control: Added libxerces2-java-doc back to "Depends:".
    (LP: #190247)

 -- Savvas Radevic <email address hidden> Fri, 20 Feb 2009 19:22:25 +0100

Changed in bcel:
status: Confirmed → Fix Released
Savvas Radevic (medigeek) wrote :

I've sent a patch to Debian, including some of the previous ubuntu changes as well:
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=517840

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.