.dcrc file not recognized

Bug #918836 reported by Mei
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
bc (Debian)
Fix Released
Unknown
bc (Ubuntu)
Undecided
Unassigned

Bug Description

When using dc, the man page suggests that the ~/.dcrc file is read at startup.

Using strace against dc shows that this is not the case; the ~/.dcrc file is never opened.

There was a "bug" reported against Debian dc (Debian Bug 472250) that was reported as fixed in version 1.06.94-3.1 and the changelog reports that this change was made in Ubuntu dc.

Debian bug 472250: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=472250

The ~/.dcrc is handy for a variety of things, but one thing is to set the precision of the calculator when starting up.

Related branches

Changed in bc (Debian):
status: Unknown → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in bc (Ubuntu):
status: New → Confirmed
Ryan Kavanagh (ryanakca)
Changed in bc (Debian):
status: Fix Released → Unknown
Changed in bc (Debian):
status: Unknown → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bc - 1.06.95-8

---------------
bc (1.06.95-8) unstable; urgency=low

  * Use makeinfo instead of obsoleted texi2html
  * Reintroduce patch reading ~/.dcrc file at dc start, 06_read_dcrc.diff
    (Closes: #582137) (LP: #918836)
  * Drop old-style 'Home page:' entries in long description
  * Added a gbp.conf to use pristine-tar and to sign tags

 -- Ryan Kavanagh <email address hidden> Sun, 02 Jun 2013 20:43:53 -0400

Changed in bc (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.