NVIDIA Driver Crashes the System

Bug #1684678 reported by Arunkarthick on 2017-04-20
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
bbswitch (Ubuntu)
Undecided
Unassigned

Bug Description

When I install the proprietary driver from NVIDIA the system doesn't log on.In return it repeatedly shows the error.

bbswitch:No suitable _dsm call found

Driver shown Additional Drivers Page:

Using NVIDIA binary driver-version 375.29 from nvidia-375(proprietary,tested).

The NVIDIA Driver was working fine in Ubuntu 16.10 in my laptop.
When I upgraded to Ubuntu 17.04 I got this error. So I completely removed that and made a clean installation of Ubuntu 17.04 but still I got the error.

My Laptop Specs:

OS:Ubuntu 17.04

Processor:i5-5200u

Graphics: NVIDIA 920M 2GB

RAM: 8GB

Arunkarthick (arun-legends) wrote :
no longer affects: unity (Ubuntu)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in bbswitch (Ubuntu):
status: New → Confirmed
Tom Hudson (thudso) wrote :

This also affects me. I'm on a Latitude e7450, and tried exactly the steps described above, but no luck.

Andy Pearson (andyp123) wrote :

Affects me too. This computer (an Asus VivoBook V551L) has worked successfully on about seven previous Ubuntu versions, but on upgrading to 17.04, it won't boot with exactly the error described above.

Tom Hudson (thudso) wrote :

Since the release of NVIDIA 375.66, this issue is resolved for me. For reference, I have a GeForce 840M, in a Dell Latitude e7450 running Ubuntu 17.04.

Kai-Heng Feng (kaihengfeng) wrote :

@Andy, does NVIDIA 375.66 work for you?

Arunkarthick (arun-legends) wrote :

I got the NVIDIA 375.66 update but still the problem persists..

Diego Souza (diegosouza-uni) wrote :

I have a Dell Vostro 5470 with GeForce GT 740M and driver version 375.66. The bug is applied to me too, in the kernel versions 4.4.0-96-generic and 4.4.0-97-generic.

Same here in a Acer Aspire E5-771G with GeForce 820M.
The recent 4.4.0-112 has this issue yet, while 4.4.0-116 is not working for different reasons (perhaps has the same issue too, cannot know for it doesn't boot).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments