bbswitch stopped working with the latest ubuntu-drivers-common / nvidia-prime

Bug #1289298 reported by Alin Andrei on 2014-03-07
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
bbswitch (Ubuntu)
Undecided
Unassigned
nvidia-prime (Ubuntu)
Undecided
Unassigned
ubuntu-drivers-common (Ubuntu)
Undecided
Unassigned

Bug Description

bbswitch no longer works for me in Ubuntu 14.04 (I was using it with nvidia-prime). Even though the package is installed and no errors are displayed when installing it, it doesn't work - "/proc/acpi/bbswitch" doesn't exist at all:

$cat /proc/acpi/bbswitch
cat: /proc/acpi/bbswitch: No such file or directory

And when I try to load it with modprobe I get "modprobe: FATAL: Module bbswitch not found".

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: bbswitch-dkms 0.7-2ubuntu1
ProcVersionSignature: Ubuntu 3.13.0-15.35-generic 3.13.5
Uname: Linux 3.13.0-15-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.13.2-0ubuntu5
Architecture: amd64
CurrentDesktop: Unity
Date: Fri Mar 7 13:42:34 2014
InstallationDate: Installed on 2012-12-30 (431 days ago)
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Release amd64 (20121017.5)
SourcePackage: bbswitch
UpgradeStatus: Upgraded to trusty on 2013-01-12 (418 days ago)

Alin Andrei (nilarimogard) wrote :
Alin Andrei (nilarimogard) wrote :

This might also happen because of the recent ubuntu-drivers-common update

Alin Andrei (nilarimogard) wrote :

And indeed, after downgrading ubuntu-drivers-common to version 0.2.88 and nvidia-prime to version 0.5~hybrid0.0.3, bbswitch works again.

summary: - bbswitch stopped working with the latest kernel
+ bbswitch stopped working with the latest ubuntu-drivers-common / nvidia-
+ prime
Alberto Milone (albertomilone) wrote :

Please make sure that both ubuntu-drivers-common (1:0.2.89.3) and nvidia-prime (0.6) are installed

Changed in bbswitch (Ubuntu):
status: New → Invalid
Alin Andrei (nilarimogard) wrote :

Both are installed, my laptop overheats like crazy because bbswitch doesn't work. After spending an entire day I managed to get it to work using older packages.

This is not invalid, I didn't spend a day fixing something that doesn't exist :)

Alberto Milone (albertomilone) wrote :

Please attach the following files:

1) The output of "dkms status"
2) your /var/log/gpu-manager.log

Alberto Milone (albertomilone) wrote :

and
3) the output of "dmesg"

Alin Andrei (nilarimogard) wrote :

I re-upgraded to ubuntu-drivers-common 1:0.2.89.) and nvidia-prime 0.6 and the bug still occurs. Here is the info you requested:

1) dkms status:
bswitch, 0.8, 3.13.0-16-generic, x86_64: installed
bbswitch, 0.8, 3.13.0-7-generic, x86_64: installed
nvidia-331, 331.38, 3.13.0-16-generic, x86_64: installed
nvidia-331, 331.38, 3.13.0-7-generic, x86_64: installedError! Could not locate dkms.conf file.
File: does not exist.

v4l2loopback, 0.8.0, 3.13.0-15-generic, x86_64: installed
v4l2loopback, 0.8.0, 3.13.0-16-generic, x86_64: installed
v4l2loopback, 0.8.0, 3.13.0-7-generic, x86_64: installed

2) attached

Alin Andrei (nilarimogard) wrote :

3) attached

Alin Andrei (nilarimogard) wrote :

I currently have bbswitch installed from the Bumblebee PPA but the result is the same with the version from the Ubuntu repositories (that's what I was using when I submitted the bug). I'll install the version from the Ubuntu repositories if you want and repost the logs.

Alberto Milone (albertomilone) wrote :

Thanks for reporting the problem. This is really a bug in ubuntu-drivers-common that I have just fixed and uploaded. It's a duplicate of bug #1289420 (let's use that other report for tracking).

Changed in nvidia-prime (Ubuntu):
status: New → Invalid
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-drivers-common - 1:0.2.89.5

---------------
ubuntu-drivers-common (1:0.2.89.5) trusty; urgency=low

  * tests/run:
    - Skip gpu-manager.py on anything other than the x86 family.

ubuntu-drivers-common (1:0.2.89.4) trusty; urgency=medium

  [ Martin Pitt ]
  * Reenable tests.
  * Mark the three failing tests as expected failure instead of skipping them
    entirely, so that we can see what they do on the buildds.

  [ Alberto Milone ]
  * tests/gpu-manager.py:
    - Refactor the test suite by reusing more code and reducing the
      overall code.
    - Add test case for zero length dmi product version.
  * share/hybrid/gpu-manager.c:
    - Do not try to match quirks if dmi product version has zero length
      (LP: #1289298).
 -- Alberto Milone <email address hidden> Sat, 08 Mar 2014 01:26:18 +0100

Changed in ubuntu-drivers-common (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers