bash_completion function for scp broken wrt ' character

Bug #82849 reported by Håkan Lindqvist on 2007-02-02
4
Affects Status Importance Assigned to Milestone
bash (Ubuntu)
Medium
Matthias Klose

Bug Description

Binary package hint: bash

The scp specific function in bash_completion does not escape the ' character.

This causes filenames (local or remote) with the ' character in their filename to have an unescaped ' after completion. Clearly not intended behavior.

A patch will be attached shortly.

Håkan Lindqvist (lindqvist) wrote :

Attaching patch made against bash_completion as of 3.1-5ubuntu3.

Áron Sisak (asisak) wrote :

Thanks for your bugreport (and proposed fix).

Changed in bash:
importance: Undecided → Medium
status: Unconfirmed → Confirmed
Matthias Klose (doko) wrote :

fixed in feisty, bash_3.2-0ubuntu4
thanks for the patch

Changed in bash:
assignee: nobody → doko
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers