expands file as a directory

Bug #68377 reported by sam on 2006-10-26
8
Affects Status Importance Assigned to Milestone
bash (Ubuntu)
Low
Matthias Klose

Bug Description

sam@lreboot:/tmp$ touch a.shell
sam@lreboot:/tmp$ chmod +x a.shell
sam@lreboot:/tmp$ ./a.shell/

type ./a.she <TAB>
and it expands like it's a directory!

Note: the original reporter indicated the bug was in package 'bash-completion'; however, that package was not published in Ubuntu.

Jonh Wendell (wendell) wrote :

Thanks for your report.

Can you tell us both Ubuntu and Bash version you are using?
I'm using edgy and did your steps, but it worked fine.

Changed in bash:
status: Unconfirmed → Needs Info

I'm using edgy and have the same problem - sometimes, and sometimes (more often) not.

marcel@idefix:~$ bash --version
GNU bash, version 3.1.17(1)-release (powerpc-unknown-linux-gnu)
Copyright (C) 2005 Free Software Foundation, Inc.

I've had the problem with dapper, too. Bash completion is activated, the bash runs in a gnome-terminal. As soon as the problem once occured, the bash appends a '/' to everything it completes, for example:

marcel@idefix:~$ aptitude ins<TAB>
marcel@idefix:~$ aptitude install/

I'm using a few tabs in my gnome-terminal, but the problem seems to be only in one of them - the others are alright. And, I think, the tab, which is having this problem, seems to be alway the same...

sam (earlgreykde) wrote :

sorry for the late reply, I was using dapper with *all* the updates applied.
I have upgraded to edgy and can't recreate.

Matthias Klose (doko) wrote :

fixed in edgy.

Changed in bash:
assignee: nobody → doko
importance: Undecided → Low
status: Needs Info → Fix Released

hi,
is it fixed because we were unable to duplicate in edgy, or because
there was a fix added?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers