bash-completion crash

Bug #310789 reported by Ryan Anderson on 2008-12-23
34
This bug affects 2 people
Affects Status Importance Assigned to Milestone
bash (Debian)
New
Unknown
bash (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: bash-completion

Ubuntu Release: Ubuntu 8.10 x86_64
Package Version: 1.872

Case: Using tab completion to fill a file that you have every reason to want to use but the people who wrote the list of approved completions don't think you should be able to perform without manual editing of the config.

Method: Hold the tab key down while yelling profanities. (The yelling is optional)

Result: Your terminal window disappears after about 5 seconds.

Example:

$ touch blah.scd
$ ls
blah.scd
$ unzip [YOU'RE HOLDING TAB HERE.....]
*POOF!*

Chris Crisafulli (itnet7) wrote :

I confirm this happens to me under the same conditions using .Ubuntu Release: Ubuntu 8.10 (32-bit). Also I attempted this on a Ubuntu 8.04.01 machine and the same issue occurred.

Changed in bash-completion:
status: New → Confirmed
Chris Crisafulli (itnet7) wrote :

This should be set to medium, unable to do so until I join ubuntu-bugcontrol.

Connor Imes (ckimes) wrote :

Thank you for reporting this bug. Confirmed from Hardy. Attaching two stacktraces, one running in xterm, another for running in gnome-terminal.

connor@compy686:~$ uname -a
Linux compy686 2.6.24-20-generic #1 SMP Mon Jul 28 13:49:52 UTC 2008 i686 GNU/Linux

connor@compy686:~$ lsb_release -rd
Description: Ubuntu 8.04.1
Release: 8.04

connor@compy686:~$ apt-cache policy bash-completion
bash-completion:
  Installed: 20060301-3ubuntu3
  Candidate: 20060301-3ubuntu3
  Version table:
 *** 20060301-3ubuntu3 0
        500 http://ubuntu.media.mit.edu hardy/main Packages
        100 /var/lib/dpkg/status

Changed in bash-completion:
importance: Undecided → Medium
status: Confirmed → Triaged
Connor Imes (ckimes) wrote :
Connor Imes (ckimes) wrote :
James Westby (james-w) wrote :

Hi,

I can reproduce this, and with the current Debian version as well.

Attached is a backtrace.

Thanks,

James

Changed in bash:
status: Unknown → New
LimCore (limcore) wrote :

malloc: ../bash/subst.c:4198: assertion botched
realloc: start and end chunk sizes differ
last command: ls
Aborting...

Warning: Program '/bin/bash' crashed.

Chris Crisafulli (itnet7) wrote :

chris@ccdell2-jaunty:~$ uname -a
Linux ccdell2-jaunty 2.6.28-11-generic #42-Ubuntu SMP Fri Apr 17 01:57:59 UTC 2009 i686 GNU/Linux

chris@ccdell2-jaunty:~$ lsb_release -rd
Description: Ubuntu 9.04
Release: 9.04
chris@ccdell2-jaunty:~$ apt-cache policy bash-completion
bash-completion:
  Installed: 20080705ubuntu3
  Candidate: 20080705ubuntu3
  Version table:
 *** 20080705ubuntu3 0
        500 http://us.archive.ubuntu.com jaunty/main Packages
        100 /var/lib/dpkg/status

Confirming this issue is still present in Juanty

What are the steps to reproduce this bug? I have tried to reproduce it on Ubuntu 9.10 (x86, 32 bit) with these steps:

1) Create a new directory
2) cd into the new directory
3) Enter these commands
$ touch blah.scd
$ ls
blah.scd
4) Type "unzip" (without quotes), followed by a space and then press TAB
unzip [TAB]

It seems to no longer be reproducible.

On Thu, Feb 25, 2010 at 2:55 PM, Danilo Piazzalunga
<email address hidden>wrote:

> What are the steps to reproduce this bug? I have tried to reproduce it
> on Ubuntu 9.10 (x86, 32 bit) with these steps:
>
> 1) Create a new directory
> 2) cd into the new directory
> 3) Enter these commands
> $ touch blah.scd
> $ ls
> blah.scd
> 4) Type "unzip" (without quotes), followed by a space and then press TAB
> unzip [TAB]
>
> --
> bash-completion crash
> https://bugs.launchpad.net/bugs/310789
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “bash” package in Ubuntu: Triaged
> Status in “bash” package in Debian: New
>
> Bug description:
> Binary package hint: bash-completion
>
> Ubuntu Release: Ubuntu 8.10 x86_64
> Package Version: 1.872
>
> Case: Using tab completion to fill a file that you have every reason to
> want to use but the people who wrote the list of approved completions don't
> think you should be able to perform without manual editing of the config.
>
> Method: Hold the tab key down while yelling profanities. (The yelling is
> optional)
>
> Result: Your terminal window disappears after about 5 seconds.
>
> Example:
>
> $ touch blah.scd
> $ ls
> blah.scd
> $ unzip [YOU'RE HOLDING TAB HERE.....]
> *POOF!*
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/ubuntu/+source/bash/+bug/310789/+subscribe
>

Connor Imes (ckimes) wrote :

I can confirm that this issue has been fixed in 9.10, I am not longer able to reproduce it. It looks like there was a major version upgrade for bash in Karmic, from 3.2 to 4.0. Thanks for letting us know that it's working.

Changed in bash (Ubuntu):
status: Triaged → Fix Released
Lin Ux (er0n) wrote :

This Crash happened again U10.10

jmalter (joerg4711) wrote :

The Bug still persits

try the following

ls /proc <enter>

You will see the directory

ls /proc/<tab>

Bash completion crashes and proc will be unmounted

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.