bash-completion config replacement prompt on upgrade from gutsy to hardy

Bug #210013 reported by Nick Barcet
54
This bug affects 1 person
Affects Status Importance Assigned to Milestone
bash (Ubuntu)
Medium
Matthias Klose
Hardy
Medium
Matthias Klose

Bug Description

Binary package hint: bash-completion

Testing upgrade from fresh gutsy install to hardy I've come to notice that I get systematically a confirmation dialog asking me if I want to replace bash_completion with the maintainer version while this file has not been modified since gutsy install. I beleive this is not normal and should only be asked if the file has been modified.

Revision history for this message
Mathias Gug (mathiaz) wrote :

Confirmed.

Changed in bash-completion:
importance: Undecided → Medium
status: New → Triaged
Revision history for this message
Mika Fischer (zoop) wrote :

I'm not sure what's happening here. I assume the transition of the bash_completion script from the bash package (gutsy) to the separate bash-completion package (hardy) was not done correctly.

I'm not a specialist for debian packaging, so I can't really help here.

What I think is going on is that previously (in the bash package) /etc/bash_completion was not a conffile. Now in the bash-completion package it is maintained by ucf. Since ucf does not know about the old file it has to ask the user what to do about it.

So the problem is that bash leaves the old version of the script in /etc/bash_completion after the upgrade or maybe bash-completion is installed before bash is updated?

Anyone more knowledgable about dpkg can help out?

Revision history for this message
Mika Fischer (zoop) wrote :

After testing with a virtualbox image, I can confirm that the problem is indeed that bash does not remove its version of the bash_completion script on upgrade to the newer version which does not include it anymore, even if it was not changed by the user.

If the file is unchanged it should be removed when upgrading.

Ensuring this will fix this bug since bash will be installed before bash-completion because of an old Conflicts: bash-completion in the gutsy version of the bash package.

Kees Cook (kees)
Changed in bash:
milestone: none → ubuntu-8.04
Steve Langasek (vorlon)
Changed in bash:
assignee: nobody → doko
Revision history for this message
Matthias Klose (doko) wrote :

I'll add the md5sums for the bash_completion file for all bash versions found in releases before hardy, and removing the bash_completion file on upgrade, if the md5sum of the current file matches one of those.

Changed in bash:
status: Triaged → In Progress
Revision history for this message
Matthias Klose (doko) wrote :

fixed in 20060301-3ubuntu3

Changed in bash:
status: In Progress → Fix Released
Revision history for this message
Mika Fischer (zoop) wrote :

I just want to note that the way this was fixed is not optimal, since the bash package still does not clean up after itself.

So now we have reports coming in of people who don't have the bash-completion package installed, but since they still got /etc/bash_completion from the old bash package, they don't notice that. They're stuck with the buggy version and this will potentially create a lot of confusion...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers