Please sync bash-completion 20080705 (main) from Debian unstable (main).

Bug #314806 reported by James Westby on 2009-01-07
4
Affects Status Importance Assigned to Milestone
bash-completion (Ubuntu)
Wishlist
Unassigned

Bug Description

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

 affects ubuntu/bash-completion
 status new
 importance wishlist
 subscribe ubuntu-main-sponsors

Please sync bash-completion 20080705 (main) from Debian unstable (main).

Explanation of the Ubuntu delta and why it can be dropped:
Debian have taken over upstream maintenance, and at that time they
came and pulled all of Ubuntu's changes.

I have been playing with it for the last hour or so doing triage
of the open bugs, and didn't see any problems (apart from the
bugs I was reproducing of course).

Thanks,

James

Changelog since current jaunty version 20060301-4ubuntu3:

bash-completion (20080705) unstable; urgency=low

  [ David Paleino ]
  * Added more completions to imagemagick (thanks to Nelson A. de
    Oliveira) (Closes: #487786)
  * Added xrandr completion (thanks to Anton Khirnov) (Closes: #487825)
  * Improving _gdb completion:
    - $filenames to $default (Closes: #463969)
    - also show directory names (i.e. compgen -d) in COMPREPLY.
    - added . to $PATH, to allow debugging "local" executables.
    - do not complete Bash's builtins (thanks to Morita Sho)

  [ Luk Claes ]
  * Remove use of ucf for /etc/bash-completion (Closes: #488171).

 -- Luk Claes <email address hidden> Sat, 05 Jul 2008 16:14:15 +0200

bash-completion (20080617.5) unstable; urgency=medium

  * Revert way of setting environment variables (Closes: #487774).
  * Add equals sign to _get_cword for mutt_aliases (Closes: #482635).
  * Enhance mlayer completion (Closes: #487826, #487838).

 -- Luk Claes <email address hidden> Tue, 24 Jun 2008 19:50:57 +0200

bash-completion (20080617.4) experimental; urgency=low

  [ David Paleino ]
  * Merged Ubuntu changes:
    - added quote(), quote_readline(), dequote() helper functions.
    - added _remove_word()
    - fixed _get_cword()
    - refactored _filedir using quote_readline()
    - refactored _filedir_xspec using quote_readline()
    - fixed COMPREPLY's in _iwconfig
    - fixed _cvs()
    - _known_hosts(): use files from UserKnownHostsFile options in
                      addition to standard ones.
    - fixed _command() to correctly prune the command line
    - disabled completion of PostgreSQL users and databases
    - fixed _java_packages()
    - fixed _muttquery()
    - added flv/FLV completion to mplayer
    - added --installed to apt-cache
    - only complete on filenames for aspell
    - fixed code for exclusions compspecs
    - added code to gracefully handle debug options (set +/-v)

 -- Luk Claes <email address hidden> Mon, 23 Jun 2008 19:25:25 +0200

bash-completion (20080617.3) unstable; urgency=low

  [ David Paleino ]
  * Fixed IFS for filedir_xspec - Thanks to Stefan Lippers-Hollmann
    (Closes: #487571)

  [ Luk Claes ]
  * Install dh-bash-completion to ease installation of completions.

 -- Luk Claes <email address hidden> Mon, 23 Jun 2008 07:24:21 +0200

bash-completion (20080617.2) unstable; urgency=low

  [ David Paleino ]
  * New upstream release
    - provide a manpage for extra/dh_bash-completion
    - fix semi-serious problem with _filedir() (Closes: #487449)
  * debian/rules:
    - added rule to generate dh_bash-completion's manpage
  * debian/install, debian/dirs:
    - installing dh_bash-completion into /usr/bin
  * debian/control:
    - new package dh-bash-completion

  [ Luk Claes ]
  * Comment new package to make sure current fix gets in the archive first.
  * Add compression completion for vi(m).

 -- Luk Claes <email address hidden> Sun, 22 Jun 2008 19:47:23 +0200

bash-completion (20080617.1) unstable; urgency=medium

  [ David Paleino ]
  * Urgency set to medium because the package is currently unusable.
  * New upstream sub-release
    - fixed some typos here and there which prevented bash completions
      at all (Closes: #487441).
    - really closing Debian bug #455510.

 -- Luk Claes <email address hidden> Sun, 22 Jun 2008 00:22:53 +0200

bash-completion (20080617) unstable; urgency=low

  [ David Paleino ]
  * New upstream release
    - add more completions to aptitude (Closes: #432289)
    - fixed UTF-8 problem with _get_cword(), thanks to
      Andrei Paskevich (Closes: #472132)
    - fixed autoremove completion, thanks to Flavio Visentin
      (Closes: #474974)
    - cmf and CMF added to playmidi completion (Closes: #365658)
    - added rrdtool completion, thanks to Justin Pryzby (Closes: #428641)
    - added OpenDocument completion for unzip/zipinfo (.od{f,g,p,s,t})
      (Closes: #472940)
    - fixed escaping problems with job control (i.e. disown, jobs, bg,
      fg): the argument is now surrounded by "" (Closes: #347316)
    - make mkdir complete also on filenames (Closes: #376433)
    - {bz,z}{cat,cmp,diff,egrep,fgrep,grep,less,more} now should complete
      on all filenames, not just compressed archives (just commented out)
      (Closes: #455510)
    - fixes Perl completion (Closes: #470742)
    - fixes get_cword -> _get_cword typo (Closes: #478596)
    - fixes _get_cword() function to properly handle filenames with
      whitespaces (Closes: #394636, #468254, #474094)
    - added .pdf.bz2 completion to evince (Closes: #424736)
    - added .svg completion to display (Closes: #441017)
    - added .m2ts completion to mplayer (Closes: #480879)
    - added extra/dh_bash-completion to ease future rewrite of bc.
  * debian/copyright - now in a fancier machine-parsable format.
  * debian/control:
    - added myself to Uploaders
    - debhelper Build-Depends updated to >= 6.
  * debian/watch:
    - improved current watch line regex
    - added (commented out) probable future watch line
  * debian/compat bumped to 6
  * debian/dirs, debian/install and debian/links added
  * debian/rules:
    - refactored to make use of debian/{dirs,install,links}

  [ Steve Kemp ]
  * Applied patch to fix completion of umount command.
    (Closes: #470539)
  * Fixed the completion of Perl manpages.
    (Closes: #404976)
  * Added 'aif' to the filenames offed for completion for mplayer.
    (Closes: #474517)
  * Allow tsocks completion.
    (Closes: #409423)
  * Update mutt completion to handle local usernames.
    (Closes: #416655)
  * Update apt-get completion to include the flag "--no-install-recommends"
    (Closes: #475242)

 -- Luk Claes <email address hidden> Sat, 21 Jun 2008 21:59:43 +0200

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)

iEYEARECAAYFAklk9dwACgkQRej+37V3/hOE/QCcDkJGJQsY5eR9SqJOWtHkEZT8
mk0An1igqSRAhiRQe3Uf7YTO/SjjA8U9
=HCif
-----END PGP SIGNATURE-----

Daniel Holbach (dholbach) wrote :

Could it be that the qdbus change was dropped?

James Westby (james-w) wrote :

Gah, sorry, that change is only in the unreleased bzr version, along with
a bunch of other fixes. Hopefully we can sync that before FF.

Attached is a patch for the merge from Debian.

Thanks,

James

Launchpad Janitor (janitor) wrote :
Download full text (5.5 KiB)

This bug was fixed in the package bash-completion - 20080705ubuntu1

---------------
bash-completion (20080705ubuntu1) jaunty; urgency=low

  * Merge from Debian, remaining changes: (LP: #314806)
    * Add qdbus completion. (LP: #257903)
    * Fix IFS issue in _umount and correct _get_cword in _postfix
      (LP: #249337)
    * Both changes in upstream bzr.

bash-completion (20080705) unstable; urgency=low

  [ David Paleino ]
  * Added more completions to imagemagick (thanks to Nelson A. de
    Oliveira) (Closes: #487786)
  * Added xrandr completion (thanks to Anton Khirnov) (Closes: #487825)
  * Improving _gdb completion:
    - $filenames to $default (Closes: #463969)
    - also show directory names (i.e. compgen -d) in COMPREPLY.
    - added . to $PATH, to allow debugging "local" executables.
    - do not complete Bash's builtins (thanks to Morita Sho)

  [ Luk Claes ]
  * Remove use of ucf for /etc/bash-completion (Closes: #488171).

bash-completion (20080617.5) unstable; urgency=medium

  * Revert way of setting environment variables (Closes: #487774).
  * Add equals sign to _get_cword for mutt_aliases (Closes: #482635).
  * Enhance mlayer completion (Closes: #487826, #487838).

bash-completion (20080617.4) experimental; urgency=low

  [ David Paleino ]
  * Merged Ubuntu changes:
    - added quote(), quote_readline(), dequote() helper functions.
    - added _remove_word()
    - fixed _get_cword()
    - refactored _filedir using quote_readline()
    - refactored _filedir_xspec using quote_readline()
    - fixed COMPREPLY's in _iwconfig
    - fixed _cvs()
    - _known_hosts(): use files from UserKnownHostsFile options in
                      addition to standard ones.
    - fixed _command() to correctly prune the command line
    - disabled completion of PostgreSQL users and databases
    - fixed _java_packages()
    - fixed _muttquery()
    - added flv/FLV completion to mplayer
    - added --installed to apt-cache
    - only complete on filenames for aspell
    - fixed code for exclusions compspecs
    - added code to gracefully handle debug options (set +/-v)

bash-completion (20080617.3) unstable; urgency=low

  [ David Paleino ]
  * Fixed IFS for filedir_xspec - Thanks to Stefan Lippers-Hollmann
    (Closes: #487571)

  [ Luk Claes ]
  * Install dh-bash-completion to ease installation of completions.

bash-completion (20080617.2) unstable; urgency=low

  [ David Paleino ]
  * New upstream release
    - provide a manpage for extra/dh_bash-completion
    - fix semi-serious problem with _filedir() (Closes: #487449)
  * debian/rules:
    - added rule to generate dh_bash-completion's manpage
  * debian/install, debian/dirs:
    - installing dh_bash-completion into /usr/bin
  * debian/control:
    - new package dh-bash-completion

  [ Luk Claes ]
  * Comment new package to make sure current fix gets in the archive first.
  * Add compression completion for vi(m).

bash-completion (20080617.1) unstable; urgency=medium

  [ David Paleino ]
  * Urgency set to medium because the package is currently unusable.
  * New upstream sub-release
    - fixed some typos here and there which prevented bash completions
      at all (Closes: #487441).
    - ...

Read more...

Changed in bash-completion:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers