.oga/.ogv extensions should be auto-completed for media players in command line

Bug #311525 reported by Ihar Hrachyshka on 2008-12-26
8
Affects Status Importance Assigned to Milestone
bash-completion (Debian)
Fix Released
Unknown
bash-completion (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: bash-completion

For now neither mplayer nor xine auto-complete filenames for .oga and.ogv files. These extensions are now default for OGG format files, and previous .ogg extension is only for backwards compatibility. Also .oga is the default extension for ripping audio disc contents with Rhythmbox and Sound Juicer. Please, add these extensions to the supported files list.

phwa.nbg (phwa-nbg) wrote :

I think this is a possible mplayer patch:

diff --git a/bash_completion b/bash_completion
index 7518ad9..94e81aa 100644
--- a/bash_completion
+++ b/bash_completion
@@ -5838,7 +5838,7 @@ _mplayer()
                        return 0
                        ;;
                -audiofile)
- _filedir '@(mp3|MP3|mpg|MPG|ogg|OGG|w?(a)v|W?(A)V|mid|MID|flac|FLAC|mka|MKA)'
+ _filedir '@(mp3|MP3|mpg|MPG|ogg|OGG|oga|OGA|ogv|OGV|w?(a)v|W?(A)V|mid|MID|flac|FLAC|mka|MKA)'
                        return 0
                        ;;
                -font)

j^ (j) wrote :

possible Ogg extensions are now ogv, oga, ogx and ogg
(for more info see http://wiki.xiph.org/index.php/MIME_Types_and_File_Extensions)

mplayer but also other players should know about these extension for tab completion
attached patch adds those. trying to only add ogg / oga for those that can only play audio

YoBoY (yoboy-leguesh) wrote :

Thank you for taking the time to make Ubuntu better. Since what you submitted is not really a bug, or a problem, but rather an idea to improve Ubuntu and the auto_completion, this should be also reported upstream.

Changed in bash-completion:
status: New → Confirmed
Bryce Harrington (bryce) on 2011-10-04
Changed in bash-completion (Debian):
importance: Undecided → Unknown
status: New → Unknown
Bryce Harrington (bryce) wrote :

Hi j, thanks for doing the patch. Things have changed in the upstream code a bit, but with a little tweaking I think I got the essence of what you were going for in there. Please doublecheck my work in oneiric and file new bugs if I've omitted anything necessary.

I don't know if there's still time to include it for oneiric but I've uploaded the patch in case there is; otherwise it should go in for pugnacious penguin.

Changed in bash-completion (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bash-completion - 1:1.3-1ubuntu5

---------------
bash-completion (1:1.3-1ubuntu5) oneiric; urgency=low

  * patches/100_upstart.patch: New bash completion for upstart.
    (LP: #535172)
  * patches/101_bash_completion.oga_ogv.patch: Increase support for other
    OGG formats including .oga, .ogx, etc.
    (LP: #311525)
  * patches/102_manpager.patch: Override MANPAGER when generating perldoc
    completions.
    (LP: #738408)
  * patches/103_colormake.patch: Add support for colormake to the make
    completion rules.
    (LP: #743208)
 -- Bryce Harrington <email address hidden> Mon, 03 Oct 2011 22:33:39 -0700

Changed in bash-completion (Ubuntu):
status: Fix Committed → Fix Released
Changed in bash-completion (Debian):
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.