Ubuntu

include bash-completion by default in hardy

Reported by naught101 on 2008-02-27
90
Affects Status Importance Assigned to Milestone
bash-completion (Ubuntu)
Wishlist
Unassigned
Hardy
Wishlist
Unassigned
ubuntu-meta (Ubuntu)
Medium
Martin Pitt
Hardy
Medium
Martin Pitt

Bug Description

Binary package hint: bash-completion

A lot of users upgrading from gutsy to hardy are going to be annoyed when they type "sudo apti" and press tab and nothing happens. It seems like a regression. Please include bash-completion by default.

Related branches

Yes, please do include it again. Just because a user shouldn't have to use the command line is no reason to cripple it - surely it can't take up that much space on the CD?

Changed in bash-completion:
status: New → Confirmed
Trip McKay (trip-mckay) wrote :

I do strongly agree... Installing packages and working fast on the commandline without autocompletion since Alpha 5 is a mess...
I first thought it would be a bug and looked up all my bashrc config files but autocompletion was enabled per-user already. I tried enabling it in the global /etc/bash.bashrc but nothing happened. Fortunately I found this bug report after a lot searching in launchpad.

To mention: before doing anything bash completed the first command typed in (e.g "sudo"), but the following one seemed to be interpreted as parameter and therefore did not autocomplete (e.g. "apt-get"). After installing bash-completion everything worked fine again.

Suggestion: if this is really needed to be done give a hint on it or some comment in the release notes, etc... This will safe a lot of trouble...

Sun Wukong (sunwukong) wrote :

+1 ! I even thought it was some kind of bug ! Very bad regression indeed :-(

Huri (huri) wrote :

+1 I completely agree with everyone here. This is a "must have" feature, and not including it by default is a regression.

Since bash-completion is now in a separate package, it should be a dependency of bash (not only recommended). The file list of bash package should be also updated because /etc/bash_completion is no longer in this package.

Åskar (olskar) wrote :

I agree with Bruno Patri, make it a dependency

Murat Gunes (mgunes) wrote :

According to the changelog [1], bash-completion is now unsupported upstream. This may be the reason it's not being installed by default.

[1] https://bugs.launchpad.net/ubuntu/+source/bash-completion

TeeAhr1 (carl1086) wrote :

+1

will0957 (jasonrw) wrote :

I strongly agree that bash autocompletion should be included by default.

Richard (rd1) wrote :

I agree too - it's a really, really nice feature that helps novices and also helps to convince experts that Ubuntu is a nice distribution. Surely it can't be that hard to keep this included and maintained?

Bruce Cowan (bruce89) wrote :

Try convincing upstream to maintain bash-completion.

Mika Fischer (zoop) wrote :

I try to actively maintain the Ubuntu package and I think after the last upload it is in pretty good shape (before that it was rather broken). I'm in the process of fixing a few more bugs and also rewriting some things that could be done more robustly.

I'm also trying to get in contact with Ian Macdonald (the upstream author) to discuss the future of the project, but I haven't heard back from him yet.

In any case there's someone taking care of the package in Ubuntu, so unmaintainedness is not a good reason against including it by default.

On the other hand I don't really know what to do to get it installed by default. So if anyone cares to work on getting bash_completion into the default install, please do.

Åskar (olskar) wrote :

If it is made a dependency of bash, it will be installed by default I think

Mika Fischer (zoop) wrote :

Hi Åskar,

while what you say is definitely true, the real question is who to poke and what process to follow to get bash to depend on it.

And actually I'd rather suggest that ubuntu-standard recommend it so that people can remove it if they're bothered.

In any case I think that bash-completion would need to be in main for that. On the other hand it has been in main for a long time before it was split out of the bash package, so that might not be a big problem.

I'm just saying I'm not really sure how to proceed and I'd rather spend time fixing bugs than figure out the necessary process to follow :)

Changed in bash-completion:
importance: Undecided → Wishlist
Savvas Radevic (medigeek) wrote :

well whoever marked my bug as duplicate, should notice that the package is ubuntu-meta
https://bugs.launchpad.net/ubuntu/+source/ubuntu-meta/+bug/195163

Changed in ubuntu-meta:
status: New → Confirmed
Savvas Radevic (medigeek) wrote :

And from what I understand, bash-completion needs a maintainer :)

Mika Fischer (zoop) wrote :

Hi Savvas,

as I said above, I'm de-facto the maintainer for Ubuntu, having fixed the most annoying bugs in the last upload and fixing most of the others in the next.

I'd also consider taking over upstream maintainership but I'd like to talk to the current upstream maintainer about that first. He is very busy unfortunately and I've failed to get a response...

But for all practical matters the package is being maintained at least within Ubuntu...

Savvas Radevic (medigeek) wrote :

Good to know that, I have noticed that the package got updated several times in the alpha period but the version says: 20060301-3ubuntu1 - that's why I thought it wasn't maintained. My fault about that, really sorry :)

Well, if that's the case then I don't see a reason not to include it. It provides usability to server and desktop solutions.

Murat Gunes (mgunes) wrote :

Mika, the standard procedure for moving a package from Universe to Main involves writing a main inclusion report and discussing the necessary changes on the development mailing lists. See https://wiki.ubuntu.com/MainInclusionProcess for details.

Changed in ubuntu-meta:
importance: Undecided → Wishlist
Mika Fischer (zoop) wrote :

Murat, thanks for the information. However, as I said above I will not spend any time trying to get bash-completion into main. My time to spend on bash-completion is limited and I'd rather fix the bugs and get them upstream (or assume maintainership). It does not make sense to fix these bugs just in Ubuntu, that's just what I happen to be using, and getting the updated package in was easy enough. But I see my time better spend fixing the bugs and getting upstream maintainance going again. That way all distributions benefit from the fixes.

So to repeat: If anyone wants to have bash-completion in the default install, he will have to do the necessary things himself, because I won't do it (I'll help if I can, obviously).

As for the Main inclusion process. I'm not sure it's necessary, since bash-completion has been in main forever and was just moved to universe as a result of the package split that was done very recently. So maybe it'll be easier to get it back into main than normal packages.

komputes (komputes) wrote :

Please make sure that bash-completion is added and to Hardy before the final release, this is by default something that most users require, and also assists with user support.

Martin Pitt (pitti) wrote :

MIR approved, promoted to main.

Changed in bash-completion:
status: Confirmed → Fix Released
Martin Pitt (pitti) wrote :

I added it to the 'standard' platform seed as recommends. The next update of *-meta packages will have it again.

Changed in ubuntu-meta:
assignee: nobody → pitti
importance: Wishlist → Medium
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-meta - 1.98

---------------
ubuntu-meta (1.98) hardy; urgency=low

  * Refreshed dependencies
  * Added bash-completion to standard-recommends-i386, standard-
    recommends-amd64, standard-recommends-powerpc, standard-recommends-
    ia64, standard-recommends-sparc, standard-recommends-hppa, standard-
    recommends-lpia (LP: #196021)
  * Added gvfs-fuse to desktop-recommends-i386, desktop-recommends-
    amd64, desktop-recommends-powerpc, desktop-recommends-ia64, desktop-
    recommends-sparc, desktop-recommends-hppa, desktop-recommends-lpia
  * Added nautilus-share to desktop-recommends-i386, desktop-recommends-
    amd64, desktop-recommends-powerpc, desktop-recommends-ia64, desktop-
    recommends-sparc, desktop-recommends-hppa, desktop-recommends-lpia
  * Added pulseaudio-module-x11 to desktop-recommends-i386, desktop-
    recommends-amd64, desktop-recommends-powerpc, desktop-recommends-
    ia64, desktop-recommends-sparc, desktop-recommends-hppa, desktop-
    recommends-lpia
  * Removed scim-tables-additional from desktop-recommends-i386

 -- Martin Pitt <email address hidden> Mon, 31 Mar 2008 15:52:18 +0200

Changed in ubuntu-meta:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers