error after upgrading to distinct package: bash: complete: kpdf: no completion specification

Bug #190619 reported by Daniel Pittman
10
Affects Status Importance Assigned to Milestone
bash-completion (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: bash-completion

After upgrading to the new bash-completion package in hardy I get this error when I start a new shell:

bash: complete: kpdf: no completion specification

This error is new with the external package, and did not occur with the earlier version included in bash.

] cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=8.04
DISTRIB_CODENAME=hardy
DISTRIB_DESCRIPTION="Ubuntu hardy (development branch)"

] dpkg -l bash-completion | cat
ii bash-completion 20060301-0ubuntu1 programmable completion for the bash shell

Regards,
       Daniel

Revision history for this message
chastell (chastell) wrote :

Confirming (Hardy Alpha 4 updated to current).

Changed in bash-completion:
status: New → Confirmed
Revision history for this message
Nemes Ioan Sorin (nemes-sorin) wrote :

Same error here

Revision history for this message
Nemes Ioan Sorin (nemes-sorin) wrote :

I forgot to say -> Hardy Alpha - up to date

Revision history for this message
Sergey Romanov (sml-uni) wrote :

'kpdf' should be deleted from the end of the line #88 in /etc/bash_completion, since it is now redefined in the line #84.

That means,

complete -f -X '!*.@(pdf|PDF)' acroread gpdf xpdf kpdf

should now be

complete -f -X '!*.@(pdf|PDF)' acroread gpdf xpdf

Revision history for this message
Sergey Romanov (sml-uni) wrote :

Well, I have just tested and found that kpdf can't handle compressed formats. So, really you should remove kpdf from the line #84 too, and add this line after it:
complete -f -X '!*.@(?(e)ps|?(E)PS|pdf|PDF)' kpdf

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bash-completion - 20060301-1ubuntu1

---------------
bash-completion (20060301-1ubuntu1) hardy; urgency=low

  * Fix kpdf completion. LP: #190619.

 -- Matthias Klose <email address hidden> Wed, 20 Feb 2008 21:28:24 +0100

Changed in bash-completion:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers