base64url can't decode own coded strings

Bug #1862515 reported by Aapo Rantalainen on 2020-02-09
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
basez (Ubuntu)
Undecided
Unassigned

Bug Description

Working task:
echo -n -e "\x3c\xf4\xc6\x86\x8f\x79" | base64url | base64url -d |xxd -p -c 100
3cf4c6868f79

Non-working task:
echo -n -e "\x3c\xf4\xc6\x86\x8f\x80" | base64url | base64url -d |xxd -p -c 100
base64url: invalid input

Fixed in upstream:
2019-08-03 Milan Kupcevic
       * base64.c: Properly decode base64url encoded strings.

Fixed in Debian (bullseye)
basez (1.6-4) sid; urgency=medium
  * Properly decode base64url encoded strings (closes: #931041)
 -- Milan Kupcevic Sun, 04 Aug 2019 00:53:50 -0400

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in basez (Ubuntu):
status: New → Confirmed

$ echo -e 'oo\x80' | base64url | base64url -d
base64url: invalid input

Ubuntu 18.04

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package basez - 1.6.2-1

---------------
basez (1.6.2-1) sid; urgency=medium

  * new upstream release
    - properly decode base64url encoded strings (lp: #1862515)
  * set standards version to 4.5.0
  * set debhelper compatibility to 11
  * d/patch/build: reorganize installdirs tasks
  * d/patch/missing-runstatedir-option: add runstatedir configure option

 -- Milan Kupcevic <email address hidden> Mon, 10 Feb 2020 01:02:28 -0500

Changed in basez (Ubuntu):
status: Confirmed → Fix Released

Would the fix be backported to Ubuntu 18.04?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers