Eliminate udisks 1 from Ubuntu

Bug #1288253 reported by Martin Pitt on 2014-03-05
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
basenji (Ubuntu)
High
Unassigned
daisy-player (Debian)
Fix Released
Unknown
daisy-player (Ubuntu)
High
Unassigned
dell-recovery (Ubuntu)
High
Unassigned
guymager (Debian)
Fix Released
Unknown
libpam-usb (Ubuntu)
High
Unassigned
linaro-image-tools (Debian)
Fix Released
Unknown
mic2 (Ubuntu)
Medium
Unassigned
quodlibet (Ubuntu)
Medium
Unassigned
rds (Ubuntu)
High
Unassigned
scolasync (Ubuntu)
High
Georges Khaznadar

Bug Description

udisks2 has been around in Ubuntu since Quantal, and udisks 1 is deprecated and unsupported.

Please note that udisks2 also has a library interface (libudisks2-0) which is easier to use than raw D-BUS calls. It is also introspectable (gir1.2-udisks-2.0) so you can use it from languages like Python.

The API is documented at http://udisks.freedesktop.org/docs/latest/ .

Debian bugs: https://bugs.debian.org/cgi-bin/pkgreport.cgi?tag=udisks1-deprecation;<email address hidden>

Related branches

Martin Pitt (pitti) wrote :

I'm marking reverse-recommends as Medium and reverse-depends as high.

Changed in guymager (Ubuntu):
importance: Undecided → Medium
Changed in linaro-image-tools (Ubuntu):
importance: Undecided → Medium
Changed in mic2 (Ubuntu):
importance: Undecided → Medium
Changed in quodlibet (Ubuntu):
importance: Undecided → Medium
Changed in basenji (Ubuntu):
importance: Undecided → High
Changed in daisy-player (Ubuntu):
importance: Undecided → High
Changed in dell-recovery (Ubuntu):
importance: Undecided → High
Changed in libpam-usb (Ubuntu):
importance: Undecided → High
Changed in rds (Ubuntu):
importance: Undecided → High
Changed in scolasync (Ubuntu):
importance: Undecided → High
Martin Pitt (pitti) on 2014-03-05
Changed in guymager (Ubuntu):
status: New → Confirmed
status: Confirmed → Triaged
Martin Pitt (pitti) on 2014-03-05
description: updated
Changed in linaro-image-tools (Ubuntu):
status: New → Triaged
description: updated
Changed in mic2 (Ubuntu):
status: New → Triaged
Martin Pitt (pitti) on 2014-03-05
Changed in quodlibet (Ubuntu):
status: New → Triaged
Changed in dell-recovery (Ubuntu):
status: New → Triaged
Martin Pitt (pitti) on 2014-03-05
Changed in rds (Ubuntu):
status: New → Triaged
Changed in scolasync (Ubuntu):
status: New → Triaged
Changed in libpam-usb (Ubuntu):
status: New → Triaged
Martin Pitt (pitti) on 2014-03-05
Changed in daisy-player (Ubuntu):
status: New → Triaged
Changed in basenji (Ubuntu):
status: New → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package dell-recovery - 1.31

---------------
dell-recovery (1.31) trusty; urgency=low

  * refresh grub2 patches for trusty grub2 2.02~beta2-7.
  * fix some deprecated usage of python3 w/ gtk
  * drop argument in find_partitions()
  * Update to udisks2. Drop support for older udisks and devkit-disks
    (LP: #1288253)
  * debian/control: new standards version
  * set booting kernel name to vmlinuz.efi now.
  * drop old GRUB patches, only want to be booting to trusty+ now.
  * disable dereference in building initrd.
 -- Mario Limonciello <email address hidden> Wed, 19 Mar 2014 00:30:55 -0500

Changed in dell-recovery (Ubuntu):
status: Triaged → Fix Released
Changed in daisy-player (Debian):
status: Unknown → Confirmed
Changed in daisy-player (Debian):
status: Confirmed → Fix Released
Phillip Susi (psusi) wrote :

rds has been removed.

Changed in rds (Ubuntu):
status: Triaged → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package daisy-player - 8.6.0-1

---------------
daisy-player (8.6.0-1) unstable; urgency=low

  * New upstream release (Closes: #740844, LP: #1288253)
  * Update dependencies

 -- Paul Gevers <email address hidden> Sat, 12 Apr 2014 21:47:16 +0200

Changed in daisy-player (Ubuntu):
status: Triaged → Fix Released
Christoph Reiter (lazka) wrote :

fixed in 3.2

Changed in quodlibet (Ubuntu):
status: Triaged → Fix Committed
Jackson Doak (noskcaj) on 2015-04-29
Changed in quodlibet (Ubuntu):
status: Fix Committed → Fix Released
Georges Khaznadar (georgesk) wrote :

The dependency on udisks 1 has been removed since version 5.0

Changed in scolasync (Ubuntu):
assignee: nobody → Georges Khaznadar (georgesk)
status: Triaged → Fix Released
Martin Pitt (pitti) wrote :

Removing packages from wily:
 basenji 1.0.1-3 in wily
  basenji 1.0.1-3 in wily amd64
  basenji 1.0.1-3 in wily arm64
  basenji 1.0.1-3 in wily armhf
  basenji 1.0.1-3 in wily i386
  basenji 1.0.1-3 in wily powerpc
  basenji 1.0.1-3 in wily ppc64el
Comment: (from Debian) RoQA; unmaintained, depends on obsolete udisks

Changed in basenji (Ubuntu):
status: Triaged → Fix Released
Martin Pitt (pitti) wrote :

Removing packages from wily:
 libpam-usb 0.5.0-4 in wily
Comment: (from Debian) RoQA; unmaintained, depends on obsolete udisks

Changed in libpam-usb (Ubuntu):
status: Triaged → Fix Released
Martin Pitt (pitti) wrote :

mic2 was removed in utopic.

Changed in mic2 (Ubuntu):
status: Triaged → Fix Released
Martin Pitt (pitti) wrote :

guymager is just a reverse-recommends, and conversion to udisks 2 is tracked in Debian. So not blocking on that.

no longer affects: guymager (Ubuntu)
no longer affects: linaro-image-tools (Ubuntu)
Martin Pitt (pitti) wrote :

linaro-image-tools is just a reverse-recommends, conversion is tracked in Debian, and we don't use this package in Ubuntu. Not blocking on that either.

So, time to finally put this to a rest:

Removing packages from wily:
 udisks 1.0.5-1build1 in wily
Comment: obsolete, unmaintained, superseded by udisks2 years ago, LP#1288253

Changed in guymager (Debian):
status: Unknown → Confirmed
Changed in linaro-image-tools (Debian):
status: Unknown → New
Changed in linaro-image-tools (Debian):
status: New → Fix Released
Changed in guymager (Debian):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.