add support for AMD CPU Family 14h

Bug #676838 reported by Keng-Yu Lin on 2010-11-18
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OEM Priority Project
High
Unassigned
base-installer (Ubuntu)
High
Colin Watson
Nominated for Maverick by Keng-Yu Lin
Lucid
High
Colin Watson
Natty
High
Colin Watson

Bug Description

Binary package hint: ubiquity

AMD has a new CPU family 14h.

Ubiquity should install the PAE kernel if the system is equipped 4GB memory but this cpu family is not currently recognised by ubiquity.

Please apply the attached patch for fixing this.

Keng-Yu Lin (lexical) wrote :
Keng-Yu Lin (lexical) wrote :

could be appropriate for maverick / lucid SRU too.

Keng-Yu Lin (lexical) on 2010-11-18
Changed in ubiquity (Ubuntu):
status: New → Confirmed
importance: Undecided → High
tags: added: patch
summary: - add support for AMD CPU Famaly 14h
+ add support for AMD CPU Family 14h
Changed in ubiquity (Ubuntu Natty):
status: Confirmed → Triaged
Changed in ubiquity (Ubuntu Lucid):
status: New → Triaged
Changed in ubiquity (Ubuntu Lucid):
importance: Undecided → High
Chris Van Hoof (vanhoof) on 2010-12-01
tags: added: hwe-blocker
Steve Magoun (smagoun) on 2011-01-06
Changed in oem-priority:
status: New → Confirmed
importance: Undecided → High
Colin Watson (cjwatson) wrote :

I'll apply this for Natty and Lucid, thanks.

Is there any point in applying this for Maverick? We're not going to be doing a point release, and thus no new CD images, so the new installer won't get into very many people's hands.

affects: ubiquity (Ubuntu Lucid) → base-installer (Ubuntu Lucid)
Changed in base-installer (Ubuntu Lucid):
status: Triaged → Fix Committed
assignee: nobody → Colin Watson (cjwatson)
Changed in base-installer (Ubuntu Natty):
assignee: nobody → Colin Watson (cjwatson)
status: Triaged → Fix Committed
Changed in base-installer (Ubuntu Lucid):
status: Fix Committed → Triaged
Colin Watson (cjwatson) wrote :

(For future reference, anything under d-i/source/ is simply a copy of another source package, updated every time we upload ubiquity. We don't bother tracking bugs in these against ubiquity, as it would be a lot of bookkeeping for little benefit - instead, we simply track bugs against the original source package in question.)

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package base-installer - 1.114ubuntu2

---------------
base-installer (1.114ubuntu2) natty; urgency=low

  * Support AMD CPU family 20 (thanks, Keng-Yü Lin; LP: #676838).
 -- Colin Watson <email address hidden> Thu, 06 Jan 2011 22:24:50 +0000

Changed in base-installer (Ubuntu Natty):
status: Fix Committed → Fix Released
Colin Watson (cjwatson) on 2011-01-06
Changed in base-installer (Ubuntu Lucid):
status: Triaged → In Progress
Keng-Yu Lin (lexical) wrote :

@Colin
  Thanks for the reminding to report a bug against the source package.
  It is okay to reject the nomination for Maverick.

Steve Magoun (smagoun) wrote :

Marking the oem-priority bug task as 'Fix Released' because this fix is now upstream. OEM doesn't have a current requirement for this feature to be released as a Maverick or Lucid SRU.

Changed in oem-priority:
status: Confirmed → Fix Released
Chris Van Hoof (vanhoof) wrote :

Closing the remaining lucid task here. This has been addressed in 10.10, 11.04, and 11.10

Changed in base-installer (Ubuntu Lucid):
status: In Progress → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers