Ubuntu

Lucid point release installer must support LTS backported Kernels

Reported by Tim Gardner on 2010-07-20
28
This bug affects 2 people
Affects Status Importance Assigned to Milestone
base-installer (Ubuntu)
Undecided
Unassigned
Lucid
Undecided
Unassigned
debian-installer (Ubuntu)
Undecided
Unassigned
Lucid
High
Colin Watson

Bug Description

Lucid point releases must support LTS backported kernels as install targets.

Tim Gardner (timg-tpi) on 2010-07-20
affects: ubuntu → base-installer (Ubuntu)
Changed in base-installer (Ubuntu):
importance: Undecided → High
milestone: none → ubuntu-10.04.2
summary: - Installer must support LTS backported Kernels
+ Lucid point release installer must support LTS backported Kernels
Colin Watson (cjwatson) wrote :

What will the package names be?

How should this be presented? The choices I can imagine are:

  1) Everyone gets asked a question in the "Installing the base system" step of installation.
  2) Some kind of option in the CD boot menu.
  3) No UI, but we document a boot parameter to select the backported kernel.

I assume that this is alternate/server CDs only, and presumably only where we have space - I don't know the answer to this right now and it may even only be feasible on netboot installs depending on how the numbers work out. Doing it for the desktop CD is significantly more complex, and I'd question the usefulness anyway since if you can boot the desktop CD at all then by definition you have a kernel which works fairly well (with the possible exceptions of audio and networking) - at any rate this doesn't seem like the first reasonable target.

Changed in base-installer (Ubuntu):
status: New → Incomplete
Tim Gardner (timg-tpi) wrote :

Colin - The Lucid PPA source package is currently called linux-maverick. It produces binaries of the form linux-image-2.6.35-ABI-server. The meta source package is called linux-meta-lts-backport-maverick, producing binaries of the form linux-image-server-lts-backport-maverick. As for install, I envision the backported kernel just being a server and alternate install choice ala option 1. The spec is at:

https://wiki.ubuntu.com/specs/KernelLucidNewKernelonLTS

Stefan Bader (smb) wrote :

If I may add my 1penny, I think option 2 would be better (or 3 but that seems a bit less pretty). The reason for it being tha some might need support from the backport kernel at installation. And I think option 1 would only allow to install a different kernel, but not to boot it for the installation.

Tim Gardner (timg-tpi) wrote :

Yeah, I guess I was assuming that the installed kernel choices would begin at the grub prompt.

Colin Watson (cjwatson) on 2010-11-10
Changed in base-installer (Ubuntu Lucid):
status: New → Triaged
importance: Undecided → High
milestone: none → ubuntu-10.04.2
assignee: nobody → Colin Watson (cjwatson)
Changed in base-installer (Ubuntu):
status: Incomplete → Invalid
importance: High → Undecided
milestone: ubuntu-10.04.2 → none
Colin Watson (cjwatson) wrote :

Looks like this might actually be already in base-installer! I'll have to test it to make sure, and of course we'll need to add the boot menu UI and get the packages onto the CDs, but it looks as though base-installer/kernel/altmeta=lts-backport-maverick will do the trick.

Colin Watson (cjwatson) wrote :

Let's look at sizing, then. The lucid server CD (last built on 2010-11-24) currently has 18345984 bytes free on amd64 and 27488256 bytes free on i386. Any one of the -lts-backport-maverick kernels exceeds both of these by some margin: the smallest non-virtual kernel is 33742668 bytes (generic on i386). Oddly, -virtual is actually bigger than that, but never mind ...

This doesn't leave me with many options. I can't add the backported kernel to the point release server CDs without removing something else, which is a tricky proposition in a point release. We haven't actually been building DVDs for point releases, but I should be able to add them to DVDs anyway. Or we can just leave this to netboot installations only, add it to the boot menu, and document it for PXE-booters. What do you think?

Per comment #3, we also need to build installer kernel/initrd variants based on the backported kernels.

Tim Gardner (timg-tpi) wrote :

Colin - I'm OK with it being a PXE boot option, and DVD (if indeed we produce DVD point releases).

Colin Watson (cjwatson) on 2010-12-15
Changed in debian-installer (Ubuntu):
status: New → Invalid
Changed in debian-installer (Ubuntu Lucid):
status: New → Triaged
importance: Undecided → High
milestone: none → ubuntu-10.04.2
assignee: nobody → Colin Watson (cjwatson)
Colin Watson (cjwatson) wrote :

I've confirmed that a base-installer change is unnecessary; base-installer/kernel/altmeta=lts-backport-maverick works fine.

I've added the necessary kernel images to the Lucid DVD images, and I'm going to change the debian-installer build system to generate several new images, called maverick-cdrom, maverick-netboot, etc.; these will use the backported kernel during installation, and will also be preconfigured to install the backported kernel on the target system.

Until linux-lts-backport-maverick 2.6.35-23.41~lucid1 and linux-meta-lts-backport-maverick 2.6.35.23.35 are promoted to lucid-updates, it will be necessary to add apt-setup/proposed=true as an installer boot parameter to test this.

Changed in base-installer (Ubuntu Lucid):
assignee: Colin Watson (cjwatson) → nobody
milestone: ubuntu-10.04.2 → none
status: Triaged → Invalid
importance: High → Undecided
Changed in debian-installer (Ubuntu Lucid):
status: Triaged → In Progress
Colin Watson (cjwatson) wrote :

After this, it will only remain to arrange for the maverick kernel and initrd to be available as boot options on the DVD.

Accepted debian-installer into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in debian-installer (Ubuntu Lucid):
status: In Progress → Fix Committed
tags: added: verification-needed
Colin Watson (cjwatson) wrote :

revno: 1626
committer: Colin Watson <email address hidden>
branch nick: debian-cd
timestamp: Wed 2011-01-19 14:37:19 +0000
message:
  add maverick installer images to amd64/i386 lucid DVDs (LP: #607657)

Martin Pitt (pitti) wrote :

The current d-i lucid-proposed build introduces a regression: Now alternate CD builds fail with

  debian-installer has kernel ABI 2.6.35-23-generic, but no corresponding udebs are on the CD!

That's the ABI of the maverick backported kernel, the real lucid kernel is .32-28. The build log [1] actually looks ok at first sight, it's pulling down the .32-28 udebs.

For some reason this doesn't affect the amd64 lucid-daily alternates, they have built fine for a while.

[1] http://launchpadlibrarian.net/62474828/debian-installer_20081029ubuntu102.6_20081029ubuntu102.7.diff.gz

tags: added: verification-failed
removed: verification-needed
tags: added: regression-proposed
Changed in debian-installer (Ubuntu Lucid):
status: Fix Committed → In Progress
Colin Watson (cjwatson) wrote :

My debian-installer upload on amd64 was incorrect: the maverick-* outputs aren't actually using the backported kernel.

I'm doing a debug build on antimony to try to track down why the alternates are caring about 2.6.35-23-generic. That looks like a bug in our debian-cd branch and not a problem with debian-installer.

Colin Watson (cjwatson) wrote :

I've rolled out a debian-cd fix, and am now doing an amd64 test build to find out what went wrong there.

Colin Watson (cjwatson) wrote :

I've uploaded a fixed version to lucid-proposed.

Martin Pitt (pitti) wrote :

Accepted debian-installer into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in debian-installer (Ubuntu Lucid):
status: In Progress → Fix Committed
tags: removed: verification-failed
tags: added: verification-needed
tags: removed: regression-proposed

verification for lucid.

I've verified that:
- Selecting the menu entry 'Install Ubuntu' installs a system with the lucid kernel
- Selecting the menu entry 'Install Ubuntu (2.6.35)' installs a system with the backported Kernels
- After a reboot, system boots and works correctly (X comes up, and wired network connectivity)

I've verified DVDs for i386 and AMD64.

Marking as verification-done.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package debian-installer - 20081029ubuntu102.8

---------------
debian-installer (20081029ubuntu102.8) lucid-proposed; urgency=low

  * Fix amd64 builds to actually include the lts-backport-maverick kernel on
    maverick-* images (LP: #607657).

debian-installer (20081029ubuntu102.7) lucid-proposed; urgency=low

  * Build images with the lts-backport-maverick kernel (2.6.35-23) for amd64
    and i386, which are themselves configured to install the
    lts-backport-maverick kernel (LP: #607657).
  * Move to 2.6.32-28 kernels.
 -- Colin Watson <email address hidden> Tue, 25 Jan 2011 11:19:31 +0000

Changed in debian-installer (Ubuntu Lucid):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers