Please provide /etc/os-release

Bug #947236 reported by Martin Pitt on 2012-03-05
54
This bug affects 10 people
Affects Status Importance Assigned to Milestone
base-files (Debian)
Fix Released
Unknown
base-files (Ubuntu)
Wishlist
Canonical Foundations Team
Precise
Wishlist
Unassigned
Quantal
Wishlist
Unassigned

Bug Description

/etc/os-release is a new upcoming attempt of a standard which is meant to supersede /etc/debian_version, and their counterparts in Fedora/SUSE: http://www.freedesktop.org/software/systemd/man/os-release.html

/etc/lsb_release is similar to this, but not standardized. The standard interface right now is to call lsb_release which is a Python script and thus a very high overhead compared to merely reading a file.

[SRU justification for quantal and resubmission for precise]

The original attempt at including os-release didn't mark it as a conffile and, as such,
when upgrading to raring, which does so, this caused some migration issues. To mitigate
that, and not have to have md5sums and magic preinsts for every precise and quantal version forever, I'm SRUing to quantal and re-submitting the precise SRU with conffile
migrations, so the affected non-conffile window is only a few versions from Q.

Robert Roth (evfool) on 2012-03-06
Changed in base-files (Ubuntu):
status: New → Confirmed
Changed in base-files (Ubuntu):
importance: Undecided → Wishlist
Changed in base-files (Ubuntu):
assignee: nobody → Canonical Foundations Team (canonical-foundations)
Changed in base-files (Debian):
status: Unknown → New
Mark Shuttleworth (sabdfl) wrote :

LSB is not a standard? SRSLY?

Martin Pitt (pitti) wrote :

No, /etc/lsb_release is indeed not. Only the "lsb_release" binary is an LSB standard, but having to call a Python script from other programs just to get the current release name is _very_ expensive.

Changed in base-files (Debian):
status: New → Fix Released
Steve Langasek (vorlon) on 2012-06-21
tags: added: rls-q-notfixing
ruario (e-launchpad-ruari-com) wrote :

F.Y.I The file is already present in recent versions of the following distros: Angstrom, ArchLinux, Debian (sid), Fedora, Frugalware, OpenSUSE, Fedora, Mageia (and possibly others), so Ubuntu is a little behind on this one. Will this be fixed in time for Quantal?

ruario (e-launchpad-ruari-com) wrote :

Not sure why I listed Fedora, twice. That was a mistake!

Changed in base-files (Ubuntu Quantal):
status: Confirmed → Opinion
Jeremy Bicha (jbicha) wrote :

Dmitrijs, why are you marking this as Opinion? Please don't mark bugs invalid without a brief explanation why.

We'll basically get this for free the next time we merge base-files from Debian. This bug then might not get fixed until 13.04 but it will get fixed.

Steve Langasek (vorlon) on 2012-08-24
Changed in base-files (Ubuntu Quantal):
status: Opinion → Won't Fix
Changed in base-files (Ubuntu):
status: Opinion → Triaged
Jeremy Bicha (jbicha) wrote :

Thank you

ruario (e-launchpad-ruari-com) wrote :

> We'll basically get this for free the next time we merge base-files from Debian.

You will get the file for free but it will still need adjusting to have Ubuntu specific information.

As a side note, in addition to the distros I listed earlier I noticed that Gentoo also added this 3 months back:
http://sources.gentoo.org/cgi-bin/viewvc.cgi/baselayout/trunk/etc.Linux/os-release?view=log&pathrev=3203

Also Slackware have just added this to their development version, so the next Slackware version (14. 0, which is currently at RC3), will include it as well:
http://ftp.slackware.com/pub/slackware/slackware-current/source/a/aaa_base/os-release

Quantal will be the odd one out, since most of the well known distros already have this.

Mark Fernandes (typist) wrote :

Kindly fix as this helps people like me who continuously switch between distros and its annonying. I was one of those who was happy with lsb-release and the /etc/lsb-release already provided by Ubuntu, however, the reasoning given in this FAQ provides a calm, reasoned explanation why they came up with this in the first place:

http://0pointer.de/blog/projects/os-release

TIA and Much appreciated!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package base-files - 6.5ubuntu9

---------------
base-files (6.5ubuntu9) quantal; urgency=low

  * Install /etc/os-release. LP: #947236.
 -- Matthias Klose <email address hidden> Mon, 10 Sep 2012 15:38:03 +0200

Changed in base-files (Ubuntu Quantal):
status: Won't Fix → Fix Released

Hello Martin, or anyone else affected,

Accepted into precise-proposed. The package will build now and be available in a few hours in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed
Changed in base-files (Ubuntu Precise):
status: New → Fix Committed
importance: Undecided → Wishlist
milestone: none → ubuntu-12.04.2
Daniel Hahler (blueyed) wrote :

Shouldn't VERSION_ID include the full version ("12.04.1" instead of "12.04")?

Adam Conrad (adconrad) wrote :

Fixed in Raring.

Changed in base-files (Ubuntu):
status: Triaged → Fix Released
Adam Conrad (adconrad) wrote :

Marking verification-failed, this upload didn't correctly mark /etc/os-release as a conffile, which will make future upgrades prompt for conffile updates, unless we do the preinst deletion trick for the precise version as well.

To avoid the migration magic and hassle, please re-upload with os-release added to conffiles.

tags: added: verification-failed
removed: verification-needed
Adam Conrad (adconrad) on 2012-10-23
Changed in base-files (Ubuntu Quantal):
status: Fix Released → In Progress
Changed in base-files (Ubuntu Precise):
status: Fix Committed → In Progress
Adam Conrad (adconrad) on 2012-10-23
description: updated
description: updated
Brian Murray (brian-murray) wrote :

Hello Martin, or anyone else affected,

Accepted base-files into quantal-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/base-files/6.5ubuntu12 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in base-files (Ubuntu Quantal):
status: In Progress → Fix Committed
tags: removed: verification-failed
tags: added: verification-needed
Brian Murray (brian-murray) wrote :

Hello Martin, or anyone else affected,

Accepted base-files into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/base-files/6.5ubuntu6.4 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in base-files (Ubuntu Precise):
status: In Progress → Fix Committed
Adam Conrad (adconrad) wrote :

Verified on both quantal and precise with the following steps:

[precise]
1) From a base precise release, upgrade to the current proposed version, and verify that /etc/os-release exists with the correct contents and is listed as a conffile.
2) From a base precise release, upgrade to the previous broken proposed version, then update to the current one, verify that /etc/os-release was not a conffile before, and was properly migrated after the upgrade.

[quantal]
1) From a base quantal release, upgrade to the proposed version, and verify that /etc/os-release was correctly migrated to being a conffile, and retains the original contents.

tags: added: verification-done
removed: verification-needed

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package base-files - 6.5ubuntu6.4

---------------
base-files (6.5ubuntu6.4) precise; urgency=low

  * Mark /etc/os-release as a conffile, and migrate it in the preinst
    for the benefit of people who tested the previous precise version

base-files (6.5ubuntu6.3) precise-proposed; urgency=low

  * Install /etc/os-release. LP: #947236.
 -- Adam Conrad <email address hidden> Tue, 23 Oct 2012 22:52:07 +0100

Changed in base-files (Ubuntu Precise):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package base-files - 6.5ubuntu12

---------------
base-files (6.5ubuntu12) quantal; urgency=low

  * Remove leap-second hack, which causes issues on some VMs: LP: #1022198
  * Migrate /etc/os-release to a conffile, see LP: #947236 for rationale.
 -- Adam Conrad <email address hidden> Tue, 23 Oct 2012 11:16:32 +0100

Changed in base-files (Ubuntu Quantal):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.