lucid->precise upgrade - prompt to update unmodified conf files in /etc/update-motd.d: 00-header, 10-help-text, 99-footer

Bug #903137 reported by Jean-Baptiste Lallement on 2011-12-12
20
This bug affects 2 people
Affects Status Importance Assigned to Milestone
base-files (Ubuntu)
Medium
Steve Langasek
Precise
Medium
Steve Langasek

Bug Description

Autoupgrade testing Lucid to Precise i386/amd64

The base image is a fresh installation of Lucid. During upgrade, the user is prompted to update the following unmodified configuration files:
00-header
10-help-text
99-footer

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: base-files 6.5ubuntu3
ProcVersionSignature: Ubuntu 3.2.0-3.8-generic 3.2.0-rc4
Uname: Linux 3.2.0-3-generic x86_64
ApportVersion: 1.90-0ubuntu1
Architecture: amd64
Date: Mon Dec 12 11:48:52 2011
Dependencies:

EcryptfsInUse: Yes
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: base-files
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Changed in base-files (Ubuntu Precise):
importance: Undecided → Medium
tags: added: dist-upgrade lucid2precise qa-daily-testing rls-mgr-p-tracking
summary: - lucid->precise upgrade - prompt to upgrade unmodified conf files in /etc
+ lucid->precise upgrade - prompt to update unmodified conf files in /etc
/update-motd.d: 00-header, 10-help-text, 99-footer
description: updated
Changed in base-files (Ubuntu Precise):
assignee: nobody → Canonical Foundations Team (canonical-foundations)
Steve Langasek (vorlon) wrote :

please attach the modified conffiles.

Changed in base-files (Ubuntu Precise):
status: New → Incomplete
Steve Langasek (vorlon) wrote :

Note that this is probably a variation on bug #820233, but the checksums appear not to match the lucid version.

Jean-Baptiste Lallement (jibel) wrote :

Original configuration files without .dpkg-dist extension.
Same installation than bug 903131

See also bug 903143 for another variation with /etc/init/failsafe-x.conf

Changed in base-files (Ubuntu Precise):
status: Incomplete → Confirmed
Steve Langasek (vorlon) wrote :

And as for bug #903131, the checksums of these files exactly match the ones from the lucid package.

So something's seriously wrong here; either /var/lib/dpkg/status is corrupted, or dpkg itself is failing to detect checksum mismatches correctly on upgrade from lucid.

Martin Pitt (pitti) wrote :

I can reproduce this by booting the current lucid 10.04.3 live system, switching apt to precise, and doing

  sudo apt-get install base-files

Changed in base-files (Ubuntu Precise):
status: Confirmed → Triaged
Martin Pitt (pitti) wrote :

This is because in lucid, the files in /etc/update-motd.d/ are shipped by base-files, but are NOT marked as conffiles. They ARE conffiles in precise, but as their contents changed, you'll get a conffile prompt.

Rolf Leggewie (r0lf) wrote :

I see the same thing for a bunch of files on lucid2precise upgrade

cron for /etc/crontab
sudo for /etc/sudoers

upstart for /etc/init/upstart-udev-bridge.conf
procps for /etc/init/procps.conf
mountall for /etc/init/mountall.conf
hostname for /etc/init/hostname.conf

The latter had all been deleted on my system, not sure when or why that happened.

On Thu, Jan 05, 2012 at 11:04:07PM -0000, Rolf Leggewie wrote:
> I see the same thing for a bunch of files on lucid2precise upgrade

> cron for /etc/crontab
> sudo for /etc/sudoers

> upstart for /etc/init/upstart-udev-bridge.conf
> procps for /etc/init/procps.conf
> mountall for /etc/init/mountall.conf
> hostname for /etc/init/hostname.conf

> The latter had all been deleted on my system, not sure when or why that
> happened.

If you've deleted conffiles, that counts as a modification. It's not a bug
at all to be prompted in that case.

(I'm pretty sure /etc/init/mountall.conf didn't disappear on its own,
considering this is an essential part of the boot sequence in 10.04.)

On 06.01.2012 07:30, Steve Langasek wrote:
> If you've deleted conffiles, that counts as a modification.

Yes, of course. All I can say again right now is that I don't remember
deleting all those files. One possibility certainly is that they didn't
get restored properly from the backup.

FWIW, this is in a lucid vserver guest system that I had a LOT of
trouble with (actually, it never really ran ever since lucid was
released). The premature release of Upstart basically killed it. See
bug 701961 for the very unpleasant story.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package base-files - 6.5ubuntu4

---------------
base-files (6.5ubuntu4) precise; urgency=low

  * debian/preinst: the non-conffile contents of /etc/update-motd.d had
    different md5sums in lucid, so include upgrade handling for those
    versions as well so we avoid spurious conffile prompts. LP: #903137.
 -- Steve Langasek <email address hidden> Wed, 25 Jan 2012 15:47:04 -0800

Changed in base-files (Ubuntu Precise):
status: Triaged → Fix Released
Steve Langasek (vorlon) wrote :

according to the QA team's weekly release report, this bug is still an issue because 99-footer is still generating a prompt.

Changed in base-files (Ubuntu Precise):
assignee: Canonical Foundations Team (canonical-foundations) → Steve Langasek (vorlon)
status: Fix Released → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package base-files - 6.5ubuntu5

---------------
base-files (6.5ubuntu5) precise; urgency=low

  * debian/preinst: also handle 99-footer. Really closes LP: #903137.
 -- Steve Langasek <email address hidden> Fri, 27 Jan 2012 10:50:52 -0800

Changed in base-files (Ubuntu Precise):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers