conffile prompt during natty -> oneiric upgrade

Bug #820233 reported by Michael Vogt on 2011-08-03
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
base-files (Ubuntu)
High
Unassigned

Bug Description

During a natty -> oneiric upgrade I see the following conffile prompt:

Setting up base-files (6.4ubuntu3) ...
Installing new version of config file /etc/debian_version ...
Installing new version of config file /etc/issue ...
Installing new version of config file /etc/issue.net ...
Installing new version of config file /etc/lsb-release ...

Configuration file `/etc/update-motd.d/00-header'
 ==> File on system created by you or by a script.
 ==> File also in package provided by package maintainer.
   What would you like to do about it ? Your options are:
    Y or I : install the package maintainer's version
    N or O : keep your currently-installed version
      D : show the differences between the versions
      Z : start a shell to examine the situation
 The default action is to keep your current version.
*** 00-header (Y/I/N/O/D/Z) [default=N] ? d
--- /etc/update-motd.d/00-header 2010-10-21 13:12:20.000000000 +0000
+++ /etc/update-motd.d/00-header.dpkg-new 2011-07-14 22:13:56.000000000 +0
000
@@ -21,7 +21,7 @@

 [ -r /etc/lsb-release ] && . /etc/lsb-release

-if [ -z "$DISTRIB_DESCRIPTION" ]; then
+if [ -z "$DISTRIB_DESCRIPTION" ] && [ -x /usr/bin/lsb_release ]; then
  # Fall back to using the very slow lsb_release utility
  DISTRIB_DESCRIPTION=$(lsb_release -s -d)
 fi

onfiguration file `/etc/update-motd.d/10-help-text'
 ==> File on system created by you or by a script.
 ==> File also in package provided by package maintainer.
   What would you like to do about it ? Your options are:
    Y or I : install the package maintainer's version
    N or O : keep your currently-installed version
      D : show the differences between the versions
      Z : start a shell to examine the situation
 The default action is to keep your current version.
*** 10-help-text (Y/I/N/O/D/Z) [default=N] ? d
--- /etc/update-motd.d/10-help-text 2010-10-21 13:12:00.000000000 +0000
+++ /etc/update-motd.d/10-help-text.dpkg-new 2011-07-14 22:13:56.000000000 +0
000
@@ -3,7 +3,8 @@
 # 10-help-text - print the help text associated with the distro
 # Copyright (C) 2009-2010 Canonical Ltd.
 #
-# Authors: Dustin Kirkland <email address hidden>
+# Authors: Dustin Kirkland <email address hidden>,
+# Brian Murray <email address hidden>
 #
 # This program is free software; you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
@@ -19,9 +20,16 @@
 # with this program; if not, write to the Free Software Foundation, Inc.,
 # 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.

+[ -r /etc/lsb-release ] && . /etc/lsb-release
+
+if [ -z "$DISTRIB_RELEASE" ] && [ -x /usr/bin/lsb_release ]; then
+ # Fall back to using the very slow lsb_release utility
+ DISTRIB_RELEASE=$(lsb_release -sr)
+fi
+
 URL="https://help.ubuntu.com/"
 if uname -r | grep -qs "\-server"; then
- URL="http://www.ubuntu.com/server/doc"
+ URL="https://help.ubuntu.com/$DISTRIB_RELEASE/serverguide/C"
 fi

 printf "\n * Documentation: %s\n" "$URL"

Michael Vogt (mvo) on 2011-08-03
Changed in base-files (Ubuntu):
status: New → Confirmed
importance: Undecided → High
tags: added: iso-testing
Michael Vogt (mvo) wrote :

In a clean natty chroot:
# md5sum /etc/update-motd.d/00-header
4241925109d5d9fc869f20143dbd4054 /etc/update-motd.d/00-header
# md5sum /etc/update-motd.d/10-help-text
918a1e4bc361b759adff1fabbcd8fb8f /etc/update-motd.d/10-help-text
# dpkg -s base-files
Package: base-files
...
Conffiles:
 /etc/debian_version 82711d8dc3e89c428b4694a284e32541
 /etc/dpkg/origins/debian 731423fa8ba067262f8ef37882d1e742
 /etc/dpkg/origins/ubuntu ea35901c45553c3451f60476be94d2d8
 /etc/host.conf 89408008f2585c957c031716600d5a80
 /etc/issue 9865e55b7162c01dfc5ea525eb9ecee3
 /etc/issue.net 9a1459493a030337fe08477a1bc0d100
 /etc/lsb-release 7ce1ffb3689e93590b84d74fb3939302
Description: Debian base system miscellaneous files
...

So the old version did not have 00-header/10-help-text as conffiles, but the new version does:
# dpkg -s base-files (new version):
Package: base-files
Conffiles:
 /etc/debian_version 931870fda5e3f942afc004db670b3cae
 /etc/dpkg/origins/debian 731423fa8ba067262f8ef37882d1e742
 /etc/dpkg/origins/ubuntu ea35901c45553c3451f60476be94d2d8
 /etc/host.conf 89408008f2585c957c031716600d5a80
 /etc/issue 27efa0e2fe4f9b972d0b09cd75818f98
 /etc/issue.net 29f9e61bc86a4594020e6383ce9699ed
 /etc/lsb-release 362f07a83dc8ae4ae26a4b860b3ef651
 /etc/update-motd.d/00-header 4a1e6eed7a59f200b4267085721750a3
 /etc/update-motd.d/10-help-text 5064fb57493325202dded183ab0c4ebd
 /etc/update-motd.d/99-footer b0541f3c2e55c44149cd92bcc599c94c
Description: Debian base system miscellaneous files
...

But with different md5sums.

Michael Vogt (mvo) wrote :

But the old package owns /etc/update-motd.d/{00-header,10-help-text} too just not as conffiles so it appears a simple is to remove the file if it was unmodified in the preinst and let dpkg replace it with the real conffile.

Michael Vogt (mvo) wrote :

Looks like this is a side effect of the fix for:
https://bugs.launchpad.net/ubuntu/+source/base-files/+bug/813282

Michael Vogt (mvo) wrote :
Changed in base-files (Ubuntu):
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package base-files - 6.4ubuntu4

---------------
base-files (6.4ubuntu4) oneiric; urgency=low

  * debian/preinst:
    - fix conffile prompt for unmodified 00-header, 10-help-text
      (LP: #820233)
  * debian/rules:
    - install the preinst into the package as no helper is used
 -- Michael Vogt <email address hidden> Wed, 03 Aug 2011 10:44:29 +0200

Changed in base-files (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Patches