missing entry for autofs in /usr/share/base-files/nsswitch.conf and /etc/nsswitch.conf

Bug #488077 reported by Stefan Kluth on 2009-11-25
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
base-files (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: base-files

I installed autofs5 and couldn't get my automounts to work until I added an entry for autofs in /etc/nsswitch.conf as shown below:

skluth@lapkluth2:~$ cat /etc/nsswitch.conf
# /etc/nsswitch.conf
#
# Example configuration of GNU Name Service Switch functionality.
# If you have the `glibc-doc-reference' and `info' packages installed, try:
# `info libc "Name Service Switch"' for information about this file.

passwd: compat
group: compat
shadow: compat

hosts: files mdns4_minimal [NOTFOUND=return] dns mdns4
networks: files

protocols: db files
services: db files
ethers: db files
rpc: db files

netgroup: nis

automount: files

I use a local autofs configuration so "files" is ok for me. In general I guess there should be "files nis" or similar. Just autofs (version 4) worked fine without this additional line to nsswitch.conf.

skluth@lapkluth2:~$ lsb_release -rd
Description: Ubuntu 9.10
Release: 9.10

ProblemType: Bug
Architecture: i386
Date: Wed Nov 25 09:56:46 2009
DistroRelease: Ubuntu 9.10
NonfreeKernelModules: openafs
Package: base-files 5.0.0ubuntu7
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic-pae
SourcePackage: base-files
Uname: Linux 2.6.31-14-generic-pae i686

Stefan Kluth (skluth) wrote :
RobinMHolt (holt) wrote :

This appears to be a problem on 10.04 as well. Is anybody looking at this bug?

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in base-files (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers