Releases files does not contain "LTS" tag

Bug #225735 reported by Jonathan Marsaud on 2008-05-02
10
Affects Status Importance Assigned to Milestone
base-files (Ubuntu)
Low
Unassigned
Hardy
Undecided
Steve Langasek

Bug Description

In Ubuntu 6.06, on /etc/lsb-release /etc/issue and /etc/issue.net files contain "LTS" tag like :

[lsb-release]
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=6.06.2
DISTRIB_CODENAME=dapper
DISTRIB_DESCRIPTION="Ubuntu 6.06.2 LTS"

[issue]
Ubuntu 6.06.2 LTS \n \l

[issue.net]
Ubuntu 6.06.2 LTS

This files on Ubuntu 8.04 does not contain "LTS" tag :

[lsb-release]
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=8.04
DISTRIB_CODENAME=hardy
DISTRIB_DESCRIPTION="Ubuntu 8.04"

[issue]
Ubuntu 8.04 \n \l

[issue.net]
Ubuntu 8.04

In my opinion, we should tag on this version files that is about a LTS version of Ubuntu, not just for fun, but about marketing products. (For example : in phpSysinfo, it will be more "marketing" to have "Ubuntu 8.04 LTS" than "Ubuntu 8.04", the "LTS" tag can reassure business entreprise if they don't know about Ubuntu support and if they see it on other phpsysinfos, they can ask about "What is an LTS version like 8.04 ?").

An other example is about an user, who have installed Ubuntu for the first time. When he begin to « know » Ubuntu, he will see on System Monitor of GNOME that his version of Ubuntu is a LTS which have a support for three years. (A new user can't say "Oh, it's Ubuntu 8.04 apparently, so it's a LTS !).

Thanks you about taking your time to read this "aesthetics" bug.

Jonathan Marsaud (zic) on 2008-05-02
description: updated
Jonathan Marsaud (zic) on 2008-05-02
description: updated
Changed in base-files:
milestone: none → ubuntu-8.04.2
Steve Langasek (vorlon) on 2009-01-29
Changed in base-files:
assignee: nobody → vorlon
Martin Pitt (pitti) on 2009-06-19
Changed in base-files (Ubuntu):
milestone: ubuntu-8.04.2 → ubuntu-8.04.3
assignee: Steve Langasek (vorlon) → nobody
milestone: ubuntu-8.04.3 → none
status: Confirmed → Invalid
Martin Pitt (pitti) wrote :

Accepted base-files into hardy-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in base-files (Ubuntu Hardy):
assignee: nobody → Steve Langasek (vorlon)
milestone: none → ubuntu-8.04.3
status: New → Fix Committed
tags: added: verification-needed
Steve Beattie (sbeattie) wrote :

I've confirmed that the release files in base-files 4.0.1ubuntu5.8.04.4 do not contain LTS. However, while /etc/lsb-release in base-files 4.0.1ubuntu5.8.04.6 in hardy-proposed does contain the LTS string, the /etc/issue and /etc/issue.net files do not:

ubuntu@hh-amd64:~$ cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=8.04
DISTRIB_CODENAME=hardy
DISTRIB_DESCRIPTION="Ubuntu 8.04.3 LTS"
ubuntu@hh-amd64:~$ cat /etc/issue
Ubuntu 8.04.3 \n \l

ubuntu@hh-amd64:~$ cat /etc/issue.net
Ubuntu 8.04.3

I'm marking as verification-failed because I don't believe this is intended behavior. Please correct if this is not the case.

tags: added: verification-done
removed: verification-needed
tags: added: verification-failed
removed: verification-done
Martin Pitt (pitti) wrote :

I think the DISTRIB_RELEASE value is intended behaviour. As far as I know, the idea was to not break the "Release" field for programs/scripts which parse it.

It's consistent with what dapper has:

$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 6.06.2 LTS
Release: 6.06
Codename: dapper

The issue and issue.net should be fixed, though, indeed.

Changed in base-files (Ubuntu Hardy):
status: Fix Committed → In Progress
Steve Langasek (vorlon) wrote :

reuploaded with the change to issue* now.

tags: removed: verification-failed
Martin Pitt (pitti) wrote :

Accepted base-files into hardy-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in base-files (Ubuntu Hardy):
status: In Progress → Fix Committed
tags: added: verification-needed
Steve Beattie (sbeattie) wrote :

Thanks, Steve and Martin. I can confirm that base-files 4.0.1ubuntu5.8.04.7 in hardy-proposed adds the "LTS" string to the DISTRIB_DESCRIPTION and to /etc/issue{,.net} consistent with the manner that it was done in Dapper. Marking verification-done.

tags: added: verification-done
removed: verification-needed

Lo, Lamento Mucho pero nose este, ni ningun otro Idioma, solo Español, nada mas, Agradecido por tu Atenciom, Gracias

> Date: Mon, 29 Jun 2009 20:30:36 +0000
> From: <email address hidden>
> To: <email address hidden>
> Subject: [Bug 225735] Re: Releases files does not contain "LTS" tag
>
> Thanks, Steve and Martin. I can confirm that base-files
> 4.0.1ubuntu5.8.04.7 in hardy-proposed adds the "LTS" string to the
> DISTRIB_DESCRIPTION and to /etc/issue{,.net} consistent with the manner
> that it was done in Dapper. Marking verification-done.
>
> ** Tags added: verification-done
> ** Tags removed: verification-needed
>
> --
> Releases files does not contain "LTS" tag
> https://bugs.launchpad.net/bugs/225735
> You received this bug notification because you are subscribed to base-
> files in ubuntu.
>
> Status in “base-files” package in Ubuntu: Invalid
> Status in base-files in Ubuntu Hardy: Fix Committed
>
> Bug description:
> In Ubuntu 6.06, on /etc/lsb-release /etc/issue and /etc/issue.net files contain "LTS" tag like :
>
> [lsb-release]
> DISTRIB_ID=Ubuntu
> DISTRIB_RELEASE=6.06.2
> DISTRIB_CODENAME=dapper
> DISTRIB_DESCRIPTION="Ubuntu 6.06.2 LTS"
>
> [issue]
> Ubuntu 6.06.2 LTS \n \l
>
> [issue.net]
> Ubuntu 6.06.2 LTS
>
> This files on Ubuntu 8.04 does not contain "LTS" tag :
>
> [lsb-release]
> DISTRIB_ID=Ubuntu
> DISTRIB_RELEASE=8.04
> DISTRIB_CODENAME=hardy
> DISTRIB_DESCRIPTION="Ubuntu 8.04"
>
> [issue]
> Ubuntu 8.04 \n \l
>
> [issue.net]
> Ubuntu 8.04
>
> In my opinion, we should tag on this version files that is about a LTS version of Ubuntu, not just for fun, but about marketing products. (For example : in phpSysinfo, it will be more "marketing" to have "Ubuntu 8.04 LTS" than "Ubuntu 8.04", the "LTS" tag can reassure business entreprise if they don't know about Ubuntu support and if they see it on other phpsysinfos, they can ask about "What is an LTS version like 8.04 ?").
>
> An other example is about an user, who have installed Ubuntu for the first time. When he begin to « know » Ubuntu, he will see on System Monitor of GNOME that his version of Ubuntu is a LTS which have a support for three years. (A new user can't say "Oh, it's Ubuntu 8.04 apparently, so it's a LTS !).
>
> Thanks you about taking your time to read this "aesthetics" bug.

_________________________________________________________________
Descubre todas las formas en que puedes estar en contacto con amigos y familiares.
http://www.microsoft.com/windows/windowslive/default.aspx

Steve Langasek (vorlon) wrote :

On Mon, Jun 29, 2009 at 08:42:37PM -0000, juan Lopez-Amor Varela wrote:

> Lo, Lamento Mucho pero nose este, ni ningun otro Idioma, solo Español, nada mas, Agradecido por tu Atenciom, Gracias

Entonces le recomiendo no subscribirse a los mensajes de fallos de paquetes
en Ubuntu, que es lo que ha hecho, por lo visto en:

   https://launchpad.net/ubuntu/+source/base-files

--
Steve Langasek Give me a lever long enough and a Free OS
Debian Developer to set it on, and I can move the world.
Ubuntu Developer http://www.debian.org/
<email address hidden> <email address hidden>

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package base-files - 4.0.1ubuntu5.8.04.7

---------------
base-files (4.0.1ubuntu5.8.04.7) hardy-proposed; urgency=low

  * /etc/lsb-release: include "LTS" in the DISTRIB_DESCRIPTION field.
    LP: #225735.
  * Also add "LTS" to /etc/issue, /etc/issue.net.

 -- Steve Langasek <email address hidden> Fri, 26 Jun 2009 22:05:43 +0000

Changed in base-files (Ubuntu Hardy):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers