Split motd-news config into a new package

Bug #1888575 reported by Andreas Hasenack on 2020-07-22
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
base-files (Ubuntu)
Undecided
Andreas Hasenack
Xenial
Undecided
Andreas Hasenack
Bionic
Undecided
Andreas Hasenack
Focal
Undecided
Andreas Hasenack
Groovy
Undecided
Andreas Hasenack
livecd-rootfs (Ubuntu)
Undecided
Unassigned
Xenial
Undecided
Unassigned
Bionic
Undecided
Unassigned
Focal
Undecided
Unassigned
Groovy
Undecided
Unassigned
ubuntu-meta (Ubuntu)
Undecided
Andreas Hasenack
Xenial
Undecided
Andreas Hasenack
Bionic
Undecided
Andreas Hasenack
Focal
Undecided
Andreas Hasenack
Groovy
Undecided
Andreas Hasenack

Bug Description

[Impact]
The motd-news script is largely useless for desktop users, as they rarely login via a text console. It makes more sense for server users.

We can use package dependencies to have the motd-news script enabled on servers, but disabled on desktops, and still handle upgrades. This is the plan:
- move /etc/default/motd-news from base-files into a new binary package (motd-news-config, produced by src:base-files)
- have ubuntu-server depend on motd-news-config
- have base-files break current ubuntu-server, so that if base-files if upgraded and ubuntu-server is installed, ubuntu-server will also be upgraded to the new version which has the depends on motd-news-config

Care must be taken to preserve a changed /etc/default/motd-news when the upgrade installs the new motd-news-config package. For example, on a server that has set ENABLED=0 in /etc/default/motd-news and upgrades to the new base-files and ubuntu-server, and gets the new motd-config-news package, ENABLED=0 must remain set.

[Test Case]
a) base-files installed, ubuntu-server installed, unmodified /e/d/motd-news
apt install base-files
- upgrades ubuntu-server
- installs motd-news-config
- /e/d/motd-news remains, motd-news remains enabled

b) base-files installed, ubuntu-server installed, modified /e/d/motd-news
apt install base-files
- upgrades ubuntu-server
- installs motd-news-config
- /e/d/motd-news remains with the original modification

c) base-files installed, ubuntu-server not installed, unmodified /e/d/motd-news
apt install base-files
- upgrades base-files
- removes /e/d/motd-news
- motd-news is disabled

d) base-files installed, ubuntu-server not installed, modified /e/d/motd-news
apt install base-files
- upgrades base-files
- /e/d/motd-news gets renamed to backup
- motd-news is disabled

e) removing motd-news-config will also remove ubuntu-server (since it's a depends, and not a recommends)

f) upgrading just ubuntu-server should pull motd-news-config in, and force-upgrade base-files

g) Removing motd-news-server leaves /e/d/motd-news around; purging motd-news-server removes the /e/d/motd-news config file

h) base-files installed, ubuntu-server installed, removed /e/d/motd-news
- apt install base-files
- upgrades base-files, upgrades ubuntu-server, installs motd-news-config
- /e/d/motd-news is installed with ENABLED=0

i) base-files installed, ubuntu-server NOT installed, removed e/d/motd-news
- apt install base-files
- base-files is upgraded
- no /e/d/motd-news is installed, motd-news remains disabled

j) Perform a release upgrade from the previous ubuntu release to the one being tested while having ubuntu-server NOT installed (or use a desktop install). At the end, motd-news should be disabled. Verify with:

$ sudo /etc/update-motd.d/50-motd-news --force
$ (no output)

k) Test that supporting changes for xenial are in place:

  i) verify grub-legacy-ec2 is not in the xenial server seed
  ii) verify that the rootfs manifest built from the ubuntu-cpc project contains the ubuntu-server package
  iii) verify that images built from the ubuntu-cpc project which purge grub-legacy-ec2 have retained ubuntu-server
  iv) verify that the base ubuntu-cpc image continues to have grub-legacy-ec2 installed.

[Regression Potential]
This update is about config file ownership transfer: /e/d/motd-news belonged to base-files, now it belongs to motd-news-config. We tried to handle two important cases here:
a) /e/d/motd-news config was changed while it belonged to base-files. For example, an user could have set ENABLED=0. We need to transfer that change to the motd-news-config package when it is installed, otherwise this SRU would jsut re-enabled motd-news. This is handled in d/motd-news-config.postinst's configure case.

b) /e/d/motd-news config file was *removed* while it belonged to base-files. In such a case, a normal upgrade of the package (base-files in this example) would not reinstate the file. Much less this upgrade here, which has an explicit rm_conffile maintscript-helper for it. But the motd-news-config package that could be installed in the transaction would place the default config file back, and the default is ENABLED=1. Thus, a system that had motd-news disabled via removing the config file would now have it re-enabled after the upgrade.
This was trickier to handle, and we do it in base-files's postinst and motd-news-config's postinst. The drawback is that in one scenario, where just base-files is upgraded and /e/d/motd-news was manually removed by the user, there will be a /e/d/motd-news.wasremoved leftover empty file (see "other info" below for details).

In general, the regression risks here are:
- have motd-news enabled again on a system where it was previously disabled. We tried to envision two ways it would have been disabled (set ENABLED=0, and remove the config file). There are probably others
- differences in dpkg and/or debhelper behavior in older ubuntu releases leading to unexpected results (should be covered by the test cases from this SRU)
- xenial in particular is trickier, because src:base-files there does NOT use debhelper, so many of the things we take for granted have to be done by hand
- have some sort of dpkg postinst or dependency error because of unpredicted scenarios. Certain assumptions are being made, like the renames that dpkg-maintscript-helper does, and that the filename /etc/default/motd-news.wasremoved that I'm touching and verifying is really mine and not something that was there already.
- the versions I'm breaking/replacing on, and using rm_conffiles on, must be exact. These are the versions today in the archive (2020-08-12):

base-files:
x: 9.4ubuntu4.12
b: 10.1ubuntu2.9
f: 11ubuntu5.1
g: 11ubuntu12 (was 11ubuntu10)

ubuntu-meta:
x: 1.361.4
b: 1.417.4
f: 1.450.1
g: 1.452

Which reflect in these relationships in the updated packages:
Groovy:
ubuntu-server 1.453:
  Depends: motd-news-config
base-files 11ubuntu11:
  Breaks: ubuntu-server (<< 1.453)
  rm_conffile /etc/default/motd-news 11ubuntu11~ base-files
motd-news-config 11ubuntu11:
  Breaks/Replaces: base-files (<< 11ubuntu11)

Focal:
ubuntu-server 1.450.2:
  Depends: motd-news-config
base-files 11ubuntu5.2:
  Breaks: ubuntu-server (<< 1.450.2)
  rm_conffile /etc/default/motd-news 11ubuntu5.2~ base-files
motd-news-config 11ubuntu5.2:
  Breaks/Replaces: base-files (<< 11ubuntu5.2)

Bionic:
ubuntu-server 1.417.5:
  Depends: motd-news-config
base-files 10.1ubuntu2.10:
  Breaks: ubuntu-server (<< 1.417.5)
  rm_conffile /etc/default/motd-news 10.1ubuntu2.10~ base-files
motd-news-config 10.1ubuntu2.10:
  Breaks/Replaces: base-files (<< 10.1ubuntu2.10)

Xenial:
ubuntu-server 1.361.5:
  Depends: motd-news-config
base-files 9.4ubuntu4.13:
  Breaks: ubuntu-server (<< 1.361.5)
  rm_conffile /etc/default/motd-news 9.4ubuntu4.13~ base-files
motd-news-config 9.4ubuntu4.13:
  Breaks/Replaces: base-files (<< 9.4ubuntu4.13)

[Other Info]
a) Testcase (i) will leave around an empty /etc/default/motd-news.wasremoved file, created by the base-files postinst. This file is removed by the motd-news-config postinst, but since that package doesn't get installed in that particular scenario, the file remains. I toyed with the idea of adding an extra check to base-file's postinst, like this:
--- a/debian/postinst.in
+++ b/debian/postinst.in
@@ -133,7 +133,11 @@ motd_news_config="/etc/default/motd-news"
 if [ ! -e ${motd_news_config} ]; then
   if [ ! -e ${motd_news_config}.dpkg-remove ]; then
     if [ ! -e ${motd_news_config}.dpkg-backup ]; then
- touch ${motd_news_config}.wasremoved
+ # The .wasremoved file only matters if ubuntu-server is installed,
+ # because that's what will pull in motd-news-config
+ if dpkg -l ubuntu-server 2>/dev/null | grep -q ^i; then
+ touch ${motd_news_config}.wasremoved
+ fi
     fi
   fi
 fi

But deemed it too risky, and not worth further potential regressions. It seemed to work, though, at least for groovy.

b) Currently the xenial cloud images, with the exception of the AWS one, do not have ubuntu-server installed. This means that this SRU will disable motd-news on them, unless ubuntu-server was manually installed for some reason. This includes LXD xenial images as well.

c) The new motd-news-config package has its d/control priority set to "optional", so a release upgrade won't pick it up (presumably the same applies to the installer). I've been told there are archive overrides that might need updating as well: dear SRU team member, please check, or ask an archive admin to check.

Related branches

Changed in base-files (Ubuntu Xenial):
assignee: nobody → Andreas Hasenack (ahasenack)
Changed in base-files (Ubuntu Bionic):
assignee: nobody → Andreas Hasenack (ahasenack)
Changed in base-files (Ubuntu Focal):
assignee: nobody → Andreas Hasenack (ahasenack)
Changed in ubuntu-meta (Ubuntu Xenial):
assignee: nobody → Andreas Hasenack (ahasenack)
Changed in ubuntu-meta (Ubuntu Bionic):
assignee: nobody → Andreas Hasenack (ahasenack)
Changed in ubuntu-meta (Ubuntu Focal):
assignee: nobody → Andreas Hasenack (ahasenack)
Changed in ubuntu-meta (Ubuntu Groovy):
assignee: nobody → Andreas Hasenack (ahasenack)
Changed in base-files (Ubuntu Xenial):
status: New → In Progress
Changed in base-files (Ubuntu Bionic):
status: New → In Progress
Changed in base-files (Ubuntu Focal):
status: New → In Progress
Changed in ubuntu-meta (Ubuntu Xenial):
status: New → In Progress
Changed in ubuntu-meta (Ubuntu Bionic):
status: New → In Progress
Changed in ubuntu-meta (Ubuntu Focal):
status: New → In Progress
Changed in ubuntu-meta (Ubuntu Groovy):
status: New → In Progress
description: updated
description: updated
description: updated
description: updated
description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package base-files - 11ubuntu11

---------------
base-files (11ubuntu11) groovy; urgency=medium

  * Move the /etc/default/motd-news conffile to the motd-news-config
    package (LP: #1888575):
    - d/base-files.maintscript: remove /etc/default/motd-news config file
      on upgrade
    - d/control: break on ubuntu-server << 1.453 to force an upgrade if
      it is installed, which will pull motd-news-config and the conffile
      back in
    - d/motd-news-config.postinst:
      + handle the upgrade case where the motd-news config file was
        changed while it belonged to base-files
      + disable motd-news if the config file was removed by hand before
        the upgrade
    - d/postinst.in: signal the motd-news-config package if the
      motd-news config file was removed manually before the upgrade
    - d/control: new motd-news-config package, carrying the
      configuration file for the /etc/update-motd.d/50-motd-news script.
    - d/rules, d/motd-news-config.install: /e/d/motd-news is in the
      motd-news-config package now

 -- Andreas Hasenack <email address hidden> Mon, 10 Aug 2020 21:02:37 +0000

Changed in base-files (Ubuntu Groovy):
status: In Progress → Fix Released
description: updated
description: updated
description: updated

Hello Andreas, or anyone else affected,

Accepted base-files into focal-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/base-files/11ubuntu5.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-focal to verification-done-focal. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-focal. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in base-files (Ubuntu Focal):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-focal
Changed in base-files (Ubuntu Bionic):
status: In Progress → Fix Committed
tags: added: verification-needed-bionic
Timo Aaltonen (tjaalton) wrote :

Hello Andreas, or anyone else affected,

Accepted base-files into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/base-files/10.1ubuntu2.10 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in base-files (Ubuntu Xenial):
status: In Progress → Fix Committed
tags: added: verification-needed-xenial
Timo Aaltonen (tjaalton) wrote :

Hello Andreas, or anyone else affected,

Accepted base-files into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/base-files/9.4ubuntu4.13 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Andreas Hasenack (ahasenack) wrote :

There are two things missing for this to be testable:
a) the motd-news-config NEW package needs to be accepted
b) it needs to be moved into main
c) ubuntu-meta needs to be accepted as well (my mistake there, I missed the bug number in d/changelog in the xenial and bionic uploads)

Steve Langasek (vorlon) wrote :

Hello Andreas, or anyone else affected,

Accepted ubuntu-meta into focal-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/ubuntu-meta/1.450.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-focal to verification-done-focal. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-focal. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in ubuntu-meta (Ubuntu Focal):
status: In Progress → Fix Committed
Steve Langasek (vorlon) wrote :

Hello Andreas, or anyone else affected,

Accepted ubuntu-meta into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/ubuntu-meta/1.417.5 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in ubuntu-meta (Ubuntu Bionic):
status: In Progress → Fix Committed
Changed in ubuntu-meta (Ubuntu Xenial):
status: In Progress → Fix Committed
Steve Langasek (vorlon) wrote :

Hello Andreas, or anyone else affected,

Accepted ubuntu-meta into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/ubuntu-meta/1.361.5 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Andreas Hasenack (ahasenack) wrote :
Download full text (14.6 KiB)

Focal verification

This verification is quite long, given the amount of tests involved.

TL;DR All tests from (a) to (j) passed as required.

focal verification succeeded.

Details below.

a) base-files installed, ubuntu-server installed, unmodified /e/d/motd-news
apt install base-files
- upgrades ubuntu-server
- installs motd-news-config
- /e/d/motd-news remains, motd-news remains enabled

Starting with:
ii base-files 11ubuntu5.1 amd64 Debian base system miscellaneous files
ii ubuntu-server 1.450.1 amd64 The Ubuntu Server system

With proposed enabled, an apt install base-files pulls in motd-news-config and upgrades ubuntu-server:
$ sudo apt install base-files
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following additional packages will be installed:
  motd-news-config ubuntu-server
The following NEW packages will be installed:
  motd-news-config
The following packages will be upgraded:
  base-files ubuntu-server
(...)

And motd-news remains enabled:
ubuntu@focal-motd-news-split:~$ sudo /etc/update-motd.d/50-motd-news --force

 * Are you ready for Kubernetes 1.19? It's nearly here! Try RC3 with
   sudo snap install microk8s --channel=1.19/candidate --classic

   https://microk8s.io/ has docs and details.

ubuntu@focal-motd-news-split:~$ apt-cache policy base-files ubuntu-server motd-news-config
base-files:
  Installed: 11ubuntu5.2
  Candidate: 11ubuntu5.2
  Version table:
 *** 11ubuntu5.2 500
        500 http://br.archive.ubuntu.com/ubuntu focal-proposed/main amd64 Packages
(...)
ubuntu-server:
  Installed: 1.450.2
  Candidate: 1.450.2
  Version table:
 *** 1.450.2 500
        500 http://br.archive.ubuntu.com/ubuntu focal-proposed/main amd64 Packages
        100 /var/lib/dpkg/status
(...)
motd-news-config:
  Installed: 11ubuntu5.2
  Candidate: 11ubuntu5.2
  Version table:
 *** 11ubuntu5.2 500
        500 http://br.archive.ubuntu.com/ubuntu focal-proposed/main amd64 Packages

b) base-files installed, ubuntu-server installed, modified /e/d/motd-news
apt install base-files
- upgrades ubuntu-server
- installs motd-news-config
- /e/d/motd-news remains with the original modification

First, change /e/d/motd-news to disable the service:
ubuntu@focal-motd-news-split:~$ sudo sed -i 's,^ENABLED=.*,ENABLED=0,' /etc/default/motd-news
ubuntu@focal-motd-news-split:~$ sudo /etc/update-motd.d/50-motd-news --force
ubuntu@focal-motd-news-split:~$

Confirm installed packages:
ubuntu@focal-motd-news-split:~$ dpkg -l base-files ubuntu-server motd-news-config | grep ^i
dpkg-query: no packages found matching motd-news-config
ii base-files 11ubuntu5.1 amd64 Debian base system miscellaneous files
ii ubuntu-server 1.450.1 amd64 The Ubuntu Server system

Install base-files, which upgrades ubuntu-server, base-files, and installs the new motd-news-config package:
ubuntu@focal-motd-news-split:~$ sudo apt install base-files
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following additional packages will be installed:
  motd-news-config ubuntu-server
The following NEW packages will be installed:
  motd-new...

tags: added: verification-done-focal
removed: verification-needed-focal
Andreas Hasenack (ahasenack) wrote :

This is fixed in groovy already.

Changed in ubuntu-meta (Ubuntu Groovy):
status: In Progress → Fix Released
Andreas Hasenack (ahasenack) wrote :
Download full text (16.2 KiB)

Bionic verification

This verification is quite long, given the amount of tests involved.

TL;DR All tests from (a) to (j) passed as required.

bionic verification succeeded.

Latest updates from bionic:
base-files:
 *** 10.1ubuntu2.9 500
        500 http://br.archive.ubuntu.com/ubuntu bionic-updates/main amd64 Packages
and
ubuntu-server:
 *** 1.417.4 500
        500 http://br.archive.ubuntu.com/ubuntu bionic-updates/main amd64 Packages

a) base-files installed, ubuntu-server installed, unmodified /e/d/motd-news
apt install base-files
- upgrades ubuntu-server
- installs motd-news-config
- /e/d/motd-news remains, motd-news remains enabled

Starting point:
ubuntu@bionic-motd-news-split:~$ dpkg -l base-files ubuntu-server motd-news-config | grep ^ii
dpkg-query: no packages found matching motd-news-config
ii base-files 10.1ubuntu2.9 amd64 Debian base system miscellaneous files
ii ubuntu-server 1.417.4 amd64 The Ubuntu Server system

Unmodified config:
$ dpkg -s base-files | grep /etc/default/motd-news; echo -n ' '; md5sum /etc/default/motd-news | awk '{print $2,$1}'
 /etc/default/motd-news c08a329a603b640095da5ffe4e73491c
 /etc/default/motd-news c08a329a603b640095da5ffe4e73491c

Installing base-files pulls in motd-news-config and upgrades base-files and ubuntu-server:
ubuntu@bionic-motd-news-split:~$ sudo apt install base-files
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following additional packages will be installed:
  motd-news-config ubuntu-server
Recommended packages:
  grub-legacy-ec2
The following NEW packages will be installed:
  motd-news-config
The following packages will be upgraded:
  base-files ubuntu-server
2 upgraded, 1 newly installed, 0 to remove and 14 not upgraded

motd-news remains enabled:
ubuntu@bionic-motd-news-split:~$ sudo /etc/update-motd.d/50-motd-news --force

 * Are you ready for Kubernetes 1.19? It's nearly here! Try RC3 with
   sudo snap install microk8s --channel=1.19/candidate --classic

   https://microk8s.io/ has docs and details.

config is now part of motd-news-config package:
ubuntu@bionic-motd-news-split:~$ dpkg -s motd-news-config | grep /etc/default/motd-news; echo -n ' '; md5sum /etc/default/motd-news | awk '{print $2,$1}'
 /etc/default/motd-news c08a329a603b640095da5ffe4e73491c
 /etc/default/motd-news c08a329a603b640095da5ffe4e73491c

b) base-files installed, ubuntu-server installed, modified /e/d/motd-news
apt install base-files
- upgrades ubuntu-server
- installs motd-news-config
- /e/d/motd-news remains with the original modification

Starting point:
ubuntu@bionic-motd-news-split:~$ dpkg -l base-files ubuntu-server motd-news-config | grep ^ii
dpkg-query: no packages found matching motd-news-config
ii base-files 10.1ubuntu2.9 amd64 Debian base system miscellaneous files
ii ubuntu-server 1.417.4 amd64 The Ubuntu Server system

Modified config:
ubuntu@bionic-motd-news-split:~$ sudo sed -i "s,^ENABLED=.*,ENABLED=0," /etc/default/motd-news
ubuntu@bionic-motd-news-split:~$ dpkg -s base-files | grep /etc/default/motd-news; echo -n ' '; md5sum /etc/default/motd-news | awk '{print $2,$1}'
 /etc/defa...

Andreas Hasenack (ahasenack) wrote :
Download full text (3.2 KiB)

For the focal verification, I added a secondary test (j2) like I did for bionic, and that is a release upgrade from an updated focal non-server system to groovy, using the base-files package from focal-proposed, thus simulating the release upgrade once this SRU is complete.

Result is correct as well. Details below.

j2) do-release-upgrade from focal to groovy with the focal-proposed base-files package installed, no ubuntu-server installed, and thus motd-news-config disabled:
Starting point:
ubuntu@focal-motd-news-split:~$ dpkg -l base-files ubuntu-server motd-news-config | grep ^ii
dpkg-query: no packages found matching motd-news-config
ii base-files 11ubuntu5.2 amd64 Debian base system miscellaneous files
ubuntu@focal-motd-news-split:~$ sudo /etc/update-motd.d/50-motd-news --force
ubuntu@focal-motd-news-split:~$ echo $?
0
ubuntu@focal-motd-news-split:~$ apt-cache policy base-files
base-files:
  Installed: 11ubuntu5.2
  Candidate: 11ubuntu5.2
  Version table:
 *** 11ubuntu5.2 500
        500 http://br.archive.ubuntu.com/ubuntu focal-proposed/main amd64 Packages
(...)

Just before running do-release-upgrade, I removed focal-proposed from sources.list, to avoid upgrading other packages, not related to this test.

Final state:
ubuntu@focal-motd-news-split:~$ dpkg -l base-files ubuntu-server motd-news-config | grep ^ii
dpkg-query: no packages found matching motd-news-config
ii base-files 11ubuntu12 amd64 Debian base system miscellaneous files
ubuntu@focal-motd-news-split:~$ apt-cache policy base-files
base-files:
  Installed: 11ubuntu12
  Candidate: 11ubuntu12
  Version table:
 *** 11ubuntu12 500
        500 http://br.archive.ubuntu.com/ubuntu groovy/main amd64 Packages

motd-new disabled as expected:
ubuntu@focal-motd-news-split:~$ sudo /etc/update-motd.d/50-motd-news --force
ubuntu@focal-motd-news-split:~$...

Read more...

Andreas Hasenack (ahasenack) wrote :
Download full text (18.8 KiB)

Xenial verification

Versions we are handling:
base-files 9.4ubuntu4.12 -> 9.4ubuntu4.13
ubuntu-server 1.361.4 -> 1.361.5
motd-news-config n/a -> 9.4ubuntu4.13

Note that in xenial, at the moment, ubuntu-server is not pre-installed in the images.

This verification is quite long, given the amount of tests involved.

TL;DR All tests from (a) to (j) passed as required.

xenial verification succeeded.

a) base-files installed, ubuntu-server installed, unmodified /e/d/motd-news
apt install base-files
- upgrades ubuntu-server
- installs motd-news-config
- /e/d/motd-news remains, motd-news remains enabled

starting point:
ubuntu@xenial-motd-news-split:~$ dpkg -l base-files ubuntu-server motd-news-config | grep ^ii
dpkg-query: no packages found matching motd-news-config
ii base-files 9.4ubuntu4.12 amd64 Debian base system miscellaneous files
ii ubuntu-server 1.361.4 amd64 The Ubuntu Server system

unmodified config:
ubuntu@xenial-motd-news-split:~$ dpkg -s base-files | grep /etc/default/motd-news; echo -n ' '; md5sum /etc/default/motd-news | awk '{print $2,$1}'
 /etc/default/motd-news c08a329a603b640095da5ffe4e73491c
 /etc/default/motd-news c08a329a603b640095da5ffe4e73491c

motd-news enabled:
ubuntu@xenial-motd-news-split:~$ sudo /etc/update-motd.d/50-motd-news --force

 * Are you ready for Kubernetes 1.19? It's nearly here! Try RC3 with
   sudo snap install microk8s --channel=1.19/candidate --classic

   https://microk8s.io/ has docs and details.
ubuntu@xenial-motd-news-split:~$ echo $?
0

apt install base-files result:
The following NEW packages will be installed:
  motd-news-config
The following packages will be upgraded:
  base-files ubuntu-server
2 upgraded, 1 newly installed, 0 to remove and 9 not upgraded.

new state:
ubuntu@xenial-motd-news-split:~$ dpkg -l base-files ubuntu-server motd-news-config | grep ^ii
ii base-files 9.4ubuntu4.13 amd64 Debian base system miscellaneous files
ii motd-news-config 9.4ubuntu4.13 all Configuration for motd-news shipped in base-files
ii ubuntu-server 1.361.5 amd64 The Ubuntu Server system

motd-news remains enabled:
ubuntu@xenial-motd-news-split:~$ sudo /etc/update-motd.d/50-motd-news --force;echo $?

 * Are you ready for Kubernetes 1.19? It's nearly here! Try RC3 with
   sudo snap install microk8s --channel=1.19/candidate --classic

   https://microk8s.io/ has docs and details.
0

b) base-files installed, ubuntu-server installed, modified /e/d/motd-news
apt install base-files
- upgrades ubuntu-server
- installs motd-news-config
- /e/d/motd-news remains with the original modification

Starting point:
ubuntu@xenial-motd-news-split:~$ dpkg -l base-files ubuntu-server motd-news-config | grep ^ii
dpkg-query: no packages found matching motd-news-config
ii base-files 9.4ubuntu4.12 amd64 Debian base system miscellaneous files
ii ubuntu-server 1.361.4 amd64 The Ubuntu Server system

Modified config file, to disable motd-news:
ubuntu@xenial-motd-news-split:~$ sudo sed -i 's,^ENABLED=.*,ENABLED=0,' /etc/default/motd-news
ubuntu@xenial-motd-news-split:~$ dpkg -s base-files | grep /etc/default/motd-news; echo -n ' '...

tags: added: verification-done-bionic verification-done-xenial
removed: verification-needed-bionic verification-needed-xenial
Mathew Hodson (mhodson) on 2020-08-31
tags: removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package base-files - 9.4ubuntu4.13

---------------
base-files (9.4ubuntu4.13) xenial; urgency=medium

  [ Andreas Hasenack ]
  * motd/50-motd-news: don't include uptime in the user-agent string
    (LP: #1886572)
  * Move the /etc/default/motd-news conffile to the motd-news-config
    package (LP: #1888575):
    - d/postinst.in, d/postrm, d/preinst: remove /etc/default/motd-news
      config file on base-files upgrade using dpkg-maintscript-helper
    - d/rules: install d/preinst
    - d/control: break on ubuntu-server << 1.361.5 to force an upgrade if
      it is installed, which will pull motd-news-config and the conffile
      back in
    - d/control: new motd-news-config package, carrying the
      configuration file for the /etc/update-motd.d/50-motd-news script.
    - d/motd-news-config.postinst:
      + handle the upgrade case where the motd-news config file was
        changed while it belonged to base-files
      + disable motd-news if the config file was removed by hand before
        the upgrade
    - d/postinst.in: signal the motd-news-config package if the
      motd-news config file was removed manually before the upgrade
    - d/conffiles: remove motd-news
    - d/rules, d/motd-news-config.conffiles: packaging motd-news-config
      without debhelper

  [ Steve Langasek ]
  * motd/50-motd-news: use wget instead of curl, since wget is standard but
    curl is optional (LP: #1888572):
    - This changes the timeout behavior slightly because wget does not have
      an exact equivalent to curl's --max-time argument, we are using
      --timeout instead.

 -- Andreas Hasenack <email address hidden> Mon, 17 Aug 2020 11:19:19 -0300

Changed in base-files (Ubuntu Xenial):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-meta - 1.361.5

---------------
ubuntu-meta (1.361.5) xenial; urgency=medium

  * d/control: ubuntu-server depends on motd-news-config
    (LP: #1888575)

 -- Andreas Hasenack <email address hidden> Thu, 13 Aug 2020 17:41:56 -0300

Changed in ubuntu-meta (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for base-files has completed successfully and the package is now being released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package base-files - 10.1ubuntu2.10

---------------
base-files (10.1ubuntu2.10) bionic; urgency=medium

  [ Andreas Hasenack ]
  * motd/50-motd-news: don't include uptime in the user-agent string
    (LP: #1886572)
  * Move the /etc/default/motd-news conffile to the motd-news-config
    package (LP: #1888575):
    - d/base-files.maintscript: remove /etc/default/motd-news config file
      on upgrade
    - d/control: break on ubuntu-server << 1.417.5 to force an upgrade if
      it is installed, which will pull motd-news-config and the conffile
      back in
    - d/motd-news-config.postinst:
      + handle the upgrade case where the motd-news config file was
        changed while it belonged to base-files
      + disable motd-news if the config file was removed by hand before
        the upgrade
    - d/postinst.in: signal the motd-news-config package if the
      motd-news config file was removed manually before the upgrade
    - d/control: new motd-news-config package, carrying the
      configuration file for the /etc/update-motd.d/50-motd-news script.
    - d/rules, d/motd-news-config.install: /e/d/motd-news is in the
      motd-news-config package now

  [ Steve Langasek ]
  * motd/50-motd-news: use wget instead of curl, since wget is standard but
    curl is optional (LP: #1888572):
    - This changes the timeout behavior slightly because wget does not have
      an exact equivalent to curl's --max-time argument, we are using
      --timeout instead.

 -- Andreas Hasenack <email address hidden> Thu, 13 Aug 2020 15:59:47 -0300

Changed in base-files (Ubuntu Bionic):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-meta - 1.417.5

---------------
ubuntu-meta (1.417.5) bionic; urgency=medium

  * d/control: ubuntu-server depends on motd-news-config
    (LP: #1888575)

 -- Andreas Hasenack <email address hidden> Fri, 07 Aug 2020 19:11:57 +0000

Changed in ubuntu-meta (Ubuntu Bionic):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package base-files - 11ubuntu5.2

---------------
base-files (11ubuntu5.2) focal; urgency=medium

  [ Andreas Hasenack ]
  * motd/50-motd-news: don't include uptime in the user-agent string
    (LP: #1886572)
  * Move the /etc/default/motd-news conffile to the motd-news-config
    package (LP: #1888575):
    - d/base-files.maintscript: remove /etc/default/motd-news config file
      on upgrade
    - d/control: break on ubuntu-server << 1.450.2 to force an upgrade if
      it is installed, which will pull motd-news-config and the conffile
      back in
    - d/motd-news-config.postinst:
      + handle the upgrade case where the motd-news config file was
        changed while it belonged to base-files
      + disable motd-news if the config file was removed by hand before
        the upgrade
    - d/postinst.in: signal the motd-news-config package if the
      motd-news config file was removed manually before the upgrade
    - d/control: new motd-news-config package, carrying the
      configuration file for the /etc/update-motd.d/50-motd-news script.
    - d/rules, d/motd-news-config.install: /e/d/motd-news is in the
      motd-news-config package now

  [ Steve Langasek ]
  * motd/50-motd-news: use wget instead of curl, since wget is standard but
    curl is optional (LP: #1888572):
    - This changes the timeout behavior slightly because wget does not have
      an exact equivalent to curl's --max-time argument, we are using
      --timeout instead.

 -- Andreas Hasenack <email address hidden> Mon, 17 Aug 2020 10:31:58 -0300

Changed in base-files (Ubuntu Focal):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-meta - 1.450.2

---------------
ubuntu-meta (1.450.2) focal; urgency=medium

  * d/control: have ubuntu-server depend on motd-news-config
    (LP: #1888575)

 -- Andreas Hasenack <email address hidden> Thu, 06 Aug 2020 14:36:39 -0300

Changed in ubuntu-meta (Ubuntu Focal):
status: Fix Committed → Fix Released
Michael Vogt (mvo) wrote :

Just a quick observation about this update.

If you have a minimal environment without the motd-news-config, e.g. a debootstrap chroot or the ubuntu core snap then there is now a new:

/etc/default/motd-news.wasremoved

after the first upgrade of base-files. The relevant base-files.postinst script has a comment like:
```
# special case of having /etc/default/motd-news removed by hand
...
```
which is slightly misleading because the file was not removed, it was never there :)

Anyway, not a big deal, just something I noticed while looking at the core snap changes.

Andreas Hasenack (ahasenack) wrote :

Hmm, the impact of having that file there in this situation is that if you *then* install the motd-news-config package, it will see that file, remove it, and install /etc/default/motd-news with ENABLED=0 instead of ENABLED=1.

Can you easily remove /etc/default/motd-news.wasremoved manually in your scripts for now for this situation?

Andreas Hasenack (ahasenack) wrote :

I filed https://bugs.launchpad.net/ubuntu/+source/base-files/+bug/1895302 for that. Do you happen to know a good way to test the first-time installation of base-files with debootstrap? It would be awesome if I could give it a ppa to consider, in addition to the archive, and it would then just pick my test base-files instead of the one from the archive.

Steve Langasek (vorlon) on 2020-09-16
Changed in livecd-rootfs (Ubuntu Xenial):
status: New → Invalid
Changed in livecd-rootfs (Ubuntu Bionic):
status: New → Invalid
Changed in livecd-rootfs (Ubuntu Xenial):
status: Invalid → Triaged
Changed in livecd-rootfs (Ubuntu Focal):
status: New → Invalid
Changed in livecd-rootfs (Ubuntu Groovy):
status: New → Invalid
description: updated

Hello Andreas, or anyone else affected,

Accepted ubuntu-meta into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/ubuntu-meta/1.361.6 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in ubuntu-meta (Ubuntu Xenial):
status: Fix Released → Fix Committed
tags: added: verification-needed verification-needed-xenial
removed: verification-done-xenial
Łukasz Zemczak (sil2100) wrote :

Accepted the hopefully final ubuntu-meta change for xenial, finally removing grub-legacy-ec2 from ubuntu-server. This requires re-running the k) test-case, among other things.

Andreas Hasenack (ahasenack) wrote :

I have another upload for base-files, for bug #1895302 (see comment #23). I can re-run the (k) test case, and of course the testcase for that bug specifically.

Andreas Hasenack (ahasenack) wrote :

Sorry, I wasn't clear. I'll re-run (k) with ubuntu-meta from xenial proposed now, with base-files from xenial-updates.

Andreas Hasenack (ahasenack) wrote :

Sorry again, I jumped he gun. I don't know how to do k-ii and k-iii, I thought (k) was one of the original test cases.

Andreas Hasenack (ahasenack) wrote :

root@xenial-base-files:~# apt-cache policy ubuntu-server
ubuntu-server:
  Installed: 1.361.6
  Candidate: 1.361.6
  Version table:
 *** 1.361.6 500
        500 http://br.archive.ubuntu.com/ubuntu xenial-proposed/main amd64 Packages
        100 /var/lib/dpkg/status
     1.361.5 500
        500 http://br.archive.ubuntu.com/ubuntu xenial-updates/main amd64 Packages
     1.361 500
        500 http://br.archive.ubuntu.com/ubuntu xenial/main amd64 Packages

ubuntu-server 1.361.5, currently in xenial-updates, has grub-legacy-ec2 in the Depends line:

root@xenial-base-files:~# apt-cache show ubuntu-server=1.361.5|grep ec2
Depends: acpid, apport, at, bcache-tools, btrfs-tools, byobu, cloud-guest-utils, cloud-initramfs-copymods, cloud-initramfs-dyn-netconf, curl, ethtool, fonts-ubuntu-font-family-console, git, grub-legacy-ec2, ifenslave, lvm2, mdadm, open-iscsi, open-vm-tools, overlayroot, patch, screen, software-properties-common, sosreport, tmux, ubuntu-cloudimage-keyring, update-notifier-common, vim, vlan, xfsprogs, motd-news-config

But ubuntu-server 1.361.6 from proposed does not, as expected:
root@xenial-base-files:~# apt-cache show ubuntu-server=1.361.6|grep ec2
root@xenial-base-files:~#

Oliver Grawert (ogra) wrote :

please note that the stable UbuntuCore18 images regressed due to this:

https://github.com/snapcore/core18/issues/170

Download full text (13.5 KiB)

See https://bugs.launchpad.net/bugs/1895302

On Tue, Sep 22, 2020, 07:41 Oliver Grawert <email address hidden>
wrote:

> please note that the stable UbuntuCore18 images regressed due to this:
>
> https://github.com/snapcore/core18/issues/170
>
> ** Bug watch added: github.com/snapcore/core18/issues #170
> https://github.com/snapcore/core18/issues/170
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1888575
>
> Title:
> Split motd-news config into a new package
>
> Status in base-files package in Ubuntu:
> Fix Released
> Status in livecd-rootfs package in Ubuntu:
> Invalid
> Status in ubuntu-meta package in Ubuntu:
> Fix Released
> Status in base-files source package in Xenial:
> Fix Released
> Status in livecd-rootfs source package in Xenial:
> Triaged
> Status in ubuntu-meta source package in Xenial:
> Fix Committed
> Status in base-files source package in Bionic:
> Fix Released
> Status in livecd-rootfs source package in Bionic:
> Invalid
> Status in ubuntu-meta source package in Bionic:
> Fix Released
> Status in base-files source package in Focal:
> Fix Released
> Status in livecd-rootfs source package in Focal:
> Invalid
> Status in ubuntu-meta source package in Focal:
> Fix Released
> Status in base-files source package in Groovy:
> Fix Released
> Status in livecd-rootfs source package in Groovy:
> Invalid
> Status in ubuntu-meta source package in Groovy:
> Fix Released
>
> Bug description:
> [Impact]
> The motd-news script is largely useless for desktop users, as they
> rarely login via a text console. It makes more sense for server users.
>
> We can use package dependencies to have the motd-news script enabled on
> servers, but disabled on desktops, and still handle upgrades. This is the
> plan:
> - move /etc/default/motd-news from base-files into a new binary package
> (motd-news-config, produced by src:base-files)
> - have ubuntu-server depend on motd-news-config
> - have base-files break current ubuntu-server, so that if base-files if
> upgraded and ubuntu-server is installed, ubuntu-server will also be
> upgraded to the new version which has the depends on motd-news-config
>
> Care must be taken to preserve a changed /etc/default/motd-news when
> the upgrade installs the new motd-news-config package. For example, on
> a server that has set ENABLED=0 in /etc/default/motd-news and upgrades
> to the new base-files and ubuntu-server, and gets the new motd-config-
> news package, ENABLED=0 must remain set.
>
> [Test Case]
> a) base-files installed, ubuntu-server installed, unmodified
> /e/d/motd-news
> apt install base-files
> - upgrades ubuntu-server
> - installs motd-news-config
> - /e/d/motd-news remains, motd-news remains enabled
>
> b) base-files installed, ubuntu-server installed, modified /e/d/motd-news
> apt install base-files
> - upgrades ubuntu-server
> - installs motd-news-config
> - /e/d/motd-news remains with the original modification
>
> c) base-files installed, ubuntu-server not installed, unmodified
> /e/d/motd-news
> apt install base-files
> - upgrades b...

Andreas Hasenack (ahasenack) wrote :

I meant, see *also* https://bugs.launchpad.net/bugs/1895302, no idea yet if it's related.

Steve Langasek (vorlon) wrote :

I have amended test case k) to stipulate that we ensure the base ubuntu-cpc image continues to have grub-legacy-ec2 installed. The intended outcome of this change is that all images that currently have grub-legacy-ec2 installed have it, all images that do not have grub-legacy-ec2 installed continue not to have it, and ubuntu-server is present on all images.

description: updated
Changed in livecd-rootfs (Ubuntu Xenial):
status: Triaged → Fix Committed

Hello Andreas, or anyone else affected,

Accepted livecd-rootfs into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/livecd-rootfs/2.408.60 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Cody Shepherd (codyshepherd) wrote :

My attempts to verify test case k) seem to indicate there is still a problem somewhere.

I've verified

i) that grub-legacy-ec2 is no longer in the server seed [1]
iv) that the livecd.ubuntu-cpc.manifest contains grub-legacy-ec2 and ubuntu-server.

However,

ii) the rootfs manifest has not retained ubuntu-server
iii) cpc "secret sauce" hooks which purge grub-legacy-ec2 have not retained ubuntu-server.

The failure of ii) occurred in a livefs-build of the ubuntu-cpc project in the xenial branch livecd-rootfs at version 2.408.61 (02ea8c93).

The failure of iii) occurred in a build of CPC "secret sauce" hooks using the Ubuntu Old Fashioned tool [2] and the same branch/revision of livecd-rootfs described above.

[1] https://git.launchpad.net/~ubuntu-core-dev/ubuntu-seeds/+git/ubuntu/tree/server?h=xenial
[2] https://github.com/chrisglass/ubuntu-old-fashioned

Cody Shepherd (codyshepherd) wrote :

Also as to verification of k.i), I've verified that the "deployed" server seed [1] matches the seed configuration in VCS linked in the last comment.

[1] https://people.canonical.com/~ubuntu-archive/seeds/ubuntu.xenial/server

Cody Shepherd (codyshepherd) wrote :

My initial guess at why this has failed is that the ubuntu-server package appears to still depend on grub-legacy-ec2 [1].

[1] https://packages.ubuntu.com/xenial/ubuntu-server

Cody Shepherd (codyshepherd) wrote :

Ok, I wasn't building from -proposed, I'll try again.

Cody Shepherd (codyshepherd) wrote :

All parts of case k) verified by repeating the steps described above against -proposed.

Steve Langasek (vorlon) on 2020-10-07
tags: added: verification-done-xenial
removed: verification-needed verification-needed-xenial
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-meta - 1.361.6

---------------
ubuntu-meta (1.361.6) xenial; urgency=medium

  * Refreshed dependencies; LP: #1888575.
  * Added motd-news-config to server (via germinate now rather than
    hard-coding, since germinate has managed to pick it up)
  * Removed grub-legacy-ec2 from server [amd64 arm64 armhf i386 powerpc
    ppc64el]

 -- Steve Langasek <email address hidden> Wed, 16 Sep 2020 22:00:18 +0000

Changed in ubuntu-meta (Ubuntu Xenial):
status: Fix Committed → Fix Released
Steve Langasek (vorlon) on 2020-10-07
Changed in livecd-rootfs (Ubuntu Xenial):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.