9.4ubuntu4.9: Broken package because of missing "#" @ /var/lib/dpkg/info/base-files.postinst +131

Bug #1836236 reported by Alexandre on 2019-07-11
94
This bug affects 20 people
Affects Status Importance Assigned to Milestone
base-files (Ubuntu)
Undecided
Unassigned
Xenial
High
Unassigned

Bug Description

Trying to install this on xenial results in:

Setting up base-files (9.4ubuntu4.9) ...
/var/lib/dpkg/info/base-files.postinst: 131: /var/lib/dpkg/info/base-files.postinst: Automatically: not found
dpkg: error processing package base-files (--configure):
 subprocess installed post-installation script returned error exit status 127
Errors were encountered while processing:
 base-files
E: Sub-process /usr/bin/dpkg returned an error code (1)

Because there is a missing comment "#" at the beginning of line 131 of /var/lib/dpkg/info/base-files.postinst, ie:

Automatically added by dh_systemd_start
^-- # ?

description: updated
description: updated
Steve Langasek (vorlon) on 2019-07-11
tags: added: regression-proposed
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in base-files (Ubuntu):
status: New → Confirmed
Tom Reynolds (tomreyn) wrote :

This command was reported to successfully work around this bug:

  sudo sed -i 's/^Automatically/# Automatically/g' /var/lib/dpkg/info/base-files.postinst

It changes any lines starting with "Automatically" into comments, which lets the script finish properly when you run:

  sudo dpkg --configure base-files

Or just run this afterwards:

  sudo apt -f install

Steve Langasek (vorlon) on 2019-07-11
Changed in base-files (Ubuntu):
status: Confirmed → In Progress
Steve Langasek (vorlon) on 2019-07-12
Changed in base-files (Ubuntu):
status: In Progress → Invalid
Changed in base-files (Ubuntu Xenial):
status: New → In Progress
importance: Undecided → High
Changed in base-files (Ubuntu Xenial):
status: In Progress → Fix Released
Changed in base-files (Ubuntu):
status: Invalid → New
Steve Langasek (vorlon) wrote :

Please do not change the triage state of these bug tasks.

Changed in base-files (Ubuntu):
status: New → Invalid
Changed in base-files (Ubuntu Xenial):
status: Fix Released → In Progress

Hello Alexandre, or anyone else affected,

Accepted base-files into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/base-files/9.4ubuntu4.10 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in base-files (Ubuntu Xenial):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-xenial
Changed in base-files (Ubuntu Xenial):
assignee: nobody → shane cody perry (theinsanelunatic5934)
status: Fix Committed → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in base-files (Ubuntu Xenial):
status: New → Confirmed
information type: Public → Private Security
Paul Collins (pjdc) on 2019-07-12
information type: Private Security → Public
Steve Langasek (vorlon) on 2019-07-12
Changed in base-files (Ubuntu Xenial):
assignee: shane cody perry (theinsanelunatic5934) → nobody
status: Confirmed → Fix Committed
Changed in base-files (Ubuntu Xenial):
status: Fix Committed → In Progress
Steve Langasek (vorlon) wrote :

I have asked you not to modify the state of these bug tasks, which are used by the developers to track the progress on this fix.

Changed in base-files (Ubuntu Xenial):
status: In Progress → Fix Committed
Steve Langasek (vorlon) wrote :

Fixed in -proposed:

(Reading database ... 21788 files and directories currently installed.)
Preparing to unpack .../base-files_9.4ubuntu4.10_amd64.deb ...
Unpacking base-files (9.4ubuntu4.10) over (9.4ubuntu4.8) ...
Processing triggers for man-db (2.7.5-1) ...
Not building database; man-db/auto-update is not 'true'.
Setting up base-files (9.4ubuntu4.10) ...
Running in chroot, ignoring request.
/usr/sbin/policy-rc.d returned 101, not running 'start motd-news.service'
Running in chroot, ignoring request.
/usr/sbin/policy-rc.d returned 101, not running 'start motd-news.timer'

Marking this verification-done, and also closing this bug since it was a proposed-only regression.

Changed in base-files (Ubuntu Xenial):
status: Fix Committed → Fix Released
tags: added: verification-done-xenial
removed: verification-needed-xenial
Changed in base-files (Ubuntu):
status: Invalid → Fix Released
tags: removed: verification-needed
Steve Langasek (vorlon) on 2019-07-21
Changed in base-files (Ubuntu):
status: Fix Released → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers