Upgrade to 5.0.0ubuntu20.10.04.6 fails due to date command

Bug #1022198 reported by Swen Kühnlein on 2012-07-08
24
This bug affects 3 people
Affects Status Importance Assigned to Milestone
base-files (Ubuntu)
Undecided
Unassigned
Quantal
Undecided
Unassigned

Bug Description

On my (virtual) machine it is not allowed to change the date, so the upgrade fails:

Richte base-files ein (5.0.0ubuntu20.10.04.6) ...
date: cannot set date: Operation not permitted
So 8. Jul 04:38:07 UTC 2012
dpkg: Fehler beim Bearbeiten von base-files (--configure):
 Unterprozess installiertes post-installation-Skript gab den Fehlerwert 1 zurück
Fehler traten auf beim Bearbeiten von:
 base-files
E: Sub-process /usr/bin/dpkg returned an error code (1)

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: base-files 5.0.0ubuntu20.10.04.6
Uname: Linux 2.6.18-028stab091.2 i686
Architecture: i386
Date: Sun Jul 8 06:35:20 2012
SourcePackage: base-files

Swen Kühnlein (swen) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in base-files (Ubuntu):
status: New → Confirmed
Hugo Vaz (hvaz) wrote :

Same happening here, and very likely to affect a big ammount of persons.

Running on an OpenVZ node.

tags: added: openvz
Hugo Vaz (hvaz) on 2012-07-08
tags: added: amd64
Adam Conrad (adconrad) wrote :

This was reported against a version in -proposed which we chose subsequently to never copy to -updates. Opening a task to SRU this in Quantal, however, where the date call is still there.

Changed in base-files (Ubuntu):
status: Confirmed → Invalid
Changed in base-files (Ubuntu Quantal):
status: New → Confirmed

Hello Swen, or anyone else affected,

Accepted base-files into quantal-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/base-files/6.5ubuntu12 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in base-files (Ubuntu Quantal):
status: Confirmed → Fix Committed
tags: added: verification-needed
Swen Kühnlein (swen) wrote :

Unfortunately I can not test this because the machine in question is (now) running precise and in "production" use.

Adam Conrad (adconrad) wrote :

Verified that the version in quantal-proposed installs, and no longer attempts to call 'date'.

tags: added: verification-done
removed: verification-needed

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package base-files - 6.5ubuntu12

---------------
base-files (6.5ubuntu12) quantal; urgency=low

  * Remove leap-second hack, which causes issues on some VMs: LP: #1022198
  * Migrate /etc/os-release to a conffile, see LP: #947236 for rationale.
 -- Adam Conrad <email address hidden> Tue, 23 Oct 2012 11:16:32 +0100

Changed in base-files (Ubuntu Quantal):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers