base-config: db_fset bug *still* exists

Bug #20039 reported by Debian Bug Importer on 2005-08-19
This bug report is a duplicate of:  Bug #20021: unknown token: db_fset. Edit Remove
6
Affects Status Importance Assigned to Milestone
base-config (Debian)
Fix Released
Unknown
base-config (Ubuntu)
High
Colin Watson

Bug Description

Automatically imported from Debian bug report #323890 http://bugs.debian.org/323890

Debian Bug Importer (debzilla) wrote :

Marking as duplicate based on debbugs merge (323852,323890)

This bug has been marked as a duplicate of bug 20021.

Debian Bug Importer (debzilla) wrote :

Message-Id: <email address hidden>
Date: Fri, 19 Aug 2005 06:47:30 +0200
From: Lukas Ruf <email address hidden>
To: Debian Bug Tracking System <email address hidden>
Subject: base-config: db_fset bug *still* exists

Package: base-config
Version: 2.70
Severity: serious

the bug db_fset *still* exists!

/var/lib/dpkg/info/base-config.postinst: line 59: syntax error near unexpected token `db_fset'
dpkg: error processing base-config (--configure):
 subprocess post-installation script returned error exit status 2

Thanks for fixing.

Lukas
http://www.lpr.ch

-- System Information:
Debian Release: testing/unstable
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: i386 (i686)
Shell: /bin/sh linked to /bin/bash
Kernel: Linux 2.6.12.5-t40p
Locale: LANG=en_IE, LC_CTYPE=en_IE (charmap=ISO-8859-1)

Versions of packages base-config depends on:
ii adduser 3.67 Add and remove users and groups
ii apt 0.6.40.1 Advanced front-end for dpkg
ii bsdutils 1:2.12p-6 Basic utilities from 4.4BSD-Lite
ii console-data 2002.12.04dbs-49 Keymaps, fonts, charset maps, fall
ii console-tools 1:0.2.3dbs-56 Linux console and font utilities
ii debconf 1.4.57 Debian configuration management sy
ii debianutils 2.14.2 Miscellaneous utilities specific t
ii gettext-base 0.14.5-2 GNU Internationalization utilities
ii passwd 1:4.0.3-39 change and administer password and

base-config recommends no packages.

-- debconf information:
  base-config/menu/mta:
* base-config/intro:
  base-config/menu/exit:
  apt-setup/security-updates: true
  apt-setup/another: false
  base-config/title:
  base-config/menu/finish:
  debian-installer/language: en
  base-config/late_command:
  apt-setup/mirror: sunsite.cnlab-switch.ch
  base-config/start-display-manager: true
  base-config/menu/apt-setup:
  base-config/menu/keyboard:
  debian-installer/country: US
  apt-setup/directory: /mirror/debian/
  base-config/install-problem: true
* base-config/pkgsel: tasksel - quickly choose from predefined collections of software
  base-config/menu/hostname:
  apt-setup/cd/another: false
  apt-setup/non-free: false
  apt-setup/badedit:
  mirror/suite: testing
  apt-setup/baddir:
  base-config/menu/pkgsel:
  base-config/menu/apt-get:
  base-config/menu/timezone:
  base-config/menu/debconf-seed:
  base-config/menu/intro:
  base-config/menu/passwd:
  apt-setup/hostname: sunsite.cnlab-switch.ch
  base-config/menu/pon:
* base-config/login:
  apt-setup/title:
  mirror/http/proxy:
  apt-setup/contrib: false
  base-config/main-menu: Finish configuring the base system
  base-config/early_command:
  apt-setup/cd/dev: /dev/cdrom
  apt-setup/country: Switzerland
  debian-installer/keymap: sg-latin1
  apt-setup/badsource:
  base-config/use-ppp: false
  apt-setup/uri_type: ftp
  apt-setup/not-mirror:
  base-config/get-hostname: uccellina
  apt-setup/security-updates-failed:
  apt-setup/cd/missing:
  base-config/menu/shell:
  apt-setup/cd/bad:
  base-config/invalid-hostname:

Debian Bug Importer (debzilla) wrote :

Message-Id: <email address hidden>
Date: Thu, 18 Aug 2005 22:36:36 -0700
From: Steve Langasek <email address hidden>
To: <email address hidden>
Subject: severity of 323852 is grave, merging 323852 323863, severity of 323887 is grave ... ... ...

# Automatically generated email from bts, devscripts version 2.9.4
severity 323852 grave
merge 323852 323863
severity 323887 grave
merge 323852 323887
severity 323890 grave
merge 323852 323890

Debian Bug Importer (debzilla) wrote :

Message-ID: <email address hidden>
Date: Thu, 18 Aug 2005 22:35:21 -0700
From: Steve Langasek <email address hidden>
To: Lukas Ruf <email address hidden>, <email address hidden>
Subject: Re: Bug#323890: base-config: db_fset bug *still* exists

--8P1HSweYDcXXzwPJ
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable

Version: 2.71

On Fri, Aug 19, 2005 at 06:47:30AM +0200, Lukas Ruf wrote:
> Package: base-config
> Version: 2.70
> Severity: serious

> the bug db_fset *still* exists!

No, it doesn't. This bug is fixed in base-config 2.71, available from
incoming.debian.org.

--=20
Steve Langasek Give me a lever long enough and a Free OS
Debian Developer to set it on, and I can move the world.
<email address hidden> http://www.debian.org/

--8P1HSweYDcXXzwPJ
Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: Digital signature
Content-Disposition: inline

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.1 (GNU/Linux)

iD8DBQFDBW+ZKN6ufymYLloRAp3kAKCRV5yzpUVDxHcL6nWqeLGKqaaxCgCfdq6I
VkbuWItyTDXJDq9GgJJi4eg=
=JJxQ
-----END PGP SIGNATURE-----

--8P1HSweYDcXXzwPJ--

Debian Bug Importer (debzilla) wrote :

Message-ID: <email address hidden>
Date: Fri, 19 Aug 2005 08:07:43 +0200
From: Lukas Ruf <email address hidden>
To: <email address hidden>
Subject: Re: Bug#323890 acknowledged by developer (Re: Bug#323890: base-config: db_fset bug *still*
 exists)

> Debian Bug Tracking System <email address hidden> [2005-08-19
> 07:53]:
>
> This is an automatic notification regarding your Bug report #323890:
> base-config: db_fset bug *still* exists, which was filed against the
> base-config package.
>
> It has been closed by one of the developers, namely Steve Langasek
> <email address hidden>.
>
> Content-Type: text/plain; charset=us-ascii Content-Disposition:
> inline Content-Transfer-Encoding: quoted-printable
>
> Version: 2.71
>
> On Fri, Aug 19, 2005 at 06:47:30AM +0200, Lukas Ruf wrote:
> > Package: base-config Version: 2.70 Severity: serious
>
> > the bug db_fset *still* exists!
>
> No, it doesn't. This bug is fixed in base-config 2.71, available
> from incoming.debian.org.
>

today at around 06h am (CET), I run the usual update/upgrade cycle on
my latop.

there, the following message appeared:

grave bugs of base-config (2.69 -> 2.70) <done>
 #323863 - base-config: line 59: syntax error near unexpected token `db_fset'
Summary:
 base-config(1 bug)

Now, run the same update/upgrade cycle and get the same message on
another box.

But I see: the "done" message appears alread for 2.69 -> to 2.70
although the bug has been fixed obviously only in 2.71.

Hence, my reporting was caused by the message already for 2.69 ->
2.70 although it's been fixed for 2.70 -> 2.71.

So, when base-config 2.71 will have made its way from
incoming.debian.org to the repository for common update/upgrade, the
bug will disappear -- most presumably.

Thanks!

wbr,
Lukas
--
Lukas Ruf <http://www.lpr.ch> | Ad Personam
rbacs <http://wiki.lpr.ch> | Restaurants, Bars and Clubs
Raw IP <http://www.rawip.org> | Low Level Network Programming
Style <http://email.rawip.org> | How to write emails

Debian Bug Importer (debzilla) wrote :

Message-Id: <email address hidden>
Date: Thu, 18 Aug 2005 23:21:35 -0700
From: Steve Langasek <email address hidden>
To: <email address hidden>
Subject: merging 323852 323887, merging 323852 323890

# Automatically generated email from bts, devscripts version 2.9.4
merge 323852 323887
merge 323852 323890

Debian Bug Importer (debzilla) wrote :

Message-ID: <email address hidden>
Date: Fri, 19 Aug 2005 03:21:36 -0700
From: Steve Langasek <email address hidden>
To: Yolker <email address hidden>, <email address hidden>,
 Carlos =?iso-8859-1?Q?Gonz=E1lez?= <email address hidden>,
 <email address hidden>, moi <email address hidden>, <email address hidden>
Subject: Re: Bug#323897: base-config: unable to upgrade to 2.70 (syntax error)

--qDbXVdCdHGoSgWSk
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable

severity 323897 grave
close 323897 2.71
merge 323897 323852
severity 323907 grave
close 323907 2.71
merge 323907 323852
severity 323926 grave
close 323926 2.71
merge 323926 323852
thanks

These are all duplicate reports of a bug that has already been fixed in
base-config 2.71, which has been uploaded and is currently available in
incoming.debian.org. Please check the list of existing bugs at
bugs.debian.org before reporting new bugs.

--=20
Steve Langasek Give me a lever long enough and a Free OS
Debian Developer to set it on, and I can move the world.
<email address hidden> http://www.debian.org/

--qDbXVdCdHGoSgWSk
Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: Digital signature
Content-Disposition: inline

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.1 (GNU/Linux)

iD8DBQFDBbKvKN6ufymYLloRAsuiAJ4hCYy5lU0ibVY80lt5G4lShwGHGwCdGExc
zZryDexlUnmdN3rZ4oriNXg=
=FQzr
-----END PGP SIGNATURE-----

--qDbXVdCdHGoSgWSk--

Debian Bug Importer (debzilla) wrote :

Message-Id: <email address hidden>
Date: Fri, 19 Aug 2005 13:56:49 -0400
From: Joey Hess <email address hidden>
To: <email address hidden>
Subject: severity of 323926 is normal

# Automatically generated email from bts, devscripts version 2.9.5
severity 323926 normal

Debian Bug Importer (debzilla) wrote :

Message-ID: <email address hidden>
Date: Sat, 20 Aug 2005 01:21:15 +0200
From: Adeodato =?utf-8?B?U2ltw7M=?= <email address hidden>
To: <email address hidden>, <email address hidden>
Cc: <email address hidden>
Subject: Re: Bug#323870: Error in package base_config

# Hello. This bug is already fixed in base-config 3.71. Thanks.

reassign 323870 base-config
close 323870 3.71
merge 323870 323852
thanks

* Storm66 [Fri, 19 Aug 2005 01:28:01 +0200]:

> Package: base_config
> Version: 2.70

> Error in postinst script :
> ============================ Original end of script ==============
> for q in mirror/suite mirror/http/proxy apt-setup/uri_type \
> apt-setup/country apt-setup/mirror apt-setup/hostname \
> apt-setup/directory apt-setup/baddir
> apt-setup/not-mirror \
> apt-setup/cd/dev apt-setup/cd/bad apt-setup/cd/another \
> apt-setup/non-free apt-setup/contrib apt-setup/badsource \
> apt-setup/another apt-setup/badedit \
> apt-setup/security-updates \
> apt-setup/security-updates-failed \
> do
> db_fset $q seen false || true
> done
> ============================ Corrected end of script ==================
> for q in mirror/suite mirror/http/proxy apt-setup/uri_type \
> apt-setup/country apt-setup/mirror apt-setup/hostname \
> apt-setup/directory apt-setup/baddir
> apt-setup/not-mirror \
> apt-setup/cd/dev apt-setup/cd/bad apt-setup/cd/another \
> apt-setup/non-free apt-setup/contrib apt-setup/badsource \
> apt-setup/another apt-setup/badedit \
> apt-setup/security-updates \
> apt-setup/security-updates-failed
> do
> db_fset $q seen false || true
> done

> Regards

> JP Pozzi

--
Adeodato Simó
    EM: asp16 [ykwim] alu.ua.es | PK: DA6AE621
    Listening to: Miguel Bosé - Amor entero

Beauty, brains, availability, personality: pick any two.

Debian Bug Importer (debzilla) wrote :

Message-Id: <email address hidden>
Date: Sat, 20 Aug 2005 18:41:17 +0200
From: Petter Reinholdtsen <email address hidden>
To: <email address hidden>
Subject: postinst bug fixed in version 2.71

severity 323937 normal
close 324038 2.71
close 324034 2.71
close 323937 2.71
merge 324038 323852
merge 324034 323852
merge 323937 323852
thanks

Already reported and fixed in version 2.71

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.