Merge barry 0.15-1 (universe) from Debian testing (main)

Bug #426716 reported by agent 8131 on 2009-09-09
34
This bug affects 4 people
Affects Status Importance Assigned to Milestone
barry (Debian)
Fix Released
Undecided
Unassigned
barry (Ubuntu)
Wishlist
Unassigned
Declined for Karmic by Brian Murray

Bug Description

Debian testing has 0.15 available. It would be nice to see that version in 9.10 as it might some of the reported bugs.

Related branches

Artur Rona (ari-tczew) on 2009-09-09
tags: added: upgrade
David Rubin (drubin) wrote :

#449661 [1] contains reasoning for upgrading to 0.15.

[1] https://bugs.edge.launchpad.net/ubuntu/+source/barry/+bug/449661

Artur Rona (ari-tczew) wrote :

Is there a good reason for getting barry 0.15 into karmic?

David Rubin (drubin) wrote :

@artur
It has bjavaloader included in it, which is the only package that allows you to install Blackberry applications onto a Blackberry device from linux. Also see the duplicate report linked above I explain the reasoning.

Artur Rona (ari-tczew) wrote :

I guess that problem should be resolved in Debian first, then sync into universe. If 0.16 will be released (@unstable) after karmic's final, we can request SRU.

David Rubin (drubin) wrote :

This seems to be in unstable.
http://packages.debian.org/sid/barry-util "Package: barry-util (0.15-1 and others)"
it is at 0.15 which is the version that contains bjavaloader so this version would satisfy this bug report.

Artur Rona (ari-tczew) wrote :

I'm not confident to this version, because I found bug report: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=548317 so I wrote that problem should be resolved first in Debian. But OK, current barry 0.15-1 is available on my-ppa. Please test it and give feedback.

Bhavani Shankar (bhavi) wrote :
Changed in barry (Ubuntu):
status: New → Confirmed
Artur Rona (ari-tczew) wrote :

 barry (0.15-1) unstable; urgency=low

   * New Upstream Version
     + Adds support for Curve 8900 (Closes: #524677)
   * Ack NMU. Thanks to Cyril Brulebois for it.
   * Updated patches:
      - fix-ftbfs-with-new-boost.diff: deleted, fixed upstream.
      - fix-ftbfs-with-gcc-4.4.diff: updated
   * debian/rules:
     + Install udev files from its new location.
     + Use .conf for modprobe config files (Closes: #518571)
   * debian/barry-util.install: do not try to install removed bs11nread util

 -- Jose Carlos Garcia Sogo <email address hidden> Sat, 29 Aug 2009 22:57:03 +0200

Changed in barry (Debian):
status: New → Fix Released
summary: - Upgrade to 0.15
+ Merge barry 0.15-1 (universe) from Debian testing (main)
tags: added: merge
removed: upgrade
Changed in barry (Ubuntu):
assignee: nobody → Fabrice Coutadeur (fabricesp)
importance: Undecided → Wishlist
status: Confirmed → In Progress
Fabrice Coutadeur (fabricesp) wrote :

Hi,

I miss 2 changes in debian/rules: why can they be dropped? Could you explain?

Thanks,
Fabrice

Changed in barry (Ubuntu):
assignee: Fabrice Coutadeur (fabricesp) → nobody
status: In Progress → Confirmed
Bhavani Shankar (bhavi) wrote :

They are incorporated in debian in a different way

cf:

* debian/rules:
     + Install udev files from its new location.
     + Use .conf for modprobe config files (Closes: #518571)

Regards

David Rubin (drubin) wrote :

Sorry could some one explain where these changes were merged to? I understand they wont be included into Karmic but lucid still seems to have 14.1 http://packages.ubuntu.com/lucid/barry-util

Thanks

Artur Rona (ari-tczew) wrote :

Hello David,
Bhavani's debdiff wasn't yet uploaded.

David Rubin (drubin) wrote :

Thanks Artur.

I was just making sure these were going into Lucid.

Changed in barry (Ubuntu):
assignee: nobody → Fabrice Coutadeur (fabricesp)
status: Confirmed → In Progress
Fabrice Coutadeur (fabricesp) wrote :

Uploaded. Thanks for your contribution!

Could you please forward to Debian the changes in barry-util.preinst and barry-util.postinst, to see if they adopt them.

Thanks,
Fabrice

Changed in barry (Ubuntu):
assignee: Fabrice Coutadeur (fabricesp) → nobody
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package barry - 0.15-1ubuntu1

---------------
barry (0.15-1ubuntu1) lucid; urgency=low

  * Merge from debian testing (LP: #426716), remaining changes:
    - debian/barry-util.preinst:
      + Remove old rules,path if unmodified
    - debian/barry-util.postinst:
      + Otherwise move to new path
    - debian/control:
      + Update udev dependency
 -- Bhavani Shankar <email address hidden> Fri, 06 Nov 2009 17:54:31 +0530

Changed in barry (Ubuntu):
status: Fix Committed → Fix Released
Changed in barry (Ubuntu):
status: Fix Released → In Progress
David Rubin (drubin) wrote :

I don't see it either. I assume the debian version doesn't have bjavaloader in it either?

This was the main reason for upgrading to 0.15 :(

The RPM source dir in the debian package lists the bjavaloader./
rpm/barry.spec
%attr(0755,root,root) %{_bindir}/bjavaloader on line 216 is there no way to port this to debian packaging to include bjavaloader in the newer version of barry-utils I assume this is only like this because when it was 0.14 there wasn't a bjavaloader binary generated.

Thanks

Fabrice Coutadeur (fabricesp) wrote :

To keep things clear, I've reported the missing binaries in a separate bug (#503687) and will close this one.

thanks,
Fabrice

Changed in barry (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.