All files in Banshee end with a comma

Bug #99938 reported by James on 2007-04-01
8
Affects Status Importance Assigned to Milestone
Banshee
Fix Released
Medium
banshee (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: banshee

When I add audio files/folder into Banshee, all of the following end with a comma:

1. Artist Name
2. Album
3. Song title

Daniel T Chen (crimsun) wrote :

This symptom only affects MPEG 1-Layer III (mp3) files for me, and I can reproduce it in Rhythmbox. I'm inclined to think it's actually a bug somewhere lower in the build-dep stack...

I'll double-check, but I don't think it was doing it in Rhythmbox for me.

On 4/2/07, Daniel T Chen <email address hidden> wrote:
> This symptom only affects MPEG 1-Layer III (mp3) files for me, and I can
> reproduce it in Rhythmbox. I'm inclined to think it's actually a bug
> somewhere lower in the build-dep stack...
>
> --
> All files in Banshee end with a comma
> https://bugs.launchpad.net/bugs/99938
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Chris Halse Rogers (raof) wrote :

This bug affects all mp3s I've downloaded from emusic. It's triggered by files using standard-breaking null-termination of ID3v2 tags, making taglib think there's another field.

I've attached this to the upstream bug. There's a patch attached to that bug; I'll try to get a debdiff with that patch up soon.

Changed in banshee:
status: Unknown → Confirmed
Chris Halse Rogers (raof) wrote :

Attached debdiff adds the patch from Gnome bugzilla. It fixes all my MP3 imports, and the (4 line) patch looks like it can't break anything.

Daniel T Chen (crimsun) on 2007-04-03
Changed in banshee:
status: Unconfirmed → Fix Committed
James (chiisu81) wrote :

The newest update to Banshee in Feisty (Banshee 0.12.0+dfsg-1ubuntu3) seems to have fixed this issue. :)

Chris Halse Rogers (raof) wrote :

Fixed package has been in the archive for a while :).

Changed in banshee:
status: Fix Committed → Fix Released
Changed in banshee:
status: Confirmed → Incomplete
Changed in banshee:
status: Incomplete → Fix Released
Changed in banshee:
status: Fix Released → Confirmed
Changed in banshee:
status: Confirmed → Fix Released
Changed in banshee:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.