Playback: "Stop When Finished" becomes deactivated after one song

Bug #987682 reported by Jakob on 2012-04-24
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
banshee (Ubuntu)
Undecided
Unassigned

Bug Description

I choose "Playback" → "Stop When Finished". Then I play a song. After this song it stops as expected. Then I play another song. But now it doesn't stop, but plays one song after another. Also, the option "Stop When Finished" is unchecked.

When reproducing this, mind that you have to let play the first song until the end. The problem doesn't appear when choosing the next song manually by clicking "next".

In other words: "Stop When Finished" only works once, but IMHO should be getting activated as a constant option.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: banshee 2.4.0-2ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-23.36-generic-pae 3.2.14
Uname: Linux 3.2.0-23-generic-pae i686
NonfreeKernelModules: nvidia
ApportVersion: 2.0.1-0ubuntu6
Architecture: i386
Date: Tue Apr 24 09:38:18 2012
EcryptfsInUse: Yes
SourcePackage: banshee
UpgradeStatus: Upgraded to precise on 2012-03-21 (33 days ago)

Jakob (jodsalz2000-launchpad) wrote :

On 24/04/2012 15:51, Jakob wrote:
> Public bug reported:
>
> I choose "Playback" → "Stop When Finished". Then I play a song. After
> this song it stops as expected. Then I play another song. But now it
> doesn't stop, but plays one song after another. Also, the option "Stop
> When Finished" is unchecked.
>
> When reproducing this, mind that you have to let play the first song
> until the end. The problem doesn't appear when choosing the next song
> manually by clicking "next".
>
> In other words: "Stop When Finished" only works once, but IMHO should be
> getting activated as a constant option.

I believe this is intended behaviour. Typically you would activate this option
while playing something just before locking your screen and moving away from
your computer (e.g. to allow the current song to finish while going to sleep).

Upon resuming playback again, you would most probably prefer the playback to
continue past one song, i.e. using normal behaviour, rather than the "Stop when
finished" behaviour.

  status invalid

--
Kind regards,
Loong Jin

Changed in banshee (Ubuntu):
status: New → Invalid
ladenedge (ladenedge) wrote :

I would think a permanent single-song play mode would work just as well for the "falling asleep and need only one song played" use case. Switching the playback mode when you resume your work doesn't seem like too much to ask.

ladenedge (ladenedge) wrote :

Also, the fact that there is a command line argument for this feature suggests to me that at least someone thought it should be a permanent setting for the given instance. It's hard to imagine any use cases for the command line arg if the existing behavior is intended..?

On 24/04/2012 22:39, ladenedge wrote:
> Also, the fact that there is a command line argument for this feature
> suggests to me that at least someone thought it should be a permanent
> setting for the given instance. It's hard to imagine any use cases for
> the command line arg if the existing behavior is intended..?

Not necessarily. --stop-when-finished is for changing the option of the
currently running Banshee instance, e.g. for scripts, or for loading a single
file into Banshee.

--
Kind regards,
Loong Jin

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers