Ubuntu

Banshee crashes when mounting Motorola Xoom

Reported by Timo Ohr on 2011-10-17
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
banshee (Ubuntu)
Undecided
Unassigned

Bug Description

Starting with 11.10, Banshee (2.2.0-1ubuntu2) consistently gets a SIGSEGV when I try to mount my Motorola Xoom. Probably due to it not having a media-player-info file. Heres the log:

-------------------------------

[Info 12:19:23.988] Running Banshee 2.2.0: [Ubuntu oneiric (development branch) (linux-gnu, x86_64) @ 2011-09-23 04:47:58 UTC]

(Banshee:5412): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

(Banshee:5412): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

(Banshee:5412): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

(Banshee:5412): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",
[Info 12:19:24.888] Updating web proxy from GConf
[Warn 12:19:24.989] Failed to load media-player-info file for 1
[Info 12:19:25.014] All services are started 0.821546
** (Banshee:5412): DEBUG: SyncDaemon already running, initializing SyncdaemonDaemon object

(Banshee:5412): libsoup-WARNING **: No feature manager for feature of type 'U1RequestChrome'
[Info 12:19:25.990] AmazonMP3 store redirect URL: https://one.ubuntu.com/music/store/amz/
[Info 12:19:26.448] nereid Client Started
[Info 12:19:26.559] GStreamer version 0.10.35.0, gapless: True, replaygain: True
[Warn 12:19:26.607] Failed to load media-player-info file for 1

** (Banshee:5412): CRITICAL **: itdb_get_control_dir: assertion `mountpoint' failed
Device 0 (VID=22b8 and PID=70a9) is a Motorola Xoom (ID 2).
[Warn 12:19:26.850] Failed to load media-player-info file for 1
[Warn 12:19:28.405] Failed to load media-player-info file for 1
Stacktrace:

  at (wrapper managed-to-native) object.__icall_wrapper_mono_string_new_wrapper (intptr) <0xffffffff>
  at (wrapper unknown) Mtp.FolderStruct.PtrToStructure (intptr,object) <0xffffffff>
  at (wrapper runtime-invoke) <Module>.runtime_invoke_void_intptr_object (object,intptr,intptr,intptr) <0xffffffff>
  at (wrapper managed-to-native) System.Runtime.InteropServices.Marshal.PtrToStructure (intptr,System.Type) <0xffffffff>
  at Mtp.Folder.GetRootFolders (Mtp.MtpDevice) <0x0007b>
  at Mtp.MtpDevice.GetRootFolders () <0x0000f>
  at Mtp.MtpDevice.SetDefaultFolders () <0x00027>
  at Mtp.MtpDevice..ctor (Mtp.MtpDeviceHandle,Mtp.MtpDeviceStruct) <0x0004f>
  at Mtp.MtpDevice.Connect (Mtp.RawMtpDevice) <0x001af>
  at Banshee.Dap.Mtp.MtpSource.DeviceInitialize (Banshee.Hardware.IDevice) <0x0040b>
  at Banshee.Dap.DapService.FindDeviceSource (Banshee.Hardware.IDevice) <0x000f0>
  at Banshee.Dap.DapService/MapDeviceJob.Run () <0x00723>
  at Banshee.Kernel.Scheduler.ProcessJobThread () <0x00173>
  at System.Threading.Thread.StartUnsafe () <0x0007e>
  at (wrapper runtime-invoke) object.runtime_invoke_void__this__ (object,intptr,intptr,intptr) <0xffffffff>

Native stacktrace:

 banshee() [0x4911ea]
 banshee() [0x4e064f]
 banshee() [0x41b187]
 /lib/x86_64-linux-gnu/libpthread.so.0(+0x10060) [0x7f39623a3060]
 /lib/x86_64-linux-gnu/libc.so.6(+0x128bef) [0x7f396211cbef]
 banshee(mono_string_new+0x1c) [0x56178c]
 [0x412791ba]

Debug info from gdb:

Could not attach to process. If your uid matches the uid of the target
process, check the setting of /proc/sys/kernel/yama/ptrace_scope, or try
again as the root user. For more details, see /etc/sysctl.d/10-ptrace.conf
ptrace: Operation not permitted.
No threads.

=================================================================
Got a SIGSEGV while executing native code. This usually indicates
a fatal error in the mono runtime or one of the native libraries
used by your application.
=================================================================

Aborted

Timo Ohr (timo-ohr) wrote :
Download full text (4.5 KiB)

It doesn't seem to get mounted as a regular drive, though. Nautilus accesses it using the following location: "gphoto2://[usb:002,013]/". There is no mount point in "/media". Other devices, like the Galaxy S2, get mounted as regular usb hard drives and seem to work fine with Banshee.

It does work for the most part in Nautilus though, even though I can't seem to access or copy certain files. I don't really care whether Banshee can access the device, as long as it doesn't crash as soon as I connect it.

Here is the log after adding a valid .is_audio_player file:
-------------------------

[Info 12:34:28.830] Running Banshee 2.2.0: [Ubuntu oneiric (development branch) (linux-gnu, x86_64) @ 2011-09-23 04:47:58 UTC]

(Banshee:6632): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

(Banshee:6632): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

(Banshee:6632): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

(Banshee:6632): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",
[Info 12:34:29.739] Updating web proxy from GConf
[Warn 12:34:29.844] Failed to load media-player-info file for 1
[Info 12:34:29.868] All services are started 0.834626
** (Banshee:6632): DEBUG: SyncDaemon already running, initializing SyncdaemonDaemon object

(Banshee:6632): libsoup-WARNING **: No feature manager for feature of type 'U1RequestChrome'
[Info 12:34:30.825] AmazonMP3 store redirect URL: https://one.ubuntu.com/music/store/amz/
[Info 12:34:31.309] nereid Client Started
[Info 12:34:31.401] GStreamer version 0.10.35.0, gapless: True, replaygain: True
[Warn 12:34:31.454] Failed to load media-player-info file for 1

** (Banshee:6632): CRITICAL **: itdb_get_control_dir: assertion `mountpoint' failed
Device 0 (VID=22b8 and PID=70a9) is a Motorola Xoom (ID 2).
ignoring usb_claim_interface = -16ignoring usb_claim_interface = -22PTP_ERROR_IO: failed to open session, trying again after resetting USB interface
LIBMTP libusb: Attempt to reset device
[Warn 12:34:31.653] Failed to load media-player-info file for 1
inep: usb_get_endpoint_status(): Device or resource busy
outep: usb_get_endpoint_status(): Device or resource busy
usb_clear_halt() on IN endpoint: Device or resource busy
usb_clear_halt() on OUT endpoint: Device or resource busy
usb_clear_halt() on INTERRUPT endpoint: Device or resource busy
ignoring usb_claim_interface = -16ignoring usb_claim_interface = -22LIBMTP PANIC: failed to open session on second attempt
[Warn 12:34:32.668] Failed to load media-player-info file for 1
Stacktrace:

  at (wrapper managed-to-native) object.__icall_wrapper_mono_string_new_wrapper (intptr) <0xffffffff>
  at (wrapper unknown) Mtp.FolderStruct.PtrToStructure (intptr,object) <0xffffffff>
  at (wrapper runtime-invoke) <Module>.runtime_invoke_void_intptr_object (object,intptr,intptr,intptr) <0xffffffff>
  at (wrapper managed-to-native) System.Runtime.InteropServices.Marshal.PtrToStructure (intptr,System.Type) <0xffffffff>
  at Mtp.Folder.GetRootFolders (Mtp.MtpDevice) <0x00083>
  at Mtp.MtpDevice.GetRootFolders () <0x0000f>
  at Mtp.MtpDevice.SetDefaultFolders () <0x00027>
  at Mtp.MtpD...

Read more...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers